Windows ATM services

Asynchronous transfer mode (ATM) is a set of standard networking technologies that can be used to build high-speed networks that guarantee quality of service (QoS) for connections. Windows ATM services software provided with Windows 2000 allows you to participate in ATM networks if you have ATM adapter hardware installed on your computer.

  • Before you begin using ATM with this computer, see Checklist: Installing ATM services.
  • For tips about using ATM, see Best practices.
  • For help with specific tasks, see How to.
  • For general background information, see Concepts.
  • For problem-solving instructions, see Troubleshooting.


Checklist: Installing ATM services

Step | Reference
Review ATM concepts such as cells, the ATM model, and ATM QoS. | Understanding ATM
Review LAN emulation (LANE), if necessary. | LAN emulation
Review TCP/IP over ATM, if necessary. | IP over ATM (IP/ATM)
Install an ATM adapter on this computer. | To install an ATM adapter
Configure the LAN emulation client, if necessary. | To configure a LAN emulation client
Set up IP/ATM connections and install and configure the ATM ARP/MARS service, if necessary. | To enable a simple TCP/IP-over-ATM connection; To install and configure the ATM ARP/MARS service
Configure permanent virtual connections (PVCs). | To create a permanent virtual connection using ATM
Troubleshoot ATM connections. | Troubleshooting


Best practices

  • Use the default ELAN.
    Windows 2000 ATM services are configured with a default unspecified_ELAN_name group name. If you plan to implement LAN emulation, it is recommended that you use the preconfigured default unspecified ELAN.

    When you purchase an ATM switch, check the product specifications to ensure that it is preconfigured with the default unspecified ELAN group name.

  • Use supported ATM adapters.
    Before you buy an ATM adapter for use with Windows 2000, be certain that it is on the Hardware Compatibility List. For more information, see the list at the Microsoft Web site.
  • Upgrading from Windows NT 4.0 to Windows 2000
    Before upgrading from Windows NT 4.0 to Windows 2000, note the following configuration information for each of the LAN emulation clients you plan to upgrade.
    • The ELAN name
    • The media type to be emulated on the LAN
    • ATM addresses for the LES and BUS associated with the ELAN
    • The maximum allowable packet size for the ELAN

    After you note these configuration parameters, use the LECS interface on your ATM switch to configure ELANs and their associated parameters, as listed and noted above.

    Next, install Windows 2000 and configure the ELAN name for each LEC. For information about configuring the ELAN name, see To configure a LAN emulation client.

  • Use only one ATM ARP/MARS per virtual LAN.
    If your network uses IP/ATM, it is recommended that you configure only one ATM ARP/MARS for each virtual LAN on your network. If you have multiple ARP servers on the same network segment, and your ARP client is configured with the addresses for these servers, the ARP caches could become out of synch. This can render parts of the network unreachable.


How to...

  • Install an ATM adapter
  • Configure a LAN emulation client
  • Enable a simple TCP/IP-over-ATM connection
  • Configure an advanced TCP/IP-over-ATM connection
  • Install and configure the ATM ARP/MARS service
  • Create a permanent virtual connection using ATM
  • View ATM connection information


Concepts

This section provides general background information about asynchronous transfer mode (ATM) technologies that are available in Windows 2000.

  • ATM overview
  • Understanding ATM
  • Using ATM
  • Resources


ATM overview

This section covers:

  • ATM defined
  • Windows ATM services defined
  • Benefits of ATM


ATM defined

Asynchronous transfer mode (ATM) refers to a number of related technologies, including software, hardware, and connection media. ATM differs from other existing LAN and WAN technologies and was specifically designed to support high-speed communication. ATM allows networks to use bandwidth resources at maximum efficiency while maintaining quality of service (QoS) for users and programs with strict service requirements.

The basic components of ATM are end stations, computers connected to the ATM network, and ATM switches, the devices responsible for connecting end stations and ensuring that data is transferred successfully.

Basic ATM components

Asynchronous means the available network bandwidth is not divided into fixed channels or slots synchronized by a timing mechanism or clock. Devices that communicate using asynchronous communication are not bound by design in terms of their ability to send and receive information at a precise transmission rate. Instead, the sender and receiver negotiate the rate at which they will communicate based on physical hardware limitations and the ability to maintain a reliable flow of information within the network.

Transfer mode refers to the way the information is transferred between sender and receiver. In ATM, the concept of small, fixed-length cells is used to structure and parcel data for transfer. By using cells that contrast directly with the variable-length packet mechanism used by most existing network technologies, ATM assures that connections can be negotiated and managed so that no single data type or connection can monopolize the transfer path.


Windows ATM services defined

  • An ATM UNI Call Manager that conforms to ATM Forum specifications for signalling over ATM and supports the creation of switched virtual circuits (SVCs) and permanent virtual circuits (PVCs).
  • Updated NDIS 5.0 ATM miniport drivers tested by Windows Hardware Quality Laboratories that provide limited support for installed ATM adapter hardware.
  • A LAN emulation client module that conforms to the ATM Forum LANE 1.0 specification, enabling existing programs and protocols designed for use on Ethernet and Token Ring networks to run without modification over an ATM network.
  • An ARP/MARS service that enables the Microsoft TCP/IP stack to resolve ATM addresses to hardware addresses for more direct and efficient use of ATM media. The IP-over-ATM module conforms to RFC specifications for Address Resolution Protocol (ARP) over ATM media, as well as support for a Multicast Address Resolution Service (MARS).
  • Enhanced support for TAPI-based applications and services.
  • Support for raw channel access filtering that can be used in application environments that include DirectStreaming.
  • Expanded Network and Dial-up Connections support for PPP dial-up over ATM media, enabling you to create and use a PPP dial-up connection over any supported ATM adapter that is installed in Windows 2000. This feature provides support for ATM over DSL, ATM over cable modem, and other ATM on-demand connectivity possibilities.
  • Access to native ATM services with Winsock 2.0 over ATM. Available through the Windows Sockets ATM Service Provider, Winsock 2.0 allows direct access to ATM services from user-mode programs. It also allows programs that use TCP/IP as a transport protocol to run over ATM networks and interoperate with standard LAN-based IP clients.


Benefits of ATM

ATM provides a flexible and scalable solution to the increasing need for quality of service in networks where multiple information types (such as data, voice, and real-time video and audio) are supported. With ATM, each of these information types can pass through a single network connection.

ATM can provide the following benefits:

  • High-speed communication
  • Connection-oriented service, similar to traditional telephony
  • Fast, hardware-based switching
  • A single, universal, interoperable network transport
  • A single network connection that can reliably mix voice, video, and data
  • Flexible and efficient allocation of network bandwidth


Understanding ATM

Asynchronous transfer mode (ATM) refers to a number of related and standardized technologies designed to provide high-speed network communication. For more information on these technologies, see the following sections:

  • ATM cells
  • The ATM model
  • ATM networks
  • Example: Switched connection (SVC)
  • Example: Permanent connection (PVC)
  • ATM quality of service (QoS)
  • LAN emulation
  • IP over ATM (IP/ATM)


ATM cells

ATM cells have a fixed length of 53 bytes. Using fixed-length cells, information can be transported in a predictable manner. This predictability accommodates different traffic types (video, voice, data) on the same network.

The 53 bytes of the ATM cell are broken into two principal sections:

The ATM cell
  • The header (5 bytes) is the addressing mechanism, defining how the cell is switched.
  • The payload (48 bytes), also called the user information field, is the portion that carries the actual information (voice, data, or video).

By using a payload length of 48 bytes for data, ATM offers a compromise between a larger cell size (such as 64 bytes) optimized for data, and a smaller cell size (such as 32 bytes) optimized for voice.


The ATM model

The protocol reference model used for ATM is taken from a model that was developed by the International Telecommunication Union (ITU) for Broadband-Integrated Services Digital Network (B-ISDN). Because ATM is the transport mode used for B-ISDN, this model applies directly to ATM and is often used as the protocol model to describe it.

The ATM protocol model consists of both planes and layers, as shown in the following figure.

The ATM protocol model

The ATM protocol reference model

The ATM model consists of three planes:

  • The user plane defines how ATM transports user information across the network.
  • The control plane performs connection administration, such as call setup and call teardown, using signalling for switched ATM services.
  • The management plane maintains the network and carries out operational functions. This plane is further subdivided into layer management and plane management to manage the different layers and planes.

Protocols of the control plane and the user plane include the following layers: the physical layer, ATM layer, ATM adaptation layer, and additional higher-layer protocols. The three bottom layers are required and should appear in all related ATM hardware and software products. The higher-layer protocols of the ATM model include other layers offered for translation and encapsulation and may be selectively implemented by users or only provided in some ATM products.

Physical layer

The physical layer defines how cells are mapped onto a physical medium for transmitting and receiving between ATM hardware devices.

ATM layer

The ATM layer describes how cells are transported through the network and how quality of service is enforced so that connections operate within their contracted service levels. At this layer, the ATM layer also uses information in each 5-byte cell header to determine a number of possible actions that can be taken.

The ATM layer provides:

  • Creation of cells.
  • Multiplexing and demultiplexing of cells.
  • Managing of cell flow and sequencing.
  • Handling of dropped cells.
  • Switch-based routing using virtual paths and virtual circuits.

ATM adaptation layer

The ATM adaptation layer (AAL) is where user information is created and received as 48-byte payloads.

The adaptation layer resolves any disparity between services provided by the cell-based technology of the ATM layer to the bit-stream technology of digital services (such as telephones and video cameras) and the packet-stream technology of traditional data networks (such as Frame relay and X.25 used in WANs and LAN protocols such as Ethernet and TCP/IP).

The International Telecommunication Union (ITU) first determined the need to provide several standard AALs (classes of service) to satisfy the requirements of encapsulating different information types into ATM layer cells.

The following table describes each of the AALs specified by the ITU along with the intended purpose for each of the proposed layers.

The ATM adaptation layers

Layer | Description
AAL1 | Supports circuit emulation using ATM cells for traditional voice, T1, and T3 carrier services. AAL1 uses two methods: structured data transfer (SDT) and synchronous residual time stamp (SRTS). Requirements include a constant bit rate and connection-oriented, isochronous (time-dependent) service.
AAL2 | Supports packet-based video and other time-dependent applications that can use variable bit rate. AAL2 is not currently defined by the ATM standards.
AAL3/4 | Supports multiplexing of data streams, including connection-oriented and connectionless services. AAL3/4 was used in early ATM implementations but is no longer favored because of additional overhead cost resulting from the segmentation and reassembly (SAR) sublayer. The SAR header and SAR trailer are each 2 bytes long, effectively reducing available cell payload for data to 44 bytes.
AAL5 | Designed to support efficient transport of LAN traffic. Widely implemented today in most ATM products.

Note

  • In practice, AAL5 is the adaptation layer used most often, offering the best performance when compared to other AALs for LAN traffic.

Upper layers

The upper layers of the ATM protocol reference model include optional protocol layers that are used to further encapsulate ATM service for use with TCP/IP and other protocols.

Some examples of upper-layer protocols include those specified by RFC 1483 (multiprotocol encapsulation over AAL5) and RFC 1577 (classical IP over ATM).


ATM networks

ATM networks are made up of three distinct elements: users (endpoint devices), switches, and interfaces.

In ATM networking, two types of interfaces exist to describe how these elements communicate: user-to-network interfaces (UNIs) and network-to-network interfaces (NNIs).

The UNI and NNI specifications provide a standard signalling method for end stations and ATM switches to communicate.

UNI and NNI signalling

Note

  • The Windows ATM services Call Manager currently supports ATM Forum UNI 3.1. For more information about Windows ATM services, see Windows ATM services defined


Example: Switched connection (SVC)

The following example shows in detail how an SVC connection is established in an ATM network.

Establishing an SVC

  1. An ATM user, End station A, sends a SETUP message on the virtual channel connection reserved for signalling (VPI=0, VCI=5) to its directly connected ATM switch, ATM switch 1.

    The SETUP message contains:

    • The 20-byte ATM address of End station B.
    • Quality of service (QoS) parameters needed for connection.

  2. ATM switch 1 analyzes the SETUP message to determine whether it can find a table entry for End station B's switch address and whether it can support the required QoS parameters for the requested connection.

    If ATM switch 1 can find End station B's switch address and support the required QoS parameters for connection, a CALL PROCEEDING message is sent back to End station A.

    If ATM switch 1 either cannot find End station B's switch address or accommodate the connection, a RELEASE message containing standard error codes is sent back to End station A and the call request is rejected.

  3. ATM switch 1 sends the SETUP message (described in Step 1) on the virtual channel connection reserved for signalling (VPI=0, VCI=5) to the next switch in the network, ATM switch 2, on its way to the destination, End station B.

    The SETUP message contains the same ATM address of End station B and all required QoS parameter information as included in Step 1. Additionally, the SETUP message now identifies a new VPI/VCI pair for use between ATM switch 1 and ATM switch 2.

  4. ATM switch 2 receives the SETUP message. End station B is determined to be a directly connected endpoint registered to ATM switch 2. If the QoS required for the requested connection can be accommodated, ATM switch 2 sends a CALL PROCEEDING message back to ATM switch 1.
  5. The SETUP message reaches its final destination, End station B. End station B can respond in either of two ways:
    • If End station B accepts the call, it sends a CALL PROCEEDING message, followed immediately by a CONNECT message back to ATM switch 2.
    • If End station B rejects the call, it sends a RELEASE message back to ATM switch 2. The RELEASE message is passed through the network back to the original source user (End station A) containing standard error codes that describe the reason for rejection.
  6. ATM switch 2 sends a CONNECT ACK message back to End station B, then passes the CONNECT message to ATM switch 1.
  7. ATM switch 1 sends a CONNECT ACK message back to ATM switch 2, then passes the CONNECT message to End station A.
  8. End station A sends a CONNECT ACK message back to ATM switch 1.

Note

  • The previous example demonstrates a simplified SVC connection using only two intermediate switches, ATM switch 1 and ATM switch 2. In practice, most SVC connections use many intermediate switches. When more intermediate switches are used, each switch forwards SETUP, CONNECT, and RELEASE messages to its downstream neighbor switch, while relaying acknowledgment messages (CONNECT ACK, RELEASE ACK) back to its upstream neighbor switch.

The result of this connection process is a virtual circuit (VC) in both directions between End stations A and B in which:

  • All intermediate switches and ATM user hardware at End stations A and B now support and protectively enforce the QoS communication parameters required for this connection.
  • All intermediate switches (in this case, ATM switches 1 and 2) have been programmed with switch table entries for mapping the series of VPI/VCI pairs used for routing ATM cells between End stations A and B.

Important

  • If any intermediate switch cannot accommodate the requested QoS connection parameters, a RELEASE message is sent back in the direction of the source user. The RELEASE message contains the standard error codes and frees the resources being reserved at each device in the connection path and at the source.


Example: Permanent connection (PVC)

Besides using switching and call message signalling to create circuits on demand between any two possible users, you can also permanently configure an ATM virtual circuit between any two specified service endpoints on an ATM network.

PVCs are used extensively by public ATM service providers to create and establish a complex ATM-based infrastructure for their internal networks. In many cases, the internal ATM infrastructure of the network is built using PVCs with actual end-to-end connections occurring over SVCs.

PVCs can also be useful in some private ATM networks where the following types of situations exist:

  • A large campus LAN migrating to a higher-speed ATM backbone. In backbone configurations, connections typically represent a few static configurable switch paths that infrequently change, so permanent configuration of ATM circuits is acceptable.
  • A small WAN with a limited number of sites, each requiring a continuous, dedicated high-speed connection that guarantees a fixed quality of service between site locations. With a circuit permanently established, the ATM switches at both WAN sites do not require the added latency and overhead of using call signalling or connection setup and teardown each time ATM cell traffic data is sent over the network. Sent data can be directly forwarded over PVCs established between each site.


ATM quality of service (QoS)

In an ATM network, quality of service (QoS) is used to assure consistently good results for all network users. ATM performs QoS by using three general approaches when servicing any connection:

  • When a required level of connection service quality is needed, ATM guarantees and enforces that the required level of service is met by all devices providing the connections.
  • When a preferred quality of service is requested for a connection, ATM attempts to acquire resources where available throughout the network to accommodate the requested level of service, while preserving and maintaining service guarantees for connections that require them.
  • When quality of service is unspecified for a connection, ATM attempts to use available network resources in a best-effort attempt to provide a form of service similar to what is available in other LAN/WAN transfer modes.

ATM service categories

ATM service categories have been established by combining and using defined ATM QoS parameters in several ways. All ATM connections fit into one of these four service categories. The service category is indicated indirectly as a result of VPI/VCI information in each ATM cell header. Switches use the VPI/VCI to determine priority for any given cell within the connection stream whenever connections that use differing service categories are multiplexed.

To control the various types of network traffic, ATM standards were modified to define the types of services most commonly used. The four general ATM service categories are listed below.

Service category Description
Constant bit rate (CBR)
  • Connections requiring a guaranteed continuous rate of transfer, such as real-time voice or video.
  • Connections that will tolerate only minimal transfer delays, such as circuit emulation for leased lines and T1 or T3 carrier services. Circuit emulation is a traffic stream of modulated pulse codes sent at regularly spaced intervals.
Variable bit rate (VBR)
  • Connections that require a lower bounded rate (such as their minimum rate of transfer), but can tolerate variation at their upper bounded rate (such as their maximum rate of transfer) to permit periods of burst transfer to occur.
  • Support for variable-speed connections with different time delay requirements that require minimal cell loss.
Available bit rate (ABR)
  • Connections not requiring a guaranteed rate of transfer, such as file transfer and e-mail.
  • Connections that are generally more tolerant of highly unpredictable or burst traffic patterns, such as ATM interconnection with emulated Ethernet and Token Ring LANs.
Unspecified bit rate (UBR)
  • Connections requiring route establishment but no guaranteed commitment of bandwidth, such as batch file transfers and lower priority bulk e-mail.
  • Connections for programs that have no delivery constraints and perform their own error checking and flow control.


LAN emulation

LAN emulation (LANE) is a group of software components that support the use of legacy applications and network protocols (Ethernet and Token Ring) over an ATM network.

LANE provides the following benefits:

  • Support for attaching traditional LANs over an ATM high-speed backbone network
  • Support for existing LAN protocols and interfaces over ATM
  • The ability to translate and resolve ATM addresses to LAN addresses

This section covers:

  • Overview of LANE services
  • How LANE works
  • LANE components
  • ATM LANE broadcast to Ethernet and Token Ring LANs


Overview of LANE services

LAN emulation services are needed to provide interoperability at Layer 2 of the OSI Protocol reference model (data-link layer) between users of ATM and traditional LAN environments.

This interoperability allows ATM network users to communicate with users on traditional LAN technologies, such as Ethernet and Token Ring, by way of an emulated LAN (ELAN).

The emulated LAN provides interconnection with traditional LANs through the following architecture and functions:

  • Mapping and translation of ATM addressing to traditional media access control addressing used in Ethernet and Token Ring LANs.
    When an ATM address is sent by an ATM user device, the address must be mapped and translated to the media access control address in the format used by IEEE 802.x-type LANs, such as Ethernet and Token Ring LANs. The media access control address identifies the specific adapter hardware used on these LANs.

    The translation also occurs when an Ethernet or Token Ring device sends data to an ATM network user. The media access control address for the ATM user is first used to send the data and then requires translation to an ATM address before the data can be passed on to the ATM network.

  • Translation between traditional LAN framing and ATM cell structures.
    Ethernet and Token Ring LANs use frames as the basic unit of transfer in communicating data through the network. ATM requires fixed-length 53-byte cells as the unit of transfer. This fundamental difference requires a frame-to-cell and cell-to-frame translation for data to be exchanged successfully between ATM and traditional LAN environments.
  • The ability to perform address registration and discovery, and to interpret LAN broadcast packets to and from an ATM environment.
    Traditional LAN environments use broadcast and multicast packets to perform many integral functions required for network communication. Some examples of the service provided by these functions could include a new device attempting to register its presence on the network or a user attempting to locate another device on the network.

    Functions such as broadcast and multicast do not correspond to the ATM connection-based model, requiring new techniques for interpreting these types of LAN user requests to comparable service in an ATM environment.


How LANE works

The general stages of LAN emulation over ATM are:

  • Client startup
    The LAN emulation client (LEC) initializes and configures itself through interaction with its local ATM switch and the LAN emulation configuration server (LECS), obtaining the address for its LAN emulation server (LES).

    • There are three ways a LEC can attempt to connect to the LECS:

    1. It can try the well-known ATM address defined in the ATM protocol.
    2. It can use the well-known VC defined in the ATM protocol.
    3. It can query using the integrated layer management interface (ILMI).

  • Client registration
    The LAN emulation client (LEC) connects to its LANE server and begins the process of joining a specific emulated LAN.
  • Address resolution
    Resolution of the media access control address to an ATM address is performed.
  • Data transfer
    Once the ATM address is determined using a LANE address resolution query, the LANE client creates a switched virtual circuit, and data transfer can begin.

Example: LANE client startup and registration

The following example details each step in establishing a LANE connection for a single LANE client:

  1. The client obtains its own ATM address by interacting with its local switch.
  2. The client contacts the LANE configuration server using a preconfigured or well-known ATM address or VC. If either of these fail, the client uses ILMI.
  3. The LANE configuration server replies to the client with the name of its emulated LAN and the ATM address for its LANE server.
  4. Using the ATM address provided by the LECS, the LEC initiates a connection to the LANE server.
  5. The client sends a LANE address resolution request (LE-ARP) to locate the broadcast unknown server (BUS).
  6. The LANE server responds with the ATM address of the BUS.
  7. The client sets up connections for multicasting to the BUS.

Once the LANE client has completed startup and registration on the ELAN, it is ready for broadcasting and multicasting to resolve addresses.

LANE broadcasting and multicasting

A broadcast or multicast is typically done to resolve a logical address (server name or IP address) to its media access control address. The process of broadcasting and multicasting over an ELAN follows two different methods:

Broadcasting and multicasting in an ELAN
  1. An ARP broadcast or multicast packet is sent from an ELAN client to the BUS.
  2. The BUS forwards the broadcast to all attached client devices in the ELAN. If one of these client devices is an edge device, the broadcast can be carried onto an Ethernet or Token Ring LAN. For detailed information, see ATM LANE broadcast to Ethernet and Token Ring LANs.


LANE components

The LANE 1.0 protocol specification defines the components required to create a single emulated LAN. These components provide LANE service in one of the following typical configurations:

  • For intermediate networks, Ethernet and Token Ring LANs can be connected over an ATM backbone network.
  • ATM users can communicate using LANE with Ethernet and Token Ring users or other ATM users on the same emulated LAN.

Note

  • Multiple ELANs can exist on a single ATM network without conflict. However, each ELAN supports connectivity only between an ATM network and a single traditional (Ethernet or Token Ring) LAN environment. LANE cannot serve as a gateway between Ethernet and Token Ring LANs.

These four LANE components are used to provide service in either of the configurations:

  • LAN emulation client (LEC)
    The LEC is generally implemented in ATM end system computers. Also, it is sometimes in ATM switches through either software (as part of the ATM device driver) or hardware (the specific ATM adapter card or ATM switch hardware).

    • The LEC forwards data between the ATM and traditional LAN environments and processes LAN broadcasts and address resolution for the client system. For address resolution, the LEC is jointly identified by two addresses: its ATM address when communicating to the ATM network and a media access control address when communicating with the Ethernet or Token Ring LAN.

  • LAN emulation server (LES)
    The LES is used to provide control functions required for all clients within a single emulated LAN. Functions include registration of media access control addresses for new LECs, resolution of media access control addresses to ATM addresses for existing LECs, and maintenance of a mapped pairing of ATM addresses-to-media access control addresses for all ELAN member devices.
  • LAN emulation configuration server (LECS)
    The LECS is responsible for assigning LAN emulation clients to specific emulated LANs. When a client requests configuration information for joining an emulated LAN, the LECS supplies the ATM address of the LAN emulation server (LES) for the emulated LAN.

    • Clients are directed to an appropriate LES based on either their physical location (as interpreted by analyzing the client ATM address) or on the identity of a particular destination LAN. The configuration server can, as an option, allow a client to configure and directly assign itself to a specific LES and emulated LAN. There is only one LECS for each internetwork and it serves all LAN emulation clients within it.

  • Broadcast and unknown server (BUS)
    The BUS is used to handle broadcast, multicast, and unknown traffic between clients on both emulated and traditional LANs. The BUS handles all emulated LAN client broadcasts to the broadcast media access control address of "FF-FF-FF-FF-FF-FF". Each client is associated with a single BUS, identified by a unique ATM address, and located within a particular ELAN.

Note

  • The LANE protocol specification does not specify where these components must be implemented in ATM products. Beginning with Windows 2000, Microsoft has implemented a LAN emulation client module that is installed during ATM hardware installation. Other LANE server components such as LES, LECS, and BUS are typically implemented with ATM switching hardware.


ATM LANE broadcast to Ethernet and Token Ring LANs

In an emulated local area network (LAN) connected to an Ethernet or Token Ring LAN by a LAN switch (edge device), a broadcast or multicast is typically done to resolve a logical address (server name or IP address) to its media access control address. The process of broadcasting and multicasting over an ELAN to an Ethernet or Token Ring LAN follows two different methods:

Broadcasting from an ATM environment to an Ethernet or Token Ring LAN that uses media access control addressing

  1. An ARP broadcast or multicast packet is sent from an ELAN client to the BUS.
  2. The BUS forwards the broadcast to all attached client devices in the ELAN.
  3. A broadcast packet is also forwarded across the LAN switch, or edge device, which interconnects the ATM network with the Ethernet or Token Ring LAN.

Returning an ARP reply for a specific media access control address from an Ethernet or Token Ring LAN back to an ATM environment

  1. Broadcasts from Ethernet and Token Ring nodes are passed back through the LAN switch to the BUS on the ATM network.
  2. The BUS processes the broadcast for the ELAN clients on the ATM network.
  3. An ARP reply packet is sent from the BUS to the ELAN client that initiated the ARP request. The response to the broadcast or multicast query contains the media access control address.

LANE address resolution

Once the response to a broadcast or multicast query contains the desired media access control address for an ELAN client, the following address resolution is needed to obtain the ATM address:

  1. The LANE client creates a LANE address resolution request (LE-ARP) and sends it to the LANE server.
  2. If the LANE server recognizes the media access control address, it replies to the LE-ARP request with the corresponding ATM address.
  3. If the LANE server does not recognize the media access control address, it forwards the LE-ARP request to other LANE clients (LAN switches) that act as proxies.
  4. The LAN switch checks its stored table of media access control addresses that are available on the non-ATM LAN.
  5. If the LAN switch, which proxies the LE-ARP request, responds with a matching media access control address for a non-ATM client device located on the Ethernet or Token Ring network, it responds by sending its ATM address back to the LANE client on the ATM network.


IP over ATM (IP/ATM)

  • IP/ATM overview
  • How IP/ATM works
  • IP/ATM components


IP/ATM overview

IP/ATM is a group of services for communicating over an ATM network that can be used as an alternative to LAN emulation. IP/ATM is handled by two main components: the IP/ATM client and the IP/ATM server. The IP/ATM server includes an ATM ARP server and a multicast address resolution server (MARS). IP/ATM network components can reside on a server or an ATM switch.

The main advantage of using IP/ATM is that it is faster than LANE. With IP/ATM, no additional header information is added to packets as they move through the protocol stack. Once an IP/ATM client has established a connection, data can be transferred without modification.

IP/ATM supports the use of a Dynamic Host Configuration Protocol (DHCP) server in the ATM network.


How IP/ATM works

The three general stages of IP/ATM operation are:

  • Client initialization
  • Client registration
  • Data transfer

IP/ATM client startup and registration with a static IP address

The following example describes each step in establishing an IP/ATM connection for a single IP/ATM client with a static IP address:

Client registration
  1. Client A initializes and gets an ATM address from the ATM switch.
  2. Client A connects to the ATM ARP/MARS server and joins the broadcast group. Client A's IP-to-ATM address mapping is added to the ATM ARP server database.
  3. Client A contacts Client B, an ATM end station connected to the network, and begins data transfer.

IP/ATM client startup and registration with DHCP

The following example describes each step in establishing an IP/ATM connection for a single IP/ATM client obtaining an IP address using Dynamic Host Configuration Protocol (DHCP):

  1. The client initializes and gets an ATM address from the ATM switch.
  2. The client connects to the ATM ARP/MARS server and joins the broadcast group.
  3. The client connects to the multicast server and sends a DHCP request. The multicast server broadcasts the DHCP request to all members of the broadcast group. The DHCP server receives the request.
  4. The DHCP server sends a DHCP reply to the multicast server, which then broadcasts the reply to the broadcast group.
  5. The client receives the DHCP reply and then registers its IP and ATM addresses with the ATM ARP/MARS server.
  6. The client is now ready to contact other hosts and begin data transfer.

Note

  • For more information about DHCP, see DHCP.

Broadcasting and multicasting

A broadcast or multicast is used to establish point-to-multipoint connections between the requesting client and multiple end stations on the network. The process of broadcasting and multicasting on IP/ATM can follow two different methods:

  • Direct point-to-multipoint connection

    If a client needs to send an IP packet to a broadcast or multicast IP address, it sends a request to the MARS to resolve the IP address to a list of clients. The MARS sends a group of addresses to a client, allowing it to set up a point-to-multipoint connection.

  • Point-to-multipoint connection through a multicast server

    The MARS can also work with a multicast server. The Windows ATM ARP/MARS has an integrated multicast server, which registers one or more multicast groups with the MARS and receives a list of members in each multicast group from the MARS. The MARS updates the multicast server when clients join or leave a multicast group. When a client makes a multicast or broadcast request to the MARS, the MARS returns only the address of the multicast server. The client contacts the multicast server, which creates a point-to-multipoint connection with the multicast group. The multicast server copies and distributes the packets sent by the client that initiated the point-to-multipoint call to end stations on the multicast list.


IP/ATM components

IP/ATM is a group of services including an IP/ATM client, and ATM ARP and MARS servers.

IP/ATM client

The IP/ATM client resides on an end station with an ATM adapter installed. It contains the mechanism, usually a configured address, for contacting the MARS to register with a multicast group.

ATM ARP

The ATM ARP server maintains a database of IP and ATM addresses of all clients on the network, resolving multicast and broadcast IP addresses to ATM addresses. ATM ARP only supports unicast traffic, allowing the client to set up point-to-point connections with other end stations.

MARS

The multicast address resolution server (MARS) maintains a database of broadcast and multicast addresses to all members of the network. The MARS can pass a list of addresses directly to a client so that the client can set up a point-to-multipoint call. If a multicast server is available, the MARS can pass the address of the multicast server to the client. In this case, the client contacts the multicast server and the multicast server creates a point-to-multipoint connection and distributes the packets to the end stations.

Note

  • The ATM ARP/MARS server with an integrated multicast server is shipped with Windows 2000 Server.


Using ATM

This section covers:

  • ATM addressing
  • Configuring LAN emulation
  • Creating switched connections
  • Creating permanent connections
  • Modifying ATM defaults
  • Well-known addresses


ATM addressing

ATM addresses are needed to support the use of switched virtual connections (SVCs) through an ATM network.

At the simplest level, ATM addresses are 20 bytes long and have three distinct parts:

  • Network prefix
    The first 13 bytes identify the location of a specific switch in the network. The use of this portion of the address can vary considerably depending on its address format. Each of the three standard ATM addressing schemes provides information about ATM switch locations differently. These schemes include the data country/region code (DCC) format, the international code designator (ICD) format, and the E.164 format proposed by the ITU-T for international telephone numbering use in broadband ISDN networks.
  • Adapter media access control address
    The next 6 bytes identify a physical endpoint, such as a specific ATM adapter card, using a media access control layer address that is physically assigned to the ATM hardware by its manufacturer. The use and assignment of media access control addresses for ATM hardware are identical to how this addressing works for Ethernet, Token Ring, and other IEEE 802.x technologies.
  • Selector (SEL)
    The last byte is used to select a logical connection endpoint on the physical ATM adapter. Although all ATM addresses fit this basic three-part structure, there are significant differences in the exact format of the first 13 bytes, depending on the addressing format or whether the ATM network is for public or private use.

All of the three ATM address formats that are currently in widespread use (DCC, ICD, and E.164) include the following characteristics:

  • They comply with the Network Service Access Point (NSAP) addressing plan as proposed by the Open Standards Interconnection (OSI) protocol suite of the International Standards Organization (ISO).
  • Each can be used to establish and interconnect privately built ATM networks that support switched virtual connections (SVCs).


Configuring LAN emulation

The basic services for an emulated LAN reside on the ATM switch and workstations with ATM hardware installed. An edge device is required if you plan to connect an Ethernet or Token Ring network to your emulated LAN.

LANE component | Where the component resides
LANE services | The LES, LECS, and BUS typically reside on the ATM switch.
LAN emulation client | The LAN emulation client can reside on workstations, ATM switches, and edge devices.

Services

Most of the configuration for LAN emulation is done on the switch running the LAN emulation services. These services include the LAN emulation server (LES), LAN emulation configuration server (LECS), and the broadcast unknown server (BUS). For more information about configuring the LANE services on your ATM switch, see the documentation for your ATM switch. For more information about these services, see LANE components.

Client

The LAN emulation client (LEC) software resides on workstations, ATM switches, and edge devices. The LAN emulation client is integrated in Windows 2000, and is installed by default if you have an ATM network adapter installed on your computer. After installation is complete, you can install and configure any network protocol driver that works over Ethernet or Token Ring, such as TCP/IP, NetBEUI, or IPX/SPX. For information about installing and configuring network protocols on your ATM ELAN connection, see To configure a connection. For more information about configuring the LAN emulation client, see To configure a LAN emulation client.


Creating switched connections

Switched connections are processed by the Windows 2000 ATM Call Manager, which handles virtual circuit creation and management. The ATM ARP client and the LAN emulation client support switched virtual circuits (SVCs). Both the LAN emulation client and ATM ARP client are based on the ATM Forum UNI specification.

LAN emulation with SVCs

The Windows LAN emulation client uses SVCs by default. The client must be configured with a valid emulated LAN name to use SVCs. For more information, see To configure a LAN emulation client.

IP/ATM with SVCs

The Windows ATM ARP client uses SVCs by default. The ATM ARP client must be configured with the address of the ATM ARP/MARS on the subnet. For more information, see To configure an advanced TCP/IP-over-ATM connection.


Creating permanent connections

Permanent virtual connections (PVCs) are typically used by large service providers or in campus backbones to maintain virtual connections in an ATM network.

The Windows 2000 ATM Call Manager is used to manually set up permanent virtual connections (PVCs) in an emulated LAN or in an IP/ATM network. Use the ATM Call Manager to define the properties for each PVC, including the PVC definition, application usage, and advanced properties.

PVC property | Description
PVC definition | Define the name, virtual path ID, virtual circuit ID, and ATM adaptation layer (AAL).
Application usage | Define the application type for use with the PVC, and the basic call-matching characteristics of this PVC.
Advanced properties | Define the quality of service (QoS) transmit and receive parameters, and specific layer protocols for call matching and answer matching.

For more information, see To create a permanent virtual connection using ATM.


Modifying ATM defaults

When you install an ATM adapter on your computer, the default LAN emulation client configuration for Windows 2000 ATM services is automatically installed. The LAN emulation client is preconfigured to use the following default emulated LAN (ELAN) group name:

<unspecified ELAN name>

The unspecified_ELAN_name is a default ELAN group name configured for use with Windows ATM services and by other vendors of ATM switching products. It enables simplified configuration of the ATM LAN emulation client service provided with computers running Windows 2000, with ATM switches that might be providing LAN Emulation services for your network.

Where the unspecified ELAN name is not currently configured or supported by default by other ATM hardware products (such as other switches used on your network), you can do one of the following:

  • Add another supported ELAN name to the list maintained here.
  • Configure the unspecified ELAN name on your ATM switches that provide LAN emulation service to your network.

For more information about changing the settings of your LAN emulation client, see To configure a LAN emulation client.


Well-known addresses

LANE well-known addresses

Windows LAN emulation clients (LEC) are preconfigured with the well-known ATM address and virtual channel defined in the ATM Forum specification for obtaining the LECS server address. The LEC uses these addresses in the following order:

  1. It can try the well-known LECS address defined in the ATM protocol.

4700790000000000000000000000A03E00000100
  2. It can use the well-known virtual channel defined in the ATM protocol.
  3. It can query using the integrated layer management interface (ILMI).

IP/ATM preconfigured address

Windows ATM ARP clients are preconfigured with the ARP/MARS addresses of Windows ATM services. This address is:

4700790001020000000000000000A03E00000200

This number is a well-known E.164 address that Microsoft has selected to simplify configuration and enhance interoperability of the ATM ARP/MARS with other Windows 2000 computers running ATM services.


Resources

This section covers:

  • ATM standards
  • ATM updated technical information
  • ATM bibliography


ATM standards

There are three major groups defining implementation standards for ATM in networks: the ATM Forum, the IETF, and the ITU-T.

ATM Forum

The ATM Forum is an international not-for-profit group of ATM hardware manufacturers, network software developers, and network service providers, consisting of workgroups that develop and review ATM specifications.

For more information about the ATM Forum and access to ATM Technical Committee specifications, see the ATM Forum Web site.(http://www.atmforum.com)

Internet Engineering Task Force (IETF)

The IETF is the standards organization for the Internet. Within the IETF, the IETF IP-over-ATM working group developed standards for IP traffic over ATM networks. The following chart lists RFCs for implementing IP over ATM.

RFC | Description
1483 | Multiprotocol encapsulation over ATM adaptation layer 5
1722 | RIP version 2 protocol applicability statement
1754 | IP over ATM Working Group's Recommendations for the ATM Forum's Multiprotocol BOF - Version 1
1755 | ATM Signaling Support for IP over ATM
2022 | Support for Multicast over UNI 3.0/3.1 based ATM Networks
2225 | Classical IP and ARP over ATM (makes obsolete RFC 1626 and RFC 1577)

For more information about the IETF and the RFCs regarding IP over ATM, see the IETF Web site.(http://www.ietf.org)

International Telecommunication Union, Telecommunication Standardization Sector (ITU-T)

The ITU-T defines standards for global telecommunication and services. The ITU-T developed B-ISDN and SONET for broadband transport services.

For additional information about the ITU-T and ITU-T recommendations, see the ITU-T Web site.(http://www.itu.int)

Note


ATM updated technical information

The Personal Support Center at the Microsoft Web site provides additional information about ATM. See Updated technical information.


ATM bibliography

For additional information, refer to the following texts:

Gadecki, K., and C. Heckart. 1997. ATM for Dummies. Foster City: IDG Books Worldwide, Inc.

Ferguson, P., and G. Huston. 1998. Quality of Service: Delivering QoS on the Internet and in Corporate Networks. New York: John Wiley and Sons, Inc.

ATM User-Network Interface (UNI) Specification, ATM Forum, Inc., Foster City: Prentice Hall, Inc.


Troubleshooting

What problem are you having?

Host cannot join an emulated LAN.

Cause: The client and switch must be running a user network interface (UNI) based on parameters outlined in ATM Forum UNI 3.1 or 4.0 specifications. Otherwise, the initial point-to-multipoint (PMP) call setup fails and no connection is made. The Windows 2000 LAN emulation client (LEC) is based on the ATM Forum UNI 3.1 specification.

Solution: Use the Atmadm utility to determine if the setup call is failing. The Atmadm utility is used to monitor connections and addresses registered by the ATM Call Manager on an asynchronous transfer mode (ATM) network. You can use it to display statistics for incoming and outgoing calls on ATM adapters. If Atmadm displays few or no packets received on signalling and ILMI VCs, check your switch connectivity. For example:

Signaling and ILMI packets sent     = 90718
Signaling and ILMI packets received = 0

See also: To view ATM connection information and Atmadm examples.

Hosts on my IP/ATM network are unreachable.

Cause: If you have more than one ATM ARP/MARS for each virtual LAN on your network, the ARP caches can become out of synch. This causes clients to be able to only contact clients registered with the same server. Clients registered with another server are unreachable.

Solution: Only use one ATM ARP/MARS for each virtual LAN.

A hardware error occurs when my ATM adapter attempts to initialize.

Cause: Your ATM adapter is running IP/ATM and LAN emulation (LANE) on the same subnet.

Solution: IP/ATM and LAN emulation (LANE) must be configured to run on separate subnets.