Novell NetWare integration

You can use tools provided with the Windows 2000 operating system to access resources on Novell NetWare networks:

  • Before you install the NWLink IPX/SPX/NetBIOS Transport Protocol (NWLink), see Checklist: Installing and configuring NWLink.
  • Before you install Gateway Service for NetWare, see Checklist: Installing and configuring Gateway Service for NetWare.
  • To find features that have been moved in Windows 2000 Server, see New ways to do familiar tasks.
  • For tips about using NWLink, see Best practices for NWLink.
  • For tips about using Gateway Service for NetWare, see Best practices for Gateway Service for NetWare.
  • For help with specific tasks, see How to.
  • For general background information, see Concepts.
  • For problem-solving instructions, see Troubleshooting.


Checklists

This section covers:

  • Checklist: Installing and configuring NWLink
  • Checklist: Installing and configuring Gateway Service for NetWare


Checklist: Installing and configuring NWLink

Step | Reference
Review concepts. | The NWLink IPX/SPX/NetBIOS Compatible Transport Protocol
Review hardware requirements. | Hardware requirements for Network and Dial-up Connections
Log on as a user in the Administrators group.
Install NWLink.

Note

  • NWLink is installed for all network connections.
 To install NWLink
Set the frame type.

Note

  • This step is for advanced users. New users should accept the default values unless told otherwise by their administrator.
 To configure NWLink
Set the external network number and internal network number.

Note

  • This step is for advanced users. New users should accept the default values unless told otherwise by their administrator.
 To configure NWLink
Enable/disable the Routing Information Protocol (RIP).

Notes

  • RIP for IPX is enabled by default.
  • This step is for advanced users. New users should accept the default values unless told otherwise by their administrator.
 To enable RIP on an interface


Checklist: Installing and configuring Gateway Service for NetWare

Step | Reference
Review concepts. | Gateway Service for NetWare
Log on as a user in the Administrators group.
Review hardware requirements. | Hardware requirements for Network and Dial-up Connections
Install Gateway Service for NetWare.

Notes

  • The NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) is installed when you install Gateway Service for NetWare.
 To install Gateway Service for NetWare
Set the default tree and context or, if you do not use Novell Directory Services (NDS), the preferred server. To set a preferred server;
To set a default tree and context
Set print options. | To set print options
On the computer running NetWare server software, create a group and a user account that will be available through the gateway. | Creating a gateway
On the computer running Windows 2000 Server, remove any existing other network service or client software. | Novell or other product documentation
Enable the gateway. | To enable a gateway on the server
Activate the gateway. To activate a gateway to a NetWare file resource;
To activate a gateway to a NetWare printer
Change the NetWare passwords. To change your password on a NetWare bindery server;
To change your password on a NetWare NDS tree
Set logon script options. | Using logon scripts


New ways to do familiar tasks

This table lists common tasks for interoperating with Novell NetWare in Windows 2000. The user interface for performing these tasks is different in Windows 2000 than it was in Windows NT 4.0.

If you want to | In Windows NT 4.0 use | In Windows 2000 use
Install and configure NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) | Network in Control Panel | Network and Dial-up Connections. For more information, see To install NWLink and To configure NWLink.
Install Gateway Service for NetWare (Windows 2000 Server) or Client Service for NetWare (Windows 2000 Professional) | Network in Control Panel | Network and Dial-up Connections. For more information, see To install Gateway Service for NetWare.
Enable or disable NWLink NetBIOS | Network in Control Panel | Network and Dial-up Connections. For more information, see To enable direct hosting of IPX.


Best practices

This section covers:

  • Best practices for NWLink
  • Best practices for Gateway Service for NetWare


Best practices for NWLink

The following list provides some best practices for the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink):

  • If you do not know what the internal network number should be set to, accept the default value of 00000000.

    • You can determine what internal network number your routers are using by typing ipxroute config at a command prompt.

    For more information about setting the internal network number, see To configure NWLink.

  • Use automatic frame type detection.

    • You should choose to have the frame type automatically detected rather than setting this value manually. If you must use manual frame type detection, determine what type of frame type you should use before you start configuring NWLink by typing ipxroute config at a command prompt. In addition, verify that all the server computers on your network that use IPX/SPX are using the same frame type.

    For more information, see To configure NWLink.

  • Specify the order that Windows 2000 accesses network providers and protocols.

    • By changing your provider order, and by changing the order of protocols bound to those providers, you can improve performance. For example, if your LAN connection is enabled to access NetWare and Microsoft Windows networks and uses TCP/IP and IPX, but your primary connection is to a NetWare network, you can move NetWare or Compatible Network to the top of the Network providers list on the Provider Order tab, and move NWLink IPX/SPX/NetBIOS Compatible Transport Protocol to the top of the File and Printer Sharing for Microsoft Networks binding on the Adapters and Bindings tab.

    For more information about modifying the order of network providers, see To modify the network provider order. For more information about modifying protocol bindings, see To modify the protocol bindings order.

  • Only install and enable the network protocols that you need.
    • Limiting the number of protocols on your computer enhances network performance and reduces network traffic.
    • If Windows 2000 encounters a problem with network connectivity, it attempts to establish connectivity by using every network protocol that is installed. By only installing and enabling the protocols that your system can use, Windows 2000 does not attempt to connect with protocols it cannot use, and returns status information to you more efficiently.
  • When using direct hosting, if you cannot access a server computer running Windows 95 or Windows 98 from a computer running Windows 2000 Professional, you must enable NetBIOS over IPX/SPX on the computer running Windows 95 or Windows 98.

    • For more information, see the Windows 95 or Windows 98 documentation.

  • When you use NWLink to connect computers running Windows 2000 that use Windows-based networking, ensure that NetBIOS broadcast propagation (type 20 packets) is enabled on all the router interfaces that connect the computers running Windows 2000.

    • You can enable NetBIOS broadcast propagation by using Routing and Remote Access. NetBIOS broadcast propagation is enabled by default.


Best practices for Gateway Service for NetWare

The following list provides some best practices for Gateway Service for NetWare and, where noted, Client Service for NetWare:

  • When connecting to NetWare resources, use Client Service for NetWare for frequent access or Gateway Service for NetWare for less frequent access.

    • If the client computers on your network need infrequent access to NetWare resources, you should use Gateway Service for NetWare rather than Client Service for NetWare. If you use Gateway Service for NetWare to provide a gateway to NetWare resources, you do not have to install the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) on client computers. Therefore, you can more easily optimize your network. However, for frequent access to NetWare resources, you should install Client Service for NetWare on the client computers.

  • When running Novell Directory Services (NDS) administrative utilities on Windows 2000 Professional, you must use NetWare client software.
  • If you need user-level security, use Client Service for NetWare.

    • Gateway Service for NetWare cannot provide user-level security; it provides share-level security.

  • When changing a user's NetWare password, synchronize the password for both NetWare and Windows 2000 resources.

    • You can use the Change Password dialog box that is available by pressing CTRL+ALT+DELETE. User names and passwords should be the same for all NetWare servers.

  • When connecting to NetWare resources on NDS trees, confirm that you are using the proper tree and context.

    • For more information, see To set a default tree and context.

  • Use the 32-bit version of command prompt.

    • If you are running Client Service for NetWare and use a command prompt, you should use the 32-bit version (Cmd.exe), which is available on the Programs menu, not the 16-bit version (Command.com).

  • Enable SAP on all router interfaces that connect NetWare resources.

    • If you are using Gateway Service for NetWare or Client Service for NetWare to connect to NetWare resources, ensure that SAP is enabled on all the router interfaces that connect the computers running Windows 2000 and the server computers running NetWare software. (A Windows 2000 remote access server, which is a computer running Windows 2000 Server and the Routing and Remote Access service, is an IPX router.) You can enable SAP on an interface by using Routing and Remote Access. For more information, see To enable SAP on an interface.

  • Follow the best practices for NWLink.

    • For more information, see Best practices for NWLink.


How To...

  • Install and configure Gateway Service for NetWare
  • Install and configure NWLink
  • Use NetWare resources
  • Use a computer running Windows 2000 Server as a NetWare gateway


Concepts

This section covers:

  • Overview of Novell NetWare integration
  • The NWLink IPX/SPX/NetBIOS Compatible Transport Protocol
  • Gateway Service for NetWare


Overview of Novell NetWare integration

Windows 2000 Server and Windows 2000 Professional provide several services that enable computers running Windows 2000 to coexist and interoperate with Novell NetWare networks and servers. Some of these services are included in Windows 2000 Server and Windows 2000 Professional; others are available as separate products.

  • NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink)

    • Included with both Windows 2000 Server and Windows 2000 Professional, NWLink is the Windows 2000 implementation of the IPX/SPX protocol. NWLink supports connectivity between computers running Windows 2000 and computers running NetWare and compatible systems. You can also use NWLink as a protocol that connects multiple computers running Windows 2000, Windows NT, Windows for Workgroups, Windows 95, Windows 98, and MS Client for DOS.

    For more information about NWLink, see The NWLink IPX/SPX/NetBIOS Compatible Transport Protocol.

  • Gateway Service for NetWare

    • Included with Windows 2000 Server, this tool enables a computer running Windows 2000 Server to connect to computers running NetWare 3.x or 4.x server software. Logon script support is also included. In addition, you can use Gateway Service for NetWare to create gateways to NetWare resources. Creating a gateway enables computers running only Microsoft client software to access NetWare resources through the gateway.

    For more information about Gateway Service for NetWare, see Gateway Service for NetWare.

  • Client Service for NetWare

    • Included with Windows 2000 Professional, this tool enables workstations to make direct connections to file and printer resources on NetWare servers running NetWare 2.x, 3.x, or 4.x software. You can use Client Service for NetWare to access servers running either Novell Directory Services (NDS) or bindery security. Logon script support is also included.

    For more information about Client Service for NetWare, see Windows 2000 Professional Help.

  • File and Print Services for NetWare

    • This tool is a separate product. File and Print Services for NetWare enables a computer running Windows 2000 Server to provide file and print services directly to NetWare and compatible client computers. The server appears just like any other NetWare server to the NetWare clients, and the clients can access volumes, files, and printers at the server. No changes or additions to the NetWare client software are necessary.

Note

  • Windows 2000 also contains an upgrade for NetWare client software for interoperating with Windows. This upgrade only applies to computers running NetWare client software and a version of Windows that was upgraded to Windows 2000. For more information, see Updated technical information.


The NWLink IPX/SPX/NetBIOS Compatible Transport Protocol

This section covers:

  • NWLink overview
  • Understanding NWLink
  • Using NWLink


NWLink overview

NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) is an implementation of Novell's Internetwork Packet Exchange/Sequenced Packet Exchange (IPX/SPX) and NetBIOS protocols. Windows 2000 clients can use NWLink to access client and server applications running on Novell NetWare servers. NetWare clients can use NWLink to access client and server applications running on Windows 2000 servers. With NWLink, computers running Windows 2000 can communicate with other network devices, such as printers, that use IPX/SPX. You can also use NWLink in small networks that only use Windows 2000 and other Microsoft client software.


Understanding NWLink

NWLink is a Network Driver Interface Specification (NDIS)-compliant, native 32-bit implementation of Novell's IPX/SPX protocol. NWLink supports two networking application programming interfaces (APIs): NetBIOS and Windows Sockets. These APIs allow communication among computers running Windows 2000 and between computers running Windows 2000 and NetWare servers. The following illustration shows where NWLink resides in the Windows 2000 architecture.

NWLink and the Windows 2000 architecture

The NWLink transport driver is an implementation of the lower-level NetWare protocols, which include IPX, SPX, RIPX (Routing Information Protocol over IPX) and NBIPX (NetBIOS over IPX). IPX controls addressing and routing of packets of data within and between networks. SPX provides reliable delivery through sequencing and acknowledgments. NWLink provides NetBIOS compatibility with a NetBIOS layer over IPX.

Interoperating with NetWare resources

Depending on what platform you are using and what resources that you want to access, you may need to use NWLink in conjunction with other tools. The following table lists several interoperability options that use NWLink.

Platform | Running | Can connect to
Windows 2000 | NWLink | Client/server applications running on a NetWare server.
Windows 2000 | NWLink and Client Service for NetWare or NWLink and Gateway Service for NetWare | NetWare servers for file and print services.
NetWare client | IPX with NetBIOS, Named Pipes, or Windows Sockets support | Computers running Windows 2000 (with NWLink installed) running IPX applications such as Microsoft SQL Server.
NetWare client | IPX | Computers running Windows 2000 Server (with NWLink and File and Print Services for NetWare installed) for file and print services.

For a Windows 2000 client to access file and print resources on a NetWare server, Client Service for NetWare must be installed on the Windows 2000 client in addition to NWLink. For more information, see the Windows 2000 Professional Help.

Non-NetWare computers on a network, which are not running NWLink or another IPX/SPX transport, can access NetWare file and print resources through a computer running Windows 2000 Server that has Gateway Service for NetWare and NWLink installed. For more information, see Gateway Service for NetWare.

If a Novell NetWare client requires file and print access to a computer running Windows 2000, File and Print Services for NetWare and NWLink must be installed on the computer running Windows 2000. File and Print Services for NetWare is available as a separate product.

Interoperating with Microsoft resources

By default, the file and print sharing components of Windows 2000 use NetBIOS over IPX to send file and print sharing messages.

Alternatively, you can disable NetBIOS so that the file and print sharing messages are sent directly over IPX. This is known as direct hosting. While direct hosting may be more efficient, it causes an interoperability issue: A direct hosting client can only connect to a direct hosting server. Direct hosting clients include computers running Microsoft Network Client for MS-DOS, Windows for Workgroups, Windows 95, and Windows 98. Direct hosting servers include computers running Microsoft Network Client for MS-DOS, Windows for Workgroups, Windows 95, Windows 98, Windows NT, and Windows 2000.

The following table lists several interoperability options that use IPX.

Platform | Running | Can connect to
Microsoft Network Client for MS-DOS, Windows for Workgroups, Windows 95, and Windows 98 | IPX only (direct hosting) | File and print shared resources on computers running Microsoft Network Client for MS-DOS, Windows for Workgroups, Windows 95, Windows 98, Windows NT, and Windows 2000.
Microsoft Network Client for MS-DOS, Windows for Workgroups, Windows 95, Windows 98, Windows NT, and Windows 2000 | NetBIOS over IPX | File and print shared resources on computers running Microsoft Network Client for MS-DOS, Windows for Workgroups, Windows 95, Windows 98, Windows NT, and Windows 2000.

Important

  • You cannot use direct hosting of IPX to gain access to resources on any computer acting as a direct host server from a computer running Windows 2000; computers running Windows 2000 do not include a direct hosting client for NWlink. For instance, while you can connect by using direct hosting of IPX to resources on a computer running Windows 2000 from a computer running Windows 95 or Windows 98 (where NetBIOS is disabled by default for performance reasons), you cannot connect by using direct hosting of IPX to the computer running Windows 95 or Windows 98 from the computer running Windows 2000.

For detailed instructions about enabling direct hosting, see To enable direct hosting of IPX.


Using NWLink

This section covers:

  • Installing NWLink
  • Configuring NWLink
  • Routing and NWLink


Installing NWLink

You can install the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) when you install Windows 2000 Server, or you can install NWLink later. You must be logged on as a member of the Administrators group to install and configure NWLink. For more information about installing NWLink, see Checklist: Installing and configuring NWLink.


Configuring NWLink

This section covers:

  • Setting the frame type
  • Setting the external and internal network numbers

For detailed instructions about configuring NWLink, see To configure NWLink.


Setting the frame type

The frame type defines the way in which the network adapter, in a computer running Windows 2000, formats data to be sent over a network. To communicate between a computer running Windows 2000 and NetWare servers, you need to configure the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) on the computer running Windows 2000 with the same frame type as the one used by the NetWare servers.

The following table lists the topologies and frame types supported by NWLink.

Topology | Supported frame type
Ethernet | Ethernet II, 802.3, 802.2, and Sub Network Access Protocol (SNAP), which defaults to 802.2
Token ring | 802.5 and SNAP
Fiber Distributed Data Interface (FDDI) | 802.2 and 802.3

Note

  • On Ethernet networks, the standard frame type for NetWare 2.2 and NetWare 3.11 is 802.3. Starting with NetWare 3.12, the default frame type was changed to 802.2.

You can choose to automatically detect or manually configure the frame type. However, the frame type is automatically detected when NWLink is loaded. If multiple frame types are detected in addition to the 802.2 frame type, NWLink defaults to the 802.2 frame type.

If the frame type is manually configured, a computer running Windows 2000 can use multiple frame types simultaneously.

You can configure the frame type by using the NWLink IPX/SPX/NetBIOS-Compatible Transport Protocol Properties dialog box. For more information, see To configure NWLink.


Setting the external and internal network numbers

The NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) uses two types of IPX network numbers for routing purposes: external network numbers, referred to as the Network number in the Manual Frame Detection dialog box, and internal network numbers, referred to as the Internal network number in the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol Properties dialog box. Both are hexadecimal numbers, with 1 to 8 digits (1 to FFFFFFFE).

The external network number is associated with physical network adapters and networks. To communicate with each other, all computers on the same network that use a given frame type must have the same external network number. If your computer has multiple network adapters that are connected to different networks, you must assign an external network number to each configured frame type and network adapter combination on your computer. If you do not know the appropriate numbers to use, see your NetWare documentation. If you do not set an external network number, the number is automatically detected by the Windows 2000 operating system.

The internal network number, also called a virtual network number, identifies a virtual network inside a computer. On a server computer running Windows 2000, programs advertise themselves as being located on the virtual network, not a physical network. When you assign internal network numbers, you gain more efficient routing to the programs in a computer with multiple network adapters that are connected to multiple, interconnected networks. By default, the internal network number is 00000000. However, in each of the following situations, you need to manually assign a unique, nonzero internal network number:

  • File and Print Services for NetWare is installed on your computer, and you select multiple frame types on a single adapter.
  • Your computer is acting as a server (running Windows 2000) for a program that uses the NetWare Service Advertising Protocol (SAP), such as SQL or SNA.
  • Your computer is acting as an IPX router that uses the Windows 2000 routing.

You can set the external and internal network numbers by using the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol Properties dialog box. For more information, see To configure NWLink.


Routing and NWLink

This section covers:

  • Using the Routing Information Protocol
  • Using the Service Advertising Protocol
  • Using Ipxroute


Using the Routing Information Protocol

In networks that use only the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink), routing information is propagated by using the Routing Information Protocol (RIP). NWLink uses the Routing Information Protocol over IPX (RIPX) to determine the best router to use when forwarding IPX traffic to another IPX network.

RIPX and NWLink

RIPX is used to determine the frame type and external network number for each interface that is configured for autodetection. When NWLink loads, it sends out a RIPX request to discover the frame type and external network number. IPX routers (and NetWare servers) respond to the request with packets that use the IPX router frame type and contain the external network number of the local network.

RIPX and routers

When the IPX host determines the IPX network number of the destination, it compares the destination IPX network number with its own attached external network number. If they are different, the IPX host must forward the IPX packet to an IPX router. To determine the best router to use to forward the IPX traffic, the IPX host sends out a RIP request for the destination IPX network number. All IPX routers on the network of the IPX host that have a route to the destination network number send back a response to the IPX host. The IPX host chooses the best response and forwards the IPX packet to the router that sent the best response.

When the Windows 2000 Routing and Remote Access service is installed, the computer running Windows 2000 acts as a RIP-based IPX router. RIPX is used to listen for route announcements and periodically send route announcements to maintain an IPX routing table.

For more information about routing with Windows 2000, see Checklist: Installing and configuring the router.


Using the Service Advertising Protocol

The NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) uses the Service Advertising Protocol (SAP) to locate the nearest server upon startup and to locate either all services or all services of a specific type. When the Windows 2000 Routing and Remote Access service is installed, the computer running Windows 2000 also uses SAP to listen for SAP advertisements and periodically make SAP advertisements to maintain a table of available services on the network. If you have installed Routing and Remote Access, you can run just SAP advertising and routing by disabling all other functions of the Routing and Remote Access.

The SAP Agent

The SAP Agent is a network service that allows services on a computer running Windows 2000 Server to advertise themselves by using periodic SAP advertisements. Without the SAP Agent, the services on a computer running Windows 2000 are unavailable to computers running NetWare client software as well as computers running Windows 2000 that are configured to use just the NWLink protocol.

You can manually install the SAP Agent by using the properties of a connection, but is usually automatically installed when a service that uses the SAP Agent is installed. An example is Microsoft Exchange Server. To make the computer running Microsoft Exchange Server available to computers running NetWare client software and computers running Windows 2000 that are configured to use just the NWLink protocol, the Microsoft Exchange Server setup program automatically installs the SAP Agent. Once installed, the Microsoft Exchange Server service uses the SAP Agent to periodically advertise its presence and location so that it can be contacted by Microsoft Exchange clients on an IPX network.

When Routing and Remote Access is running, you can configure SAP settings per network adapter, such as whether to forward broadcasts from one adapter to another or whether to disable SAP over an adapter. These settings are configured through the Routing and Remote Access console. You cannot configure the SAP Agent.

The following table summarizes the relationship between the SAP Agent and Routing and Remote Access.

Routing and Remote Access/SAP Agent running? | Routing method
Neither SAP Agent nor Routing and Remote Access is running | Services are not advertised/routed.
SAP Agent is running (but not Routing and Remote Access) | SAP Agent advertises/routes services.
Routing and Remote Access is running (but not SAP Agent) | Routing and Remote Access advertises/routes services.
Both SAP Agent and Routing and Remote Access are running | Routing and Remote Access advertises/routes services.

Note

  • You do not need to install the SAP Agent service separately when Routing and Remote Access is running, since Routing and Remote Access assumes the responsibilities of the SAP Agent.


Using Ipxroute

You can modify the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) settings that affect routing with the Ipxroute.exe command-line utility (the ipxroute command). The Ipxroute utility provides the same functionality as the Route.exe command-line utility that is supplied by Novell for its MS-DOS-based clients.

The Ipxroute utility manages the source routing variables of NWLink. Ipxroute.exe is installed only if the NWLink transport protocol is bound to a network adapter.

The Ipxroute utility changes these settings for the current session only. When you log off, the settings are lost. To permanently change NWLink settings, you must set them in the registry.

For information about syntax for the ipxroute command, see Ipxroute.


Gateway Service for NetWare

This section covers:

  • Gateway Service for NetWare overview
  • Understanding Gateway Service for NetWare and gateways
  • Using Gateway Service for NetWare


Gateway Service for NetWare overview

With Gateway Service for NetWare, you can create a gateway through which Microsoft client computers without Novell NetWare client software can access NetWare file and print resources. You can make gateways for resources located on Novell Directory Services (NDS) trees as well as for resources on servers with bindery security. These resources include volumes, directories, directory map objects, printers, and print queues.

A user who works locally at a computer running Windows 2000 Server can use Gateway Service for NetWare to gain direct access to NetWare file and print resources, both on NDS trees and on servers with bindery security.

Gateway Service for NetWare depends on and works with another NetWare compatibility feature of Windows 2000 Server: the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink). NWLink is an implementation of the Internetwork Packet Exchange (IPX), Sequenced Packet Exchange (SPX), and NetBIOS transport protocols used by the NetWare network. The Microsoft implementations of these protocols can seamlessly coexist with other protocols on the same network adapter.

Note

  • Gateway Service for NetWare does not support the IP protocol to interoperate with NetWare version 5.x. To do this, you must run the IP/IPX gateway in NetWare 5.x, or use a redirector that is compatible with NCP and supports native IP.


Understanding Gateway Service for NetWare and gateways

Gateway Service for NetWare acts as a bridge between the server message block (SMB) protocol used by the Windows 2000 network and the NetWare core protocol (NCP) used by the NetWare network. When a gateway is enabled, network clients running Microsoft client software can access NetWare files and printers without having to run NetWare client software locally. The following illustration shows an example of a file gateway configuration.

File gateway

For file access, the gateway server redirects one of its own drives to the NetWare volume and then shares that drive to other Microsoft clients. The file gateway uses a NetWare account on the computer running Windows 2000 Server to create a validated connection to the NetWare server. This connection appears on the computer running Windows 2000 Server as a redirected drive. When you share the redirected drive, it becomes like any other shared resource on the computer running Windows 2000 Server.

For example, suppose you want to create a gateway from the computer Airedale (running Gateway Service for NetWare) to the NetWare NDS folder \\Nw4\Server1\Org_Unit.Org\Data volume on the NetWare server Nw4. When activating the gateway, you specify \\Nw4\Server1\Org_Unit.Org\Data as the NetWare resource, and then you specify a share name for Microsoft clients, such as Nw_Data. Microsoft clients would then refer to this resource as \\Airedale\Nw_Data.

After the gateway connection is established, it is disconnected only if the computer running Windows 2000 Server is turned off, if the administrator disconnects the shared resource or disables the gateway, or if a network problem prevents access to the NetWare server. Logging off the computer running Windows 2000 Server does not, by itself, disconnect the gateway.

Note

  • Because requests from Microsoft networking clients are processed through the gateway, access is slower than direct access from the client to the NetWare network. Clients that require frequent access to NetWare resources should run Windows 2000 Professional with Client Service for NetWare, or Windows 95 and Windows 98 with their NetWare client software, to achieve higher performance.


Using Gateway Service for NetWare

This section covers:

  • Installing Gateway Service for NetWare
  • Configuring Gateway Service for NetWare
  • Creating a gateway
  • Setting gateway share permissions
  • Connecting directly to NetWare resources


Installing Gateway Service for NetWare

You have the option to install Gateway Service for NetWare when you install Windows 2000 Server, or you can install Gateway Service for NetWare later. You must be logged on as a member of the Administrators group to install and configure Gateway Service for NetWare. For more information about installing Gateway Service for NetWare after you have already installed Windows 2000 Server, see To install Gateway Service for NetWare.

During installation of Gateway Service for NetWare, NWLink is installed if it is not already on the server. For more information about NWLink, see The NWLink IPX/SPX/NetBIOS Compatible Transport Protocol. Also during installation of Gateway Service for NetWare, Client Service for NetWare is installed and the GSNW icon is added to Control Panel.

By default, the NetWare network is placed first in the network search order.

Important

  • Before you install Gateway Service for NetWare on a computer, remove any existing client software that is compatible with NCP, including NetWare client software, from the computer.


Configuring Gateway Service for NetWare

When you first log on after Gateway Service for NetWare is installed, you are prompted to set your default tree and context or your preferred server. The tree and context define the position of the user object for the user name you use to log on to a Novell Directory Services (NDS) tree. A preferred server is the NetWare server to which you are automatically connected when you log on, if your network does not use NDS.

You can have either a default tree and context or a preferred server, but not both. (In NDS environments, you set a default tree and context.) If you select a default tree and context, you can still access NetWare servers that use bindery security.

For more information, see To set a preferred server and To set a default tree and context. To change your tree and context at a later time, you can use Gateway Service for NetWare (in Control Panel).


Creating a gateway

Before you can create a gateway to NetWare resources on a computer running Windows 2000 Server:

  • The NetWare server must have a group named NTGATEWAY with the necessary rights for the resources that you want to access.
  • You must have a user account on the NetWare network with the necessary rights for the resources that you want to access.
  • The NetWare user account you use must be a member of the NTGATEWAY group.

The NetWare user account you use to enable gateways can be either a Novell Directory Services (NDS) account or a bindery account. If the server will have gateways to both NDS resources and resources on servers running bindery security, the user account must be a bindery account. (This account can connect to NDS resources through bindery emulation.) If you create gateways only to NDS resources, the account can be an NDS account.

Creating a gateway is a two-step process:

  1. First, you enable gateways on the server running Windows 2000 Server. When you enable a gateway, you must type the name and password of the user account that has access to the NetWare server and is a member of the NTGATEWAY group on that NetWare server.

    You need to do this only once for each server that will act as a gateway. For more information, see To enable a gateway on the server.

  2. For each volume or printer to which you want to create a gateway, you activate a gateway. When you activate a gateway, you specify the NetWare resource and a share name that Microsoft client users will use to connect to the resource.

    To activate a gateway for a volume, you can use Gateway Service for NetWare (in Control Panel). To activate a gateway for a printer, you can use the Add Printer wizard.

    If you are activating a gateway to an NDS resource, and the gateway user account is a bindery user account, specify the resource that uses the bindery context name. If you are using a NDS user account, and you do not plan on also creating gateways to bindery resources, specify the NDS resource name.

    For more information, see To activate a gateway to a NetWare file resource and To activate a gateway to a NetWare printer.

Security for gateway resources is provided on two levels:

  • On the computer running Windows 2000 Server and acting as a gateway, you can set share-level permissions for each resource made available through the gateway. For more information, see To set permissions for a gateway share to a NetWare resource.
  • On the NetWare file server, the NetWare administrator can assign trustee rights to the user account that is used for the gateway or to the NTGATEWAY group. These rights are enforced for all Microsoft client users who access the resource through the gateway. There is no auditing of gateway access.


Setting gateway share permissions

You can set the following permissions for files and directories through a gateway share to NetWare resources.

Permission Prevents or allows

No Access (None)

Prevents:

  • Access to the shared volume, its directories, its subdirectories, and its files.

Read

Allows:

  • Viewing file names, directory names, and subdirectory names.
  • Changing to the directories and subdirectories of the shared volume.
  • Viewing data in files and running application files.

Change

Allows:

  • Viewing file names, directory names, and subdirectory names.
  • Changing to the directories and subdirectories of the shared volume.
  • Viewing data in files and running application files.
  • Adding files, directories, and subdirectories to the shared volume.
  • Changing data in files.
  • Deleting subdirectories and files.

Full Control (All)

Allows:

  • Viewing file names, directory names, and subdirectory names.
  • Changing to the directories and subdirectories of the shared volume.
  • Viewing data in files and running application files.
  • Adding files, directories, and subdirectories to the shared volume.
  • Changing data in files.
  • Deleting subdirectories and files.
  • Changing permissions (NTFS files and directories only).
  • Taking ownership (NTFS files and directories only).

For more information, see To enable a gateway on the server.


Connecting directly to NetWare resources

In addition to providing gateway technology, Gateway Service for NetWare enables users working locally at a computer running Windows 2000 Server to access NetWare resources directly, just as Client Service for NetWare provides this service to Windows 2000 Professional users. The information in this section applies to users working locally at a computer running Windows 2000 Server who access NetWare resources directly—not to Microsoft clients who access resources through a gateway. (This information does apply to users of Client Service for NetWare on computers running Windows 2000 Professional.)

Novell Directory Services (NDS) trees (as well as NetWare servers running bindery security) appear in the NetWare or Compatible Network list in Windows Explorer. You can double-click a tree name to expand it, and then double-click any container object to expand its contents and structure. You can connect to and assign a local drive to any volume, folder, or directory map object anywhere in the tree hierarchy (for which you have credentials). For more information, see To connect to a NetWare volume by using My Network Places.

To connect to an NDS printer, you can use the Add Printer wizard, just as you would to connect to any network printer. For more information, see To connect to a NetWare printer by using the Add Printer wizard.

If you have a default tree and context, once you have logged on, you do not need to log on again or supply another password to access any volume in your default tree. If you access another tree, you are prompted to supply a full context (including user name) for that tree.

This section covers:

  • Changing the NetWare password
  • Using logon scripts
  • Managing NetWare file attributes
  • Running NetWare utilities and NetWare-aware programs


Changing the NetWare password

Users who use either Gateway Service for NetWare or Client Service for NetWare to directly access NetWare resources can change their passwords on NDS trees on the network. To do this, you can use the standard password-changing procedure for Windows 2000 Server: Press CTRL+ALT+DEL, click Change Password, and in Log on to, click NetWare or Compatible Network.

To change the password on a NetWare server running bindery security, you can use the setpass command on the NetWare server.

For more information, see To change your password on a NetWare bindery server and To change your password on a NetWare NDS tree.


Using logon scripts

When a user, running either Gateway Service for NetWare or Client Service for NetWare to directly access NetWare resources, first makes a connection to a particular NetWare server, the user's logon script (if any) runs. A user's logon script does not run, however, if the user connects to NetWare resources through a gateway.

Note

  • If you are running Client Service for NetWare and use a command prompt, you should use the 32-bit version (Cmd.exe), which is available on the Programs menu, not the 16-bit version (Command.com). While running Client Service for NetWare, if you run a batch file (such as a logon script) that opens an instance of the command prompt, the batch file should begin with the command #cmd, not #command.


Managing NetWare file attributes

NetWare file attributes are not exactly the same as those for Windows 2000 Server. The following table shows the corresponding file rights for a NetWare file opened through Gateway Service for NetWare.

Windows 2000 file attributes | NetWare file attributes
A (Archive) | A
S (System) | Sy
H (Hidden) | H
R (Read-only) | Ro, Di (Delete inhibit), Ri (Rename inhibit)

Gateway Service for NetWare does not support the following NetWare file attributes: Rw (Read/write), S (Shareable), T (Transactional), P (Purge), Ra (Read audit), Wa (Write audit), and Ci (Copy inhibit).

When you copy a file from a Microsoft networking client to the NetWare file server by means of Gateway Service for NetWare, the Ro, A, Sy, and H file attributes are preserved.

When you use a computer running Gateway Service for NetWare to directly access NetWare servers, you can use NetWare utilities (such as the filer and rights commands), to set attributes that are not supported by the mapping of Windows 2000–to–NetWare file rights. For more information about other supported utilities, see Running NetWare utilities and NetWare-aware programs.


Running NetWare utilities and NetWare-aware programs

With Windows 2000 Server and Gateway Service for NetWare, you can run some standard NetWare utilities from a command prompt, and many NetWare-aware programs. Gateway Service for NetWare does not support NetWare 4.x or 5.x utilities. In addition, for some administrative functions, you must use Windows 2000 Server management tools.


Troubleshooting

This section provides troubleshooting information for the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) and Gateway Service for NetWare.

Many common problems are caused by improper installation or configuration of the network adapter or Gateway Service for NetWare. To begin troubleshooting, you should confirm that the network adapter is installed and configured correctly and that existing installations of NetWare redirectors are removed. You can also use Event Viewer (available in Administrative Tools in Control Panel) to view the system log information generated during startup.

Additional troubleshooting information follows:

What problem are you having?

Gateway Service for NetWare does not start.

Cause: One of the required services or protocols may be unavailable.

Solution: Try to start Gateway Service for NetWare manually. If that fails, you can use Event Viewer (available in Administrative Tools in Control Panel) to look at the system log and troubleshoot the problem.

Gateway Service for NetWare (or Client Service for NetWare) starts, but no servers are found.

Cause: The frame type or SAP may be configured incorrectly.

Solution: Try the following:

  • You may be unable to see NetWare servers because the network frame type is set incorrectly. You can view the network adapter load line in the Autoexec.ncf file of the NetWare server to verify that you are using the correct frame type for the server. For example, suppose a network adapter load line for a server is:

    load 3C503 FRAME=ETHERNET_802.3 NAME=ETH

    In this case, the server is bound to a 3Com 503 Ethernet adapter that accepts the raw 802.3 frame format.

    You can use Network and Dial-up Connections in Control Panel to see the frame type that is set for your network adapter. If the frame type is detected automatically and the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) detects any frames of type 802.2 or no frames at all, NWLink sets the frame type to 802.2. If the network adapter receives frames of type 802.2, but your NetWare network uses some other frame type, you must set the frame type manually. For instructions about setting the frame type manually, see To configure NWLink.

    On a computer running Windows 2000 Server, you can determine which frame type your routers are using by typing ipxroute config at a command prompt.

  • If you cannot see NetWare file server resources, ensure that SAP is enabled on all the router interfaces that connect the computers running Windows 2000 and the server computers running NetWare software. (A Windows 2000 remote access server, which is a computer running Windows 2000 Server and the Routing and Remote Access service, is an IPX router.) You can enable SAP on an interface by using Routing and Remote Access (available in Administrative Tools in Control Panel). For more information, see To enable SAP on an interface.

Gateway Service for NetWare (or Client Service for NetWare) starts, but only some resources are found.

Cause: The tree and context or SAP may be configured incorrectly.

Solution: Try the following:

  • In an Novell Directory Services (NDS) environment, verify that you are using the correct tree and context.

  • For each IPX router, view the SAP service table and verify that all of the services that should be learned from SAP are present. If some of the services are not present, you should verify that SAP filtering is not preventing the propagation of these services. For more information about viewing the SAP service table, see To view routing tables. For more information about enabling SAP filtering, see To set input and output filters. The SAP service table is not the same as the NetWare slist command or running an NDS query for a list of all the servers in the tree.

Access is denied when you try to configure a computer running Windows 2000 Server as a file or print gateway.

Cause: The NetWare user account you use to enable the gateway may not be configured correctly on your NetWare server.

Solution: Verify that the NetWare user account you use to enable the NetWare server is a member of the NTGATEWAY group, and that your account and the NTGATEWAY group have sufficient trustee rights.

For information about setting up the NTGATEWAY group and assigning trustee rights on the NetWare server, see your NetWare documentation.

See also: Using Gateway Service for NetWare

The NetWare map command cannot be used to connect to file or print resources.

Cause: You may be using the wrong command prompt or the default environment size of the command prompt window may be too small.

Solution: The default environment for 16-bit programs is too small to accommodate the mapping table created by the map command. You should designate the 32-bit command prompt, Cmd.exe, as the permanent command interpreter and reset the default environment size allocated to the command prompt window. An environment of 4,096 bytes is large enough to accommodate the map command, the mapping table, and the command interpreter.

To make these changes to the environment, type the following line in Config.nt:

shell=%systemroot%\system32\cmd.exe /e:4096

This line sets Cmd.exe as the command interpreter for the window as long as it remains open or until you issue another shell command. The line also permanently allocates 4,096 bytes of environment space to 16-bit programs you run in the window.

The network does not start when you start your computer.

Cause: You may have duplicate computer names.

Solution: You must specify a computer name that is not the same as the name of another computer on the network or the same as the name of a workgroup or a domain on the network.

A computer running NWLink cannot connect to other computers.

Cause: Routing may be configured incorrectly.

Solution: Try the following:

  • Verify that you have NetBIOS broadcast propagation (type 20 packets) enabled on all the router interfaces between the computers. (A Windows 2000 remote access server, which is a computer running Windows 2000 Server and the Routing and Remote Access service, is an IPX router.) You can enable NetBIOS broadcast propagation in Routing and Remote Access (available in Administrative Tools in Control Panel).
  • Verify that you do not have more than eight routers between the computers running Windows 2000.