Other protocols

This section covers:

  • NetBEUI defined
  • IPX/SPX defined
  • L2TP defined
  • PPTP defined
  • RADIUS defined


NetBEUI defined

NetBIOS Enhanced User Interface (NetBEUI) is a non-routable network transport suited for use in small networks that consist of a single network segment with less than 50 computers. NetBEUI is one of two network solutions for supporting Network Basic Input Output System (NetBIOS) usage, which is required by earlier versions of Windows for network name resolution. The other NetBIOS-based solution, used for larger or routed networks, is NetBIOS over TCP/IP (NetBT).

For more information, see either NetBEUI or NetBIOS over TCP/IP (NetBT) concepts.


IPX/SPX defined

Internetwork Packet Exchange (IPX) and Sequenced Packet Exchange (SPX) are transport protocols used in Novell NetWare networks. Together, they correspond to the Internet Protocol (IP) and Transport Control Protocol (TCP), which are used in the TCP/IP protocol suite.

Windows 2000 implements IPX through the NWLink. For more information, see The NWLink IPX/SPX/NetBIOS Compatible Transport Protocol.


L2TP defined

Layer Two Tunneling Protocol (L2TP) is networking technology that supports multiprotocol virtual private networks (VPNs), which enable remote users to access corporate networks securely across the Internet. Like the Point-to-Point Tunneling Protocol (PPTP), it can be used to provide securing of tunneled end-to-end Internet connections through other remote access technologies, such as Internet access provided through DSL.

Unlike PPTP, L2TP is not dependent on vendor-specific encryption technologies for a fully secured and successful implementation. For this reason, it is likely to become the standard for securing virtual private network connections throughout the Internet.

Windows 2000 implements L2TP support through IP Security (IPSec) technology and the Routing and Remote Access service. For more information, see PPTP defined, IP Security (IPSec), or Virtual private networks.


PPTP defined

Point-to-Point Tunneling Protocol (PPTP) is networking technology that supports multiprotocol virtual private networks (VPNs), enabling remote users to access corporate networks securely across the Internet. Unlike the Point-to-Point Protocol (PPP), which is designed to support a dial-up network connection to the Internet, PPTP does not rely upon a dial-up connection. It can be used to provide secure, tunneled end-to-end Internet connections through other remote access technologies, such as Internet access provided through DSL.

Windows 2000 implements PPTP client-side support through Network and Dial-up Connections and server-side support through Routing and Remote Access. For more information, see Point-to-Point Tunneling Protocol (PPTP) or Virtual private networks.


RADIUS defined

Remote Authentication Dial-In User Service (RADIUS) is a security authentication client/server protocol widely used by Internet service providers on other remote access servers. RADIUS is the most common means of authenticating and authorizing dial-up and tunnelled network users.

Windows 2000 implements a RADIUS server through the Internet Authentication Service. For more information, see RADIUS or Internet Authentication Service.