Windows Script Host

You can use Windows Script Host to run scripts written in JScript and VBScript, as well as any ActiveX-compatible scripting engines.

  • For help with specific tasks, see How to...
  • For general background information, see Concepts.


How to...

  • Run scripts using the command-line-based script host (Cscript.exe)
  • Run scripts using the Windows-based script host (Wscript.exe)
  • Set properties for an individual script
  • Download Windows Script Host samples
  • Run Windows Script Host samples


Concepts

This section provides general background information about Windows Script Host.

  • Windows Script Host overview
  • Using Windows Script Host object model