Deployment Guide Glossary

Glossary

.

.adm
A file name extension for Administrative Templates files.
.msi
A file name extension for Windows Installer package files.

A

access control
The security mechanism in Windows NT and Windows 2000 that determines which objects a security principal can use and how the security principal can use them. See also authorization; security principal.
access control entry (ACE)
An entry in an access control list (ACL) containing a security ID (SID) and a set of access rights. A process with a matching security ID is either allowed access rights, denied rights, or allowed rights with auditing.
access control list (ACL)
The part of a security descriptor that enumerates the protections applied to an object. The owner of an object has discretionary access control of the object and can change the object's ACL to allow or disallow others access to the object. ACLs are made up of access control entries (ACEs). Each security descriptor for an object in Windows NT or Windows 2000 contains four security components: creator (owner); group, for POSIX compliance and is associated with the "primary group" set in individual user objects in User Manager; discretionary access control list (DACL, usually referred to simply as ACL), determines the permissions on the object; and system access control list (SACL), determines auditing. See also discretionary access control list.
access token
An object containing the security information for a logon session. Windows 2000 creates an access token when a user logs on, and every process executed on behalf of the user has a copy of the token. The token identifies the user, the user's groups, and the user's privileges. The system uses the token to control access to securable objects and to control the ability of the user to perform various system-related operations on the local computer. There are two kinds of access token: primary and impersonation. See also primary token; impersonation token; privilege; process; security identifier.
accessibility
The quality of a system incorporating hardware or software to engage a customizable user interface, alternative input and output methods, and greater exposure of screen elements to make the computer usable by people with cognitive, hearing, physical, or visual disabilities.
accessibility wizard
An interactive tool that makes it easier to set up commonly used accessibility features by specifying options by type of disability, rather than by numeric value changes.
account domain
A Windows NT domain that holds user account data. Also known as a master domain.
account lockout
A Windows 2000 security feature that locks a user account if a number of failed logon attempts occur within a specified amount of time, based on security policy lockout settings. (Locked accounts cannot log on.)
Active Directory
The directory service included with Windows 2000 Server. It stores information about objects on a network and makes this information available to users and network administrators. Active Directory gives network users access to permitted resources anywhere on the network using a single logon process. It provides network administrators with an intuitive hierarchical view of the network and a single point of administration for all network objects. See also directory; directory service.
Active Directory Connector (ADC)
A synchronization agent in Windows 2000 Server, Windows 2000 Advanced Server, and Windows 2000 Enterprise Server that provides an automated way of keeping directory information between the two directories consistent. Without the ADC, you would have to manually enter new data and updates in both directory services.
Active Directory Installation wizard
A Windows 2000 Server tool that allows the following during Setup: installation of Active Directory, creation of trees in a forest, replicating an existing domain, installation of Kerberos authentication software, and promotion of servers to domain controllers.
Active Directory replication
Replication that occurs through the Directory Replicator Service, which provides multimaster replication of directory partitions between domain controllers. "Multimaster" means that directory partition replicas are writable on each domain controller. The replication service copies the changes from a given directory partition replica to all other domain controllers that hold the same directory partition replica. See also directory partition; File Replication service.
Active Directory Service Interfaces (ADSI)
A directory service model and a set of COM interfaces. ADSI enables Windows 95, Windows 98, Windows NT, and Windows 2000 applications to access several network directory services, including Active Directory. It is supplied as a Software Development Kit (SDK).
active partition
The partition from which the computer starts up. The active partition must be a primary partition on a basic disk. If you are using Windows 2000 exclusively, the active partition can be the same as the system partition. If you are using Windows 2000 and Windows 98 or earlier, or MS-DOS, the active partition must contain the startup files for both operating systems.
active/active
The cluster configuration of an application, in which the application runs on all nodes at the same time. See also active/passive.
active/passive
The cluster configuration of an application, in which the application runs on only one node at a time. See also active/active.
ActiveX
A set of technologies that enables software components to interact with one another in a networked environment, regardless of the language in which the components were created.
address
In Systems Management Server, addresses are used to connect sites and site systems. Senders use addresses to send instructions and data to other sites.
address classes
See internet address classes.
address pool
A group of IP addresses in a scope. Pooled addresses are then available for dynamic assignment by a DHCP server to DHCP clients.
Address Resolution Protocol (ARP)
In TCP/IP, a protocol that uses limited broadcast to the local network to resolve a logically assigned IP address. The IP address is conferred in software for each IP network host device to its physical hardware or media access control layer address. With ATM the ARP protocol is used two different ways. For CLIP, ARP is used to resolve addresses to ATM hardware addresses. With ATM LAN Emulation, ARP is used to resolve Ethernet/802.3 or Token Ring addresses to ATM hardware addresses. See also media access control; TCP/IP.
administrative templates (.adm files)
An ASCII file referred to as an Administrative Template (.adm file) used by Group Policy as a source to generate the user interface settings an administrator can set.
admission control
The service used to administratively control network resources on shared network segments.
Advanced Configuration and Power Interface (ACPI)
An open industry specification that defines power management on a wide range of mobile, desktop, and server computers and peripherals. ACPI is the foundation for the OnNow industry initiative that allows system manufacturers to deliver computers that will start at the touch of a keyboard. ACPI design is essential to take full advantage of power management and Plug and Play in Windows 2000. Check the manufacturer's documentation to verify that a computer is ACPI-compliant. See also Plug and Play.
advertise
In Systems Management Server, to make a program available to members of a collection (group).
advertisement
In Systems Management Server, a notification sent by the site server to the client access points (CAPs) specifying that a software distribution program is available for clients to use.
agent
An application that runs on a simple network management protocol (SNMP) managed device. The agent application is the object of management activities. A computer running SNMP agent software is also sometimes referred to as an agent.
algorithm
A rule or procedure for solving a problem. Internet Protocol security uses cryptographically based algorithms to encrypt data.
alternative input devices
Input devices for users who cannot use standard input devices, such as a mouse or a keyboard.
answer file
A text file that you can use to provide automated input for unattended installation of Windows 2000. This input includes parameters to answer the questions required by Setup for specific installations. In some cases, you can use this text file to provide input to wizards, such as the Active Directory Installation wizard, which is used to add Active Directory to Windows 2000 Server through Setup. The default answer file for Setup is known as Unattend.txt.
AppleTalk
The Apple Computer network architecture and network protocols. A network that has Macintosh clients and a computer running Windows 2000 Server with Services for Macintosh functions as an AppleTalk network.
AppleTalk Protocol
The set of network protocols on which AppleTalk network architecture is based. The AppleTalk Protocol stack must be installed on a computer running Windows 2000 Server so that Macintosh clients can connect to it. See also AppleTalk.
application assignment
A process that uses Software Installation (an extension of Group Policy) to assign programs to groups of users. The programs appear on the users' desktop when they log on.
application programming interface (API)
A set of routines that an application uses to request and carry out lower-level services performed by a computer's operating system. These routines usually carry out maintenance tasks such as managing files and displaying information.
area
A group of contiguous networks within an OSPF autonomous system. OSPF areas reduce the size of the link state database and provide the ability to summarize routes. See also autonomous system, link state database.
area border router (ABR)
A router that is attached to multiple areas. Area border routers maintain separate link state databases for each area. See also link state database.
ARP Cache
A table of IP addresses and their corresponding media access control address. There is a separate ARP cache for each interface.
assigning
In Systems Management Server, to deploy a program to members of a collection (group), where acceptance of the program is mandatory.
Asynchronous Transfer Mode (ATM)
A high-speed connection-oriented protocol used to transport many different types of network traffic.
attribute (object)
In Active Directory, a single property of an object. An object is described by the values of its attributes. For each object class, the schema defines what attributes an instance of the class must have and what additional attributes it might have.
attributes (file)
Information that indicates whether a file is read-only, hidden, ready for archiving (backing up), compressed, or encrypted, and whether the file contents should be indexed for fast file searching.
auditing
To track the activities of users by recording selected types of events in the security log of a server or a workstation.
augmentative communication devices
Add-on software and hardware that can help users with disabilities control a computer using assistive technology. Examples are speech recognition systems and screen readers.
authentication
In network access, the process by which the system validates the user's logon information. A user's name and password are compared against an authorized list. If the system detects a match, access is granted to the extent specified in the permissions list for that user. When a user logs on to an account on a computer running Windows 2000 Professional, the authentication is performed by the client. When a user logs on to an account on a Windows 2000 Server domain, authentication can be performed by any server of that domain. See also server; trust relationship.
authentication
The IPSec process that verifies the origin and integrity of a message by assuring the genuine identity of each computer. Without strong authentication, an unknown computer and any data it sends is suspect. IPSec provides multiple methods of authentication to ensure compatibility with earlier systems running earlier versions of Windows, non-Windows-based systems, and shared computers.
authoritative
For the Domain Name System (DNS), the use of zones by DNS servers to register and resolve a DNS domain name. When a DNS server is configured to host a zone, it is authoritative for names within that zone. DNS servers are granted authority based on information stored in the zone. See also zone.
authoritative restore
In Backup, a type of restore operation on a Windows 2000 domain controller in which the objects in the restored directory are treated as authoritative, replacing (through replication) all existing copies of those objects. Authoritative restore is applicable only to replicated System State data such as Active Directory data and File Replication service data. The Ntdsutil.exe utility is used to perform an authoritative restore. See also nonauthoritative restore; System State.
authorization
In remote access or demand-dial routing connections, the verification that the connection attempt is allowed. Authorization occurs after successful authentication.
automated installation
To run an unattended setup using one or more of several methods such as Remote Installation Services, bootable CD, and Sysprep.
Automatic Private IP Addressing (APIPA)
A feature of Windows 2000 TCP/IP that automatically configures a unique IP address from the range 169.254.0.1 to 169.254.255.254 and a subnet mask of 255.255.0.0 when the TCP/IP protocol is configured for dynamic addressing and a Dynamic Host Configuration.
autonomous system (AS)
A group of routers exchanging routing information by using a common routing protocol.
availability
A measure of the fault tolerance of a computer and its programs. A highly available computer runs 24 hours a day, 7 days a week. See also fault tolerance.

B

backbone
In OSPF, an area common to all other OSPF areas that is used as the transit area for inter-area traffic and for distributing routing information between areas. The backbone must be contiguous. See also Open Shortest Path First (OSPF).
backup domain controller
In Windows NT Server 4.0 or earlier, a computer running Windows NT Server that receives a copy of the domain's directory database (which contains all account and security policy information for the domain). The copy synchronizes periodically with the master copy on the primary domain controller. A backup domain controller also authenticate user logon information and can be promoted to function as primary domain controllers as needed. Multiple backup domain controllers can exist in a domain. Windows NT 3.51 and 4.0 backup domain controllers can participate in a Windows 2000 domain when the domain is configured in mixed mode. See also mixed mode; primary domain controller.
backup operator
A type of local or global group that contains the user rights needed to back up and restore files and folders. Members of the Backup Operators group can back up and restore files and folders regardless of ownership, access permissions, encryption, or auditing settings. See also auditing; global group; local group; user rights.
backup set
A collection of files, folders, and other data that have been backed up and stored in a file or on one or more tapes.
bandwidth
In communications, the difference between the highest and lowest frequencies in a given range. For example, a telephone line accommodates a bandwidth of 3000 Hz, the difference between the lowest (300 Hz) and highest (3300 Hz) frequencies it can carry. In computer networks, greater bandwidth indicates faster data-transfer capability and is expressed in bits per second (bps).
Bandwidth Allocation Protocol (BAP)
A PPP control protocol that is used on a multiprocessing connection to dynamically add and remove links.
basic disk
A physical disk that contains primary partitions or extended partitions with logical drives used by Windows 2000 and all versions of Windows NT. Basic disks can also contain volume, striped, mirror, or RAID-5 sets that were created using Windows NT 4.0 or earlier. As long as a compatible file format is used, basic disks can be accessed by MS-DOS, Windows 95, Windows 98, and all versions of Windows NT.
basic volume
A volume on a basic disk. Basic volumes include primary partitions, logical drives within extended partitions, as well as volume, striped, mirror, or RAID-5 sets that were created using Windows NT 4.0 or earlier. Only basic disks can contain basic volumes. Basic and dynamic volumes cannot exist on the same disk.
binary
A base-2 number system in which values are expressed as combinations of two digits, 0 and 1.
bindery
A database in Novell NetWare 2.x and 3.x that contains organizational and security information about users and groups.
binding
A process by which software components and layers are linked together. When a network component is installed, the binding relationships and dependencies for the components are established. Binding allows components to communicate with each other.
bit
The smallest unit of information handled by a computer. One bit expresses a 1 or a 0 in a binary numeral, or a true or false logical condition. A group of 8 bits makes up a byte, which can represent many types of information, such as a letter of the alphabet, a decimal digit, or other character. Bit is also called binary digit.
bits per second (bps)
The number of bits transmitted every second, used as a measure of the speed at which a device, such as a modem, can transfer data. A character is made up of 8 bits. In asynchronous communication, each character is preceded by a start bit and terminates with a stop bit. So for each character, 10 bits are transmitted. If a modem communicates at 2400 bits per second (bps), then 240 characters are sent every second.
block policy option
An option that prevents Group Policy objects specified in higher-level Active Directory containers from applying to a computer or user.
boot
To start or reset a computer. When first turned on or reset, the computer executes the software that loads and starts the computer's operating system, which prepares it for use.
bootable CD-ROM
An automated installation method that runs Setup from a CD-ROM. This method is useful for computers at remote sites with slow links and no local IT department. See also automated installation.
bootstrap protocol (BOOTP)
A set of rules or standards to enable computers to connect with one another, used primarily on TCP/IP networks to configure workstations without disks. RFCs 951 and 1542 define this protocol. DHCP is a boot configuration protocol that uses this protocol.
bottleneck
A condition, usually involving a hardware resource, that causes the entire system to perform poorly.
BounceKeys
A keyboard filter that assists users whose fingers bounce on the keys when pressing or releasing them.
bridgehead server
A server that receives and forwards e-mail traffic at each end of a connection agreement, similar to the task a gateway performs.
broadcast
An address that is destined for all hosts on a given network. See also broadcast network.
broadcast and unknown server (BUS)
A multicast service on an emulated local area network (ELAN) that forwards broadcast, multicast, and initial unicast data traffic sent by a LAN emulation client. See also emulated local area network (ELAN).
broadcast network
A network that supports more than two attached routers and has the ability to address a single physical message to all of the attached routers (broadcast). Ethernet is an example of a broadcast network.
browse list
Any list of items that can be browsed, such as a list of servers on a network, or a list of printers displayed in the Add Printer wizard.
browser
A client tool for navigating and accessing information on the Internet or an intranet. In the context of Windows networking, "browser" can also mean the Computer Browser service, a service that maintains an up-to-date list of computers on a network or part of a network and provides the list to applications when requested. When a user attempts to connect to a resource in a domain, the domain's browser is contacted to provide a list of available resources.
buffer
An area of memory used for intermediate storage of data until it can be used.
bulk encryption
A process in which large amounts of data, such as files, e-mail messages, or online communications sessions, are encrypted for confidentiality. It is usually done with a symmetric key algorithm. See also encryption; symmetric key encryption.
BUS
See broadcast and unknown server.
bus
A communication line used for data transfer among the components of a computer system. A bus is essentially a highway that allows different parts of the system to share data.

C

cable modem
A modem that provides broadband Internet access in the range of 10 to 30 Mbps.
cache
For DNS and WINS, a local information store of resource records for recently resolved names of remote hosts. Typically, the cache is built dynamically as the computer queries and resolves names; it helps optimize the time required to resolve queried names. See also cache file; naming service; resource record.
cache file
A file used by the Domain Name System (DNS) server to preload its names cache when service is started. Also known as the "root hints" file because resource records stored in this file are used by the DNS Service to help locate root servers that provide referral to authoritative servers for remote names. For Windows DNS servers, the cache file is named Cache.dns and is located in the %Systemroot%\System32\Dns folder. See also authoritative; cache; systemroot.
caching
For DNS, typically the server-side ability of DNS servers to store information learned about the domain namespace during the processing and resolution of name queries. With Windows 2000, caching is also available through the DNS client service (resolver) as a way for DNS clients to keep a cache of name information learned during recent queries. See also caching resolver.
caching resolver
For Windows 2000, a client-side Domain Name System (DNS) name resolution service that performs caching of recently learned DNS domain name information. The caching resolver service provides system-wide access to DNS-aware programs for resource records obtained from DNS servers during processing of name queries. Data placed in the cache is used for a limited period of time and aged according to the active Time-To-Live (TTL) value. You can set the TTL either individually for each resource record (RR) or defaults to the minimum TTL set in the SOA RR for the zone. See also cache; caching; expire interval; minimum TTL; resolver; resource record; Time To Live (TTL).
Call Manager
A software component that establishes, maintains and terminates a connection between two computers.
central site
In Systems Management Server, the primary site at the top of the Systems Management Server hierarchy, to which all other sites in the Systems Management Server system report their inventory and events.
certificate
A file used for authentication and secure exchange of data on nonsecured networks, such as the Internet. A certificate securely binds a public encryption key to the entity that holds the corresponding private encryption key. Certificates are digitally signed by the issuing certification authority and can be managed for a user, a computer, or a service.
certificate revocation list (CRL)
A document maintained and published by a certification authority that lists certificates that have been revoked. A CRL is signed with the private key of the CA to ensure its integrity. See also certificate; certification authority.
certificate services
The Windows 2000 service that issues certificates for a particular CA. It provides customizable services for issuing and managing certificates for the enterprise. See also certificate; certification authority.
certificate stores
Windows 2000 stores public key objects, such as certificates and certificate revocation lists, in logical stores and physical stores. The logical stores group public key objects for users, computers, and services. Physical stores are where the public key objects are actually stored in the registry of local computers (or in Active Directory for some user certificates). Logical stores contain pointers to the public key objects in the physical stores. Users, computers, and services share many public key objects, so logical stores enable public key objects to be shared without requiring the storage of duplicates of the objects for each user, computer, or service.
certificate template
A Windows 2000 construct that profiles certificates (that is, it pre specifies format and content) based on their intended usage. When requesting a certificate from a Windows 2000 certification authority (CA), certificate requestors will, depending on their access rights, be able to select from a variety of certificate types that are based on certificate templates, such as "User," and "Code Signing." See also certificate; certification authority.
certificate trust list (CTL)
A signed list of root certification authority certificates that an administrator considers reputable for designated purposes, such as client authentication or secure e-mail. See also certificate; certification authority; root certificate; root certification authority.
certification authority (CA)
An entity responsible for establishing and vouching for the authenticity of public keys belonging to users (end entities) or other certification authorities. Activities of a certification authority can include binding public keys to distinguished names through signed certificates, managing certificate serial numbers and certificate revocation. See also certificate; public key.
certification hierarchy
A model of trust for certificates in which certification paths are created through the establishment of parent-child relationships between certification authorities. See also certification authority; certification path.
certification path
An unbroken chain of trust from a certificate to the root certification authority in a certification hierarchy. See also certification hierarchy; certificate.
Challenge Handshake Authentication Protocol (CHAP)
A challenge-response authentication protocol for PPP connections documented in RFC 1994 that uses the industry-standard Message Digest 5 (MD5) one-way encryption scheme to hash the response to a challenge issued by the remote access server.
change log
See quorum log.
child domain
For DNS and Active Directory, a domain located in the namespace tree directly beneath another domain name (the parent domain). For example, "example.reskit.com" is a child domain of the parent domain, "reskit.com." Child domain is also called subdomain. See also parent domain; domain; directory partition.
child object
An object that resides in another object. A child object implies relation. For example, a file is a child object that resides in a folder, which is the parent object. See also object; parent object.
cipher
The method of forming a hidden message. The cipher is used to transform a readable message called plaintext (also sometimes called cleartext) into an unreadable, scrambled, or hidden message called ciphertext. Only someone with a secret decoding key can convert the ciphertext back into its original plaintext. See also ciphertext; plaintext; cryptography.
ciphertext
Text that has been encrypted using an encryption key. Ciphertext is meaningless to anyone who does not have the decryption key. See also decryption; encryption; encryption key; plaintext.
Class A IP address
A unicast IP address that ranges from 1.0.0.1 to 126.255.255.254. The first octet indicates the network, and the last three octets indicate the host on the network. See also Class B IP address; Class C IP address; IP address.
Class B IP address
A unicast IP address that ranges from 128.0.0.1 to 191.255.255.254. The first two octets indicate the network, and the last two octets indicate the host on the network. See also Class A IP address; Class C IP address; IP address.
Class C IP address
A unicast IP address that ranges from 192.0.0.1 to 223.255.255.254. The first three octets indicate the network, and the last octet indicates hosts on the network. Network Load Balancing provides optional session support for Class C IP addresses (in addition to support for single IP addresses) to accommodate clients that make use of multiple proxy servers at the client site. See also Class A IP address; Class B IP address; IP address.
Class D IP address
The Internet address class designed for IP multicast addresses. The value of the first octet for Class D IP addresses and networks varies from 224 to 239.
classless interdomain routing (CIDR)
A method of allocating public IP addresses that is not based on the original Internet Address Classes. Classless interdomain routing (CIDR) was developed to help prevent the depletion of public IP addresses and minimize the size of Internet routing tables.
clean installation
The process of installing an operating system on a clean or empty partition of a computer's hard disk.
client
Any computer or program connecting to, or requesting services of, another computer or program. See also server.
client access point
In Systems Management Server, a site system that provides a set of shared directories and files that create a common communication point between the site server and client computers.
client request
A service request from a client computer to a server computer or, for Network Load Balancing, a cluster of computers. Network Load Balancing forwards each client request to a specific host within the cluster according to the system administrator's load-balancing policy. See also client; cluster; host; server.
Client Service for Netware
A service included with Windows 2000 Professional that allows client computers to make direct connections to resources on computers running NetWare 2.x, 3.x, 4.x, or 5.x server software.
client-side extensions
Group Policy components that, in certain cases, are responsible for implementing Group Policy on the client computer.
ClonePrincipal
A tool that allows the incremental migration of users to a Windows 2000 environment without affecting the existing Windows NT production environment.
closed captioning
Alternative representation, usually text, of audio or graphics media that can be seen only on a specially equipped receiver.
cluster
A set of computers that work together to provide a service. The use of a cluster enhances both the availability of the service and the scalability of the operating system that provides the service. Network Load Balancing provides a software solution for clustering multiple computers running Windows 2000 Advanced Server that provides networked services over the Internet and private intranets. See also availability; scalability.
Cluster Administrator
An application (Cluadmin.exe) used to configure a cluster and its nodes, groups, and resources. Cluster Administrator can run on any member of the trusted domain regardless of whether the computer is a cluster node. See also cluster; Cluster Administrator extension; Cluster.exe; node; resource.
Cluster Administrator extension
A dynamic-link library (DLL) that enables Cluster Administrator to manage a custom resource type. A Cluster Administrator extension uses the Cluster Administrator Extension API. See also cluster; Cluster Administrator; resource.
cluster API
A collection of functions implemented by the cluster software and used by a cluster-aware client or server application, a cluster management application or a resource DLL. The cluster API is used to manage the cluster, cluster objects, and the cluster database. See also cluster; cluster-aware application; dynamic-link library; node; resource; resource DLL.
Cluster service
Clussvc.exe, the primary executable of the Windows Clustering component that creates a server cluster, controls all aspects of its operation, and manages the cluster database. Each node in a server cluster runs one instance of the Cluster service.
cluster-aware
The classification of an application or service that runs on a server cluster node, is managed as a cluster resource, and is designed to be aware of and interact with the server cluster environment.
cluster-aware application
An application or service that runs on a server cluster node and is managed as a cluster resource. Cluster-aware applications use the Cluster API to receive status and notification information from the server cluster. See also Cluster API; cluster-unaware application; node.
cluster-unaware application
In a server cluster, an application that can run on a node and be managed as a cluster resource but does not support the Cluster API and therefore has no inherent knowledge of its environment. Cluster-unaware applications function the same regardless of whether they are running on a node in a server cluster or on a non-clustered system. See also cluster-aware application; node.
Cluster.exe
An alternative to using Cluster Administrator to administer clusters from the Windows 2000 command prompt. Cluster.exe can be called from command scripts to automate many cluster administration tasks. See also Cluster Administrator.
code signing
To digitally sign software code to ensure its integrity and provide assurance of its origin.
cognitive disabilities
Impairments resulting from perceptual anomalies, memory loss, and learning and developmental disabilities, such as dyslexia and Down syndrome
collection
In Systems Management Server, a set of resources in a site defined by membership rules. Collections are used to distribute software, view inventory on clients, and access clients for remote tool sessions.
common gateway interface (CGI)
A server-side interface for initiating software services. A set of interfaces that describe how a Web server communicates with software on the same computer. Any software can be a CGI program if it handles input and output according to the CGI standard.
Common Internet File System (CIFS)
A protocol and a corresponding API used by application programs to request higher level application services. CIFS was formerly known as SMB (Server Message Block).
Component Object Model (COM)
An object-based programming model designed to promote software interoperability; it allows two or more applications or components to easily cooperate with one another, even if they were written by different vendors, at different times, in different programming languages, or if they are running on different computers running different operating systems. COM is the foundation technology upon which broader technologies can be built. Microsoft Object Linking & Embedding (OLE) technology and ActiveX are both built on top of COM.
Component Server
A server that provides a platform to run component services such as Application Load Balancing, Transaction Services, and Application Management.
computer account objects
Objects used to identify a specific computer account in Windows NT Server 4.0 or Windows 2000 Server.
computer name
A unique name of up to 15 uppercase characters that identifies a computer to the network. The name cannot be the same as any other computer or domain name in the network.
confidentiality
An Internet Protocol security service that ensures a message is disclosed only to intended recipients by encrypting the data.
connection agreement
A configurable section in the ADC UI that holds information such as the server names to contact for synchronization, object classes to synchronize, target containers, and the synchronization schedule. See also Active Directory Connector (ADC).
connection-oriented
A type of network protocol that requires an end-to-end virtual connection between the sender and receiver before communicating across the network.
console tree
The tree view pane in a Microsoft Management Console (MMC) that displays the hierarchical namespace. By default it is the left pane of the console window, but it can be hidden. The items in the console tree (for example, Web pages, folders, and controls) and their hierarchical organization determines the management capabilities of a console. See also Microsoft Management Console (MMC); namespace.
consoles
A framework for hosting administrative tools in the Microsoft Management Console (MMC). A console is defined by the items in its console tree, which might include folders or other containers, World Wide Web pages, and other administrative items. A console has windows that can provide views of the console tree, and the administrative properties, services, and events that are acted on by the items in the console tree.
container object
An object that can logically contain other objects. For example, a folder is a container object. See also noncontainer object; object.
convergence
The process of stabilizing a system after changes occur in the network. For routing, if a route becomes unavailable, routers send update messages throughout the internetwork, reestablishing information about preferred routes. For Network Load Balancing, a process by which hosts exchange messages to determine a new, consistent state of the cluster and to elect the host with the highest host priority, known as the default host. During convergence, a new load distribution is determined for hosts that share the handling of network traffic for specific TCP or UDP ports. See also cluster; default host; host; User Datagram Protocol (UDP).
cost
A unitless metric configured on OSPF routers that indicates the preference of using a certain link.
crypto-accelerator board
A hardware device that speeds up cryptographic operations by offloading operations to a special processor on the board.
CryptoAPI (CAPI)
An application programming interface (API) that is provided as part of Windows 2000. CryptoAPI provides a set of functions that allow applications to encrypt or digitally sign data in a flexible manner while providing protection for private keys. Actual cryptographic operations are performed by independent modules known as cryptographic service providers (CSPs). See also cryptographic service provider; private key.
cryptographic service provider (CSP)
An independent software module that performs cryptography operations such as secret key exchange, digital signing of data, and public key authentication. Any Windows 2000 service or application can request cryptography operations from a CSP. See also CryptoAPI.
cryptography
The art and science of information security. It provides four basic information security functions: confidentiality, integrity, authentication, and nonrepudiation. See also confidentiality; integrity; authentication; nonrepudiation.
custom subnet mask
A subnet mask that is not based on the Internet Address Classes. Custom subnet masks are commonly used when subnetting.

D

datagram
An unacknowledged packet of data sent to another network destination. The destination can be another device directly reachable on the local area network (LAN) or a remote destination reachable using routed delivery through a packet-switched network.
DCOM
See Distributed Component Object Model.
DCOM Configuration tool
A Windows NT Server tool that can be used to configure 32-bit applications for DCOM communication over the network. See also DCOM.
decryption
The process of making encrypted data readable again by converting ciphertext to plaintext. See also ciphertext; encryption; plaintext.
default gateway
A configuration item for the TCP/IP protocol that is the IP address of a directly reachable IP router. Configuring a default gateway creates a default route in the IP routing table.
default host
The host with the highest host priority for which a drainstop command is not in progress. After convergence, the default host handles all of the network traffic for TCP and UDP ports that are not otherwise covered by port rules. See also convergence; drainstop; host priority; port rule; user datagram protocol.
default network
In the Macintosh environment, the physical network on which the processes of the server reside as nodes and on which the server appears to users. The default network of the server must be one to which that server is attached. Only servers on AppleTalk Phase 2 internets have default networks.
default route
A route that is used when no other routes for the destination are found in the routing table. For example, if a router or end system cannot find a network route or host route for the destination, the default route is used. The default route is used to simplify the configuration of end systems or routers. For IP routing tables, the default route is the route with the network destination of 0.0.0.0 and netmask of 0.0.0.0.
default subnet mask
A subnet mask that is used on an Internet Address Class-based network. The subnet mask for Class A is 255.0.0.0. The subnet mask for Class B is 255.255.0.0. The subnet mask for Class C is 255.255.255.0.
defragmentation
The process of rewriting parts of a file to contiguous sectors on a hard disk to increase the speed of access and retrieval. When files are updated, the computer tends to save these updates on the largest continuous space on the hard disk, which is often on a different sector than the other parts of the file. When files are thus fragmented, the computer must search the hard disk each time the file is opened to find all of the parts of the file, which slows down response time. In Active Directory, defragmentation rearranges how the data is written in the directory database file to compact it. See also fragmentation.
delegation
The ability to assign responsibility for management and administration of a portion of the namespace to another user, group, or organization. For DNS, a name service record in the parent zone that lists the name server authoritative for the delegated zone. See also inheritance; parenting.
delegation wizard
A wizard used to distribute precise elements of the administrator's workload to others.
demand-dial connection
A connection, typically using a circuit-switched wide area network link, that is initiated when data needs to be forwarded. The demand-dial connection is typically terminated when there is no traffic.
demand-dial interface
A logical interface that represents a demand-dial connection (a PPP link) that is configured on the calling router. The demand-dial interface contains configuration information such as the port to use, the addressing used to create the connection (such as a phone number), authentication and encryption methods, and authentication credentials.
dependency
The state in which one resource must be online before a second resource can come online.
dependency tree
A discrete set of resources that are connected to each other by dependency relationships. All resources in a given dependency tree must be members of a single group. See also dependency; resource.
desktop
The on-screen work area in which windows, icons, menus, and dialog boxes appear.
device
Any piece of equipment that can be attached to a network or computer, for example, a computer, printer, joystick, adapter or modem card, or any other peripheral equipment. Devices normally require a device driver to function with Windows 2000. See also device driver.
device driver
A program that allows a specific device, such as a modem, network adapter, or printer, to communicate with Windows 2000. Although a device can be installed on a system, Windows 2000 cannot use the device until the appropriate driver has been installed and configured. If a device is listed in the Hardware Compatibility List (HCL), a driver is usually included with Windows 2000. Device drivers load (for all enabled devices) when a computer is started, and thereafter run invisibly. See also Hardware Compatibility List (HCL).
Dfs root
A Server Message Block share at the top of the Dfs topology that is the starting point for the links and shared files that make up the Dfs namespace. A Dfs root can be defined at the domain level, for domain-based operation, or at the server level, for stand-alone operation. Domain-based Dfs can have multiple roots in the domain but only one root on each server.
Dfs topology
The overall logical hierarchy of a distributed file system, including elements such as roots, links, shared folders, and replica sets, as depicted in the Dfs administrative console. This is not to be confused with the Dfs namespace, which is the logical view of shared resources seen by users.
DHCP
See Dynamic Host Configuration Protocol.
DHCP Manager
The primary tool used to manage DHCP servers. The DHCP Manager is a Microsoft Management Console (MMC) tool that is added to the Administrative Tools menu when the DHCP service is installed.
DHCP Service
A service, that enables a computer to function as a DHCP server and configure DHCP-enabled client computers on a network. DHCP runs on a server computer, enabling the automatic, centralized management of IP addresses and other TCP/IP configuration settings for a network's client computers.
dialog box
A window that is displayed to request or supply information. Many dialog boxes have options which must be selected before Windows NT can carry out a command.
digital certificate
See certificate.
directory
An information source (for example, a telephone directory) that contains information about people, computer files, or other objects. In a file system, a directory stores information about files. In a distributed computing environment (such as a Windows 2000 domain), the directory stores information about objects such as printers, applications, databases, and other users.
directory partition
A contiguous subtree of Active Directory that is replicated as a unit to other domain controllers in the forest that contain a replica of the same subtree. In Active Directory a single server always holds at least three directory partitions: schema, class and attribute definitions for the directory; configuration, replication topology and related metadata; domain, subtree that contains the per-domain objects for one domain. The schema and configuration directory partitions are replicated to every domain controller in a given forest. A domain directory partition is replicated only to domain controllers for that domain. In addition to a full, writable replica of its own domain directory partition, a global catalog server also holds partial, read-only replicas of all other domain directory partitions in the forest. See also full replica; Global Catalog; partial replica.
directory service
Both the directory information source and the services that make the information available and usable. A directory service enables the user to find an object given any one of its attributes. See also Active Directory; directory.
directory store
The physical storage for Active Directory directory partition replicas on a given domain controller. The store is implemented using the Extensible Storage Engine.
directory tree
A hierarchy of objects and containers in a directory that can be viewed graphically as an upside down tree, with the root object at the top. Endpoints in the tree are usually single (leaf) objects, and nodes in the tree, or branches, are container objects. A tree shows how objects are connected in terms of the path from one object to another. A simple tree is a single container and its objects. A contiguous subtree is any unbroken path in the tree, including all the members of any container in that path.
disable
To make a device nonfunctional. For example, if a device in a hardware profile is disabled, the device cannot be used while using that hardware profile. Disabling a device frees the resources that were allocated to the device.
discovery
A process by which the Windows 2000 Net Logon service attempts to locate a domain controller running Windows 2000 Server in the trusted domain. Once a domain controller has been discovered, it is used for subsequent user account authentication. For SNMP, dynamic discovery is the identification of devices attached to an SNMP network.
discretionary access control list (DACL)
The part of an object's security descriptor that grants or denies specific users and groups permission to access the object. Only the owner of an object can change permissions granted or denied in a DACL; thus access to the object is at the owner's discretion. See also access control entry; object; system access control list; security descriptor.
disk
A physical data storage device attached to a computer. See also basic disk; dynamic disk.
disk quota
The maximum amount of disk space available to a user.
display adapter
An expansion board that plugs into a personal computer to give it display capabilities. A computer's display capabilities depend on both the logical circuitry (provided in the video adapter) and the monitor. Each adapter offers several different video modes. The two basic categories of video modes are text and graphic. Within the text and graphic modes, some monitors also offer a choice of resolutions. At lower resolutions a monitor can display more colors. Modern adapters contain memory, so that the computer's RAM is not used for storing displays. In addition, most adapters have their own graphics coprocessor for performing graphics calculations. These adapters are often called graphics accelerators. See also network adapter.
distributed component object model (DCOM)
The Microsoft Component Object Model (COM) specification that defines how components communicate over Windows-based networks. Use the DCOM Configuration tool to integrate client/server applications across multiple computers. DCOM can also be used to integrate robust Web browser applications. See also DCOM Configuration tool.
distributed DHCP
A DHCP scenario in which IP addresses are distributed across a site boundary.
Distributed file system (Dfs)
A Windows 2000 service consisting of software residing on network servers and clients that transparently links shared folders located on different file servers into a single namespace for improved load sharing and data availability.
distribution folder
The folder created on the Windows 2000 distribution server to contain the Setup files.
distribution point
In Systems Management Server, a site system with the distribution point role that stores package files received from a site server. Systems Management Server clients contact distribution points to obtain programs and files after they detect that an advertised application is available from a client access point.
distribution point group
In Systems Management Server, a set of distribution points that can be managed as a single entity.
DNS server
A computer that runs DNS server programs containing name-to-IP address mappings, IP address-to-name mappings, information about the domain tree structure, and other information. DNS servers also attempt to resolve client queries.
DNS suffix
For DNS, an optional parent domain name that can be appended to the end of a relative domain name used in a name query or host lookup. The DNS suffix can be used to complete an alternate fully qualified DNS domain name to be searched when the first attempt to query a name fails.
domain
For Windows NT and Windows 2000, a networked set of computers running Windows NT or Windows 2000 that share a Security Accounts Manager (SAM) database and that can be administered as a group. A user with an account in a particular domain can log on to and access his or her account from any computer in the domain. A domain is a single security boundary of a Windows NT computer network. For DNS, a branch under a node in the DNS tree.
domain consolidation
The process of combining two or more domains into a larger domain.
domain controller
For a Windows NT Server or Windows 2000 Server domain, the server that authenticates domain logons and maintains the security policy and the master database for a domain. Both servers and domain controllers are capable of validating a user's logon, but password changes must be made by contacting the domain controller.
domain controller locator (Locator)
An algorithm that runs in the context of the Netlogon service and that finds domain controllers on a Windows 2000 network. Locator can find domain controllers by using DNS names (for IP/DNS-compatible computers) or by using NetBIOS names (for computers that are running Windows 3.x, Windows for Workgroups, Windows NT 3.5 or later, Windows 95, or Windows 98, or it can be used on a network where IP transport is not available).
domain local group
A Windows 2000 group only available in native mode domains and can contain members from anywhere in the forest, in trusted forests, or in a trusted pre-Windows 2000 domain. Domain local groups can only grant permissions to resources within the domain in which they exist. Typically, domain local groups are used to gather security principals from across the forest to control access to resources within the domain.
domain migration
The process of moving accounts, resources, and their associated security objects from one domain structure to another.
domain name
In Windows 2000 and Active Directory, the name given by an administrator to a collection of networked computers that share a common directory. For DNS, domain names are specific node names in the DNS namespace tree. DNS domain names use singular node names, known as "labels," joined together by periods (.) that indicate each node level in the namespace. See also domain name system (DNS);namespace.
domain name label
Each part of a full DNS domain name that represents a node in the domain namespace tree. Domain names are made up of a sequence of labels, such as the three labels ("noam," "reskit," and "com") that make up the DNS domain name "noam.reskit.com." Each label used in a DNS name must have 63 or fewer characters.
Domain Name System (DNS)
A hierarchical naming system used for locating domain names on the Internet and on private TCP/IP networks. DNS provides a service for mapping DNS domain names to IP addresses, and vice versa. This allows users, computers, and applications to query the DNS to specify remote systems by fully qualified domain names rather than by IP addresses. See also domain; ping.
domain namespace
The database structure used by the Domain Name System (DNS). See also Domain Name System (DNS).
domain restructure
The process of reorganizing one domain structure into another that typically results in the accounts, groups, and trusts being altered.
domain tree
In DNS, the inverted hierarchical tree structure that is used to index domain names. Domain trees are similar in purpose and concept to the directory trees used by computer filing systems for disk storage. See also domain name; namespace.
domain upgrade
The process of replacing an older operating system version on the computers in a domain with a later version.
domain-based Dfs
An implementation of Dfs that stores its configuration information in Active Directory. Because this information is made available on every domain controller in the domain, domain-based Dfs provides high availability for any distributed file system in the domain. A domain-based Dfs root has the following characteristics: it must be hosted on a domain member server, it has its topology published automatically to Active Directory, it can have root-level shared folders and it supports root and file replication through FRS.
drain
For Network Load Balancing, a program that disables new traffic handling for the rule whose port range contains the specified port. All ports specified by the port rule are affected. If "all" is specified for the port, this command is applied to the ports covered by all port rules. New connections to the specified host or hosts are not allowed, but all active connections are maintained. To disable active connections, use the disable command. This command has no effect if the specified hosts have not started cluster operations. See also drainstop; port rule.
drainstop
For Network Load Balancing, a tool that disables all new traffic handling on the specified hosts. The hosts then enter the draining mode to complete existing connections. While draining, hosts remain in the cluster and stop their cluster operations when there are no more active connections. You can terminate draining mode by explicitly stopping cluster mode with the stop command or by restarting new traffic handling with the start command. To drain connections from a specific port, use the drain command. See also drain.
dump file
A file used to store data in memory in case of failure.
Dvorak keyboard
An alternative keyboard with a layout that makes the most frequently typed characters more accessible to people who have difficulty typing on the standard QWERTY layout.
dynamic disk
A physical disk that is managed by Disk Management. Dynamic disks can contain only dynamic volumes (that is, volumes created with Disk Management). Dynamic disks cannot contain partitions or logical drives, nor can they be accessed by MS-DOS. See also dynamic volume; partition.
Dynamic Host Configuration Protocol (DHCP)
A networking protocol that provides safe, reliable, and simple TCP/IP network configuration and offers dynamic configuration of Internet Protocol (IP) addresses for computers. DHCP ensures that address conflicts do not occur and helps conserve the use of IP addresses through centralized management of address allocation.
dynamic routing
The use of routing protocols to update routing tables. Dynamic routing responds to changes in the internetwork topology.
dynamic update
An updated specification to the Domain Name System (DNS) standard that permits hosts that store name information in DNS to dynamically register and update their records in zones maintained by DNS servers that can accept and process dynamic update messages.
dynamic volume
A logical volume that is created using Disk Management. Dynamic volumes include simple, spanned, striped, mirrored, and RAID-5 volumes. Dynamic volumes must be created on dynamic disks. See also dynamic disk; volume.
dynamic-link library (DLL)
A feature of the Microsoft Windows family of operating systems and the OS/2 operating system. DLLs allow executable routines, generally serving a specific function or set of functions, to be stored separately as files with .dll extensions, and to be loaded only when needed by the program that calls them.

E

embedded object
Information created in another application that has been pasted inside a document. When information is embedded, you can edit it in the new document using toolbars and menus from the original program. When you double-click the embedded icon, the toolbars and menus from the program used to create the information appear. Embedded information is not linked to the original file. If you change information in one place, it is not updated in the other. See also linked object.
emergency repair disk (ERD)
A disk, created by the Backup utility, that contains information about your current Windows system settings. This disk can be used to repair your computer if it will not start or if your system files are damaged or erased.
emulated local area network (ELAN)
A logical network initiated by using the mechanisms defined by LAN emulation. This could include ATM and previously attached end stations.
enable
To make a device functional. For example, if a device in your hardware configuration settings is enabled the device is available for use when your computer uses that hardware configuration.
encrypted password
A password that is scrambled. Encrypted passwords are more secure than plaintext passwords, which are susceptible to network sniffers.
encryption
The process of disguising a message or data in such a way as to hide its substance.
encryption key
A value used by an algorithm to encode or decode a message.
end-to-end encryption
Data encryption between the client application and the server hosting the resource or service being accessed by the client application.
enterprise certification authority
A Windows 2000 certification authority that is fully integrated with Active Directory. See also certification authority; stand-alone certification authority.
entry
Entries are the lowest level element in the registry. They appear in the right pane of a Registry Editor window. Each entry consists of an entry name, its data type, and its value.

They store the actual configuration data that affects the operating system and programs that run on the system. As such, they are different from keys and subkeys, which are containers.

Entries are referenced by their registry path and name. The amount and type of data that can be stored in an entry is determined by the data type of the entry.

environment variable
A string consisting of environment information, such as a drive, path, or filename, associated with a symbolic name that can be used by Windows NT and Windows 2000. You use the System option in Control Panel or the set command from the command prompt to define environment variables.
error detection
A technique for detecting when data is lost during transmission. This allows the software to recover lost data by requesting that the transmitting computer retransmit the data.
event
Any significant occurrence in the system or an application that requires users to be notified or an entry to be added to a log.
Event Log
The file in which event logging entries are recorded.
event logging
The Windows 2000 process of recording an audit entry in the audit trail whenever certain events occur, such as services starting and stopping and users logging on and off and accessing resources. You can use Event Viewer to review Services for Macintosh events as well as Windows 2000 events.
event types
Errors, basic actions with time stamps, or device problems.
everyone category
In the Macintosh environment, one of the user categories to which permissions for a folder are assigned. Permissions given to everyone apply to all users who use the server, including guests.
expire interval
For DNS, the number of seconds that DNS servers operating as secondary masters for a zone use to determine if zone data should be expired when the zone is not refreshed and renewed. See also zone.
explicit trust relationship
A trust relationship from Windows NT in which an explicit link is made in one direction only. Explicit trusts can also exist between Windows NT domains and Windows 2000 domains, and between forests.
export
In NFS, to make a file system available by a server to a client for mounting.
extended partition
A portion of a basic disk that can contain logical drives. To have more than four volumes on your basic disk, you need to use an extended partition. Only one of the four partitions allowed per physical disk can be an extended partition, and no primary partition needs to be present to create an extended partition. You can create extended partitions only on basic disks. See also basic disk; logical drive; partition; primary partition; unallocated space.
Extensible Authentication Protocol (EAP)
An extension to PPP that allows for arbitrary authentication mechanisms to be employed for the validation of a PPP connection.
external network number
A 4-byte hexadecimal number used for addressing and routing purposes. The external network number is associated with physical network adapters and networks. To communicate with each other, all computers on the same network that use a given frame type must have the same external network number. All external network numbers must be unique to the IPX internetwork. See also internal network number; Internetwork Packet Exchange (IPX).
external routes
A route that is not within an OSPF autonomous system.
extranet
A limited subset of computers or users on a public network, typically the Internet, that are able to access an organization's internal network. Typically the computers or users belong to partner organizations.
eye-gaze pointing device
An input device that uses vision to control an on-screen cursor that allows users to press on-screen buttons in dialog boxes, to choose menu items, and select cells or text.

F

failback (v., fail back)
In a server cluster, the moving of a failed over group to the next node on the group's Preferred Owners list. See also failover; node; resource.
failover (v., fail over)
In a server cluster, the means of providing high availability. Upon failure, either of a resource in a group or of the node where the group is online, the cluster takes the group offline on that node, then brings it online on another node. See also node; resource.
FAT32
A derivative of the file allocation table file system. FAT32 supports smaller cluster sizes than FAT, which results in more efficient space allocation on FAT32 drives. See also file allocation table (FAT); NTFS file system.
fault tolerance
The assurance of data integrity when hardware failures occur. On the Windows NT and Windows 2000 platforms, fault tolerance is provided by the Ftdisk.sys driver.
FDDI
See Fiber Distributed Data Interface.
Fiber Distributed Data Interface (FDDI)
A type of network media designed to be used with fiber-optic cabling. See also LocalTalk; Token Ring.
file allocation table (FAT)
A file system based on a file allocation table (FAT) maintained by some operating systems, including Windows NT and Windows 2000, to keep track of the status of various segments of disk space used for file storage.
File Replication service
A service used by the Distributed file system (Dfs) to synchronize content between assigned replicas, and by Active Directory Sites and Services to replicate topological and global catalog information across domain controllers.
file server
A server that provides organization-wide access to files, programs, and applications.
file system
In an operating system, the overall structure in which files are named, stored, and organized. NTFS, FAT, and FAT32 are types of file systems.
File Transfer Protocol (FTP)
A protocol that defines how to transfer files from one computer to another over the Internet and a client/server application that moves files using this protocol.
filter
In IPSec, a rule that provides the ability to trigger security negotiations for a communication based on the source, destination, and type of IP traffic.
filtering mode
For Network Load Balancing, the method by which network traffic inbound to a cluster is handled by the hosts within the cluster. Traffic can either be handled by a single server, load balanced among the hosts within the cluster, or disabled completely. See also server.
FilterKeys
A Windows 2000 accessibility feature that allows people with physical disabilities to adjust keyboard response time. See also BounceKeys; RepeatKeys; SlowKeys.
filters
In IP and IPX packet filtering, a series of definitions that indicate to the router the type of traffic allowed or disallowed on each interface.
firewall
A combination of hardware and software that provides a security system, usually to prevent unauthorized access from outside to an internal network or intranet. A firewall prevents direct communication between network and external computers by routing communication through a proxy server outside of the network. The proxy server determines whether it is safe to let a file pass through to the network. A firewall is also called a security-edge gateway.
folder redirection
A Group Policy option that allows you to redirect designated folders to the network.
forest
A collection of one or more Windows 2000 Active Directory trees, organized as peers and connected by two-way transitive trust relationships between the root domains of each tree. All trees in a forest share a common schema, configuration, and global catalog. When a forest contains multiple trees, the trees do not form a contiguous namespace.
form
Specifies the paper size (such as letter or legal) assigned to a tray on a printer. A form defines physical characteristics such as paper size and printer area margins of the paper or other print media.
FORTEZZA
A family of security products, including PCMCIA-based cards, compatible serial port devices, combination cards (such as FORTEZZA/Modem and FORTEZZA/Ethernet), server boards, and others. FORTEZZA is a registered trademark held by the National Security Agency.
fractional T1
A T1 line that consists of 23 B channels and 1 D channel. The single D channel is used for clocking purposes.
fragmentation
The scattering of parts of the same disk file over different areas of the disk. Fragmentation occurs as files on a disk are deleted and new files are added. It slows disk access and degrades the overall performance of disk operations, although usually not severely. See also defragmentation.
frame
In synchronous communication, a package of information transmitted as a single unit from one device to another. Frame is a term most often used with Ethernet networks. A frame is similar to the packet used on other networks. See also packet.
free space
Available space that is used to create logical drives within an extended partition. See also extended partition; logical drive; unallocated space.
FTP
See File Transfer Protocol.
full replica
A read/write replica of a directory partition that contains all attributes of all objects in the partition. A full replica is also called a master replica. See also partial replica
full zone transfer (AXFR)
The standard query type supported by all DNS servers to update and synchronize zone data when the zone is changed. When a DNS query is made using AXFR as the specified query type, the entire zone is transferred as the response. See also incremental zone transfer (IXFR); zone; zone transfer.
fully qualified domain name (FQDN)
A DNS domain name that has been stated so as to indicate its precise location in the domain namespace tree. For example, client1.reskit.com. The FQDN is also known as a full computer name.

G

gateway
A device connected to multiple physical TCP/IP networks, capable of routing or delivering IP packets between them. A gateway translates between different transport protocols or data formats (for example, IPX and IP) and is generally added to a network primarily for its translation ability. See also IP address; Internet Protocol router.
Gateway Service for NetWare
A service that creates a gateway in which Microsoft clients can access NetWare core protocol networks, such as NetWare file and print services, through a Windows 2000 server.
generic Quality of Service
A method by which a TCP/IP network can offer Quality of Service guarantees for multimedia applications. Generic Quality of Service allocates different bandwidths for each connection on an as-needed basis.
Gigabit Ethernet
The Ethernet standard that transmits data at 1billion bits per second, or more.
Global Catalog
An Active Directory service that stores directory information from all source domains in a single location in the installation's tree. Users can submit queries to the Global Catalog about objects without regard to the logical or physical location of the object. The Global Catalog is optimized for high performance in resolving queries.
global group
For Windows 2000 Server, a group that can be used in its own domain, in member servers and workstations of the domain, and in trusting domains. In all those places a global group can be granted rights and permissions and can become a member of local groups. However, a global group can contain user accounts only from its own domain. See also group; local group.
globally unique identifier (GUID)
A 16-byte value generated from the unique identifier on a device, the current date and time, and a sequence number. A GUID is used to identify a particular device or component.
graphical user interface (GUI)
A display format, like that of Windows, that represents a program's functions with graphic images such as buttons and icons. GUIs allow a user to perform operations and make choices by pointing and clicking with a mouse.
group
A collection of users, computers, contacts and other groups. Groups can be used as security or as e-mail distribution collections. Distribution groups are used only for e-mail. Security groups are used both to grant access to resources and as e-mail distribution lists. In a server cluster, a collection of resources, and the basic unit of failover. See also domain local group; global group; native mode; universal group.
group memberships
The groups to which a user account belongs. Permissions and rights granted to a group are also provided to its members. In most cases, the actions a user can perform in Windows 2000 are determined by the group memberships of the user account the user is logged on to. See also group.
Group Policy
An administrator's tool for defining and controlling how programs, network resources, and the operating system operate for users and computers in an organization. In an Active Directory environment, Group Policy is applied to users or computers on the basis of their membership in sites, domains, or organizational units.
Group Policy object
A collection of Group Policy settings. Group Policy objects are the documents created by the Group Policy snap-in. Group Policy objects are stored at the domain level, and they affect users and computers contained in sites, domains, and organizational units. Each Windows 2000-based computer has exactly one group of settings stored locally, called the local Group Policy object.
guest
A Services for Macintosh user who does not have a user account or who does not provide a password. When a Macintosh user assigns permissions to everyone, these permissions are given to the guests and users of the group.
guest account
A built-in account used to log on to a computer running Windows 2000 when a user does not have an account on the computer or domain or in any of the domains trusted by the computer's domain.
GUI mode
The portion of Setup that uses a graphical user interface (GUI).

H

handle
In the user interface, an interface added to an object that facilitates moving, sizing, reshaping, or other functions pertaining to an object. In programming, a pointer to a pointer-that is, a token that lets a program access a resource identified.
hardware abstraction layer (HAL)
A thin layer of software provided by the hardware manufacturer that hides, or abstracts, hardware differences from higher layers of the operating system. Through the filter provided by the HAL, different types of hardware all look alike to the rest of the operating system. This allows Windows NT and Windows 2000 to be portable from one hardware platform to another. The HAL also provides routines that allow a single device driver to support the same device on all platforms. The HAL works closely with the kernel.
hardware compatibility list (HCL)
A list of the devices supported by Windows 2000.
hardware failure
A malfunction of a physical component, such as a disk head failure or memory error.
hardware inventory
The automated process Systems Management Server uses to gather detailed information about the hardware in use on client computers in a Systems Management Server site.
hardware router
A router that performs routing as a dedicated function and has specific hardware designed and optimized for routing.
hardware type
A classification for similar devices. For example, Imaging Device is a hardware type for digital cameras and scanners.
heartbeat
In a server cluster or Network Load Balancing cluster, a periodic message sent between nodes to detect system failure of any node.
hexadecimal
A base-16 number system whose numbers are represented by the digits 0 through 9 and the letters A (equivalent to decimal 10) through F (equivalent to decimal 15).
hierarchical storage management (HSM)
A technology that automates storage management and lowers storage costs by automatically migrating infrequently accessed files from local storage to remote storage and recalling the files upon user demand.
high availability
The ability to keep an application or service operational and usable by clients most of the time.
hop count
The Transport Control field indicates the number of IPX routers that have processed the IPX packet.
host
A Windows 2000 computer that runs a server program or service used by network or remote clients. For Network Load Balancing, a cluster consists of multiple hosts connected over a local area network.
host ID
A number used to identify an interface on a physical network bounded by routers. The host ID should be unique to the network.
host name
The name of a computer on a network. In the Windows 2000 Server Resource Kit, host name is used to refer to the first label of a fully qualified domain name. See also hosts file.
host priority
For Network Load Balancing, a host's precedence for handling default network traffic for TCP and UDP ports. It is used if a host within the cluster goes offline, and determines which host within the cluster will assume responsibility for the traffic previously handled by the offline host. See also User Datagram Protocol (UDP).
Hosts
A file containing lists of known IP addresses, used by TCP/IP to locate computers on a network or the Internet.
hosts file
A local text file in the same format as the 4.3 Berkeley Software Distribution (BSD) UNIX/etc/hosts file. This file maps host names to IP addresses. In Windows 2000, this file is stored in the \%Systemroot%\System32\Drivers\Etc folder. See also systemroot.
hot keys
A Windows 2000 feature that allows quick activation of specified accessibility features through a combination of keys pressed in unison.
hub
A network-enabled device joining communication lines at a central location, providing a common connection to all devices on the network.
hub-and-spoke
A WINS server configuration that uses a central "hub" as a point of contact for many outlying WINS server "spokes" to improve convergence time.
Hypertext Markup Language (HTML)
A simple markup language used to create hypertext documents that are portable from one platform to another. HTML files are simple ASCII text files with embedded codes (indicated by markup tags) to indicate formatting and hypertext links. HTML is used for formatting documents on the World Wide Web.
Hypertext Transfer Protocol (HTTP)
The protocol used to transfer information on the World Wide Web. An HTTP address (one kind of URL or Uniform Resource Locator) takes the form: http://www.microsoft.com

I

IKE
See Internet Key Exchange.
impersonation
A circumstance that occurs when Windows 2000 Server allows one process to take on the security attributes of another.
impersonation token
An access token that has been created to capture the security information of a client process, allowing a service to "impersonate" the client process in security operations. See also access token; primary token.
incremental zone transfer (IXFR)
An alternate query type that can be used by some DNS servers to update and synchronize zone data when a zone is changed. When incremental zone transfer is supported between DNS servers, servers can keep track of and transfer only those incremental resource record changes between each version of the zone. See also full zone transfer (AXFR); zone; zone transfer.
infrared (IR)
Light that is beyond red in the color spectrum. While the light is not visible to the human eye, infrared transmitters and receivers can send and receive infrared signals. See also Infrared Data Association; infrared device; infrared port.
Infrared Data Association (IrDA)
A networking protocol used to transmit data created by infrared devices. Infrared Data Association is also the name of the industry organization of computer, component, and telecommunications vendors who establish the standards for infrared communication between computers and peripheral devices, such as printers. See also infrared; infrared device; infrared port.
infrared device
A computer, or a computer peripheral such as a printer, that can communicate using infrared light. See also infrared.
infrared port
An optical port on a computer to communicate with other computers or devices using infrared light, without cables. Infrared ports can be found on some portable computers, printers, and cameras. An infrared port can also be added to a computer with an IR dongle (or hardware key security device) connected to a PCI card, serial port, parallel port (for a printer), or direct connection to the motherboard. See also infrared device; infrared port.
inheritance
The ability to build new object classes from existing object classes. The new object is defined as a subclass of the original object. The original object becomes a superclass of the new object. A subclass inherits the attributes of the superclass, including structure rules and content rules.
insertion point
The place where text will be inserted when typed. The insertion point usually appears as a flashing vertical bar in an application's window or in a dialog box.
install
When referring to software, to add program files and folders to your hard disk and related data to your registry so that the software will run properly. "Installing" contrasts with "upgrading," where existing program files, folders, and registry entries are updated to a more recent version. When referring to hardware, to physically connect the device to your computer, to load device drivers onto your computer, and to configure device properties and settings. See also device driver; registry.
integrity
An Internet Protocol security property that protects data from unauthorized modification in transit, ensuring that the data received is exactly the same as the data sent. Hash functions sign each packet with a cryptographic checksum, which the receiving computer checks before opening the packet. If the packet-and therefore signature-has changed, the packet is discarded.
IntelliMirror
A set of Windows 2000 features used for desktop change and configuration management. When IntelliMirror is used in both the server and client, the users' data, applications, and settings follow them when they move to another computer. Administrators can use IntelliMirror to perform remote installation of Windows 2000.
interface
In networking, a logical device over which packets can be sent and received. In the Routing and Remote Access administrative tool, it is a visual representation of the network segment that can be reached over the LAN or WAN adapters. Each interface has a unique name. See also local area network (LAN); network adapter; routing; wide area network (WAN).
internal namespace
A private namespace that is only used by users within an organization.
internal network number
A 4-byte hexadecimal number used for addressing and routing purposes. The internal network number identifies a virtual network inside a computer. The internal network number must be unique to the IPX internetwork. Internal network number is also called virtual network number. See also external network number; Internetwork Packet Exchange (IPX).
internet
Two or more network segments connected by routers. Another term for internetwork. With Services for Macintosh, an internet can be created by connecting two or more AppleTalk networks to a computer running Windows 2000 Server. With TCP/IP, an internet can be created by connecting two or more IP networks to a multihomed computer running either Windows 2000 Server or Windows 2000 Professional. IP forwarding must be enabled to route between attached IP network segments.
Internet
A worldwide public TCP/IP internetwork consisting of thousands of networks, connecting research facilities, universities, libraries, and private companies.
Internet Assigned Numbers Authority (IANA)
An organization that delegates IP addresses and their allocation to organizations such as the InterNIC.
Internet Control Message Protocol (ICMP)
A required maintenance protocol in the TCP/IP suite that reports errors and allows simple connectivity. ICMP is used by the ping tool to perform TCP/IP troubleshooting.
Internet Engineering Task Force (IETF)
An open community of network designers, operators, vendors, and researchers concerned with the evolution of Internet architecture and the smooth operation of the Internet. Technical work is performed by working groups organized by topic areas (such as routing, transport, and security) and through mailing lists. Internet standards are developed in IETF Requests for Comments (RFCs), which are a series of notes that discuss many aspects of computing and computer communication, focusing on networking protocols, programs, and concepts.
Internet Group Management Protocol (IGMP)
A protocol in the TCP/IP protocol suite that is responsible for the management of IP multicast group membership.
Internet Information Services (IIS)
Software services that support Web site creation, configuration, and management, along with other Internet functions. Internet Information Services include Network News Transfer Protocol (NNTP), File Transfer Protocol (FTP), and Simple Mail Transfer Protocol (SMTP). See also File Transfer Protocol (FTP); Network News Transfer Protocol (NNTP); Simple Mail Transfer Protocol (SMTP).
Internet Key Exchange (IKE)
A protocol that establishes the security association and shared keys necessary for two parties to communicate with Internet Protocol security.
Internet Protocol (IP)
A routable protocol in the TCP/IP protocol suite that is responsible for IP addressing, routing, and the fragmentation and reassembly of IP packets.
Internet Protocol router
A system connected to multiple physical TCP/IP networks that can route or deliver IP packets between the networks. See also packet; router; routing; TCP/IP.
Internet Protocol security (IPSec)
A set of industry-standard, cryptography-based protection services and protocols. IPSec protects all protocols in the TCP/IP protocol suite and Internet communications using L2TP. See also Layer 2 Tunneling Protocol (L2TP).
Internet service provider (ISP)
A company that provides individuals or companies access to the Internet and the World Wide Web. An ISP provides a telephone number, a user name, a password and other connection information so users can connect their computers to the ISP's computers. An ISP typically charges a monthly and/or hourly connection fee.
internetwork
At least two network segments connected using routers.
Internetwork packet exchange (IPX)
A network protocol native to NetWare that controls addressing and routing of packets within and between LANs. IPX does not guarantee that a message will be complete (no lost packets). See also Internetwork Packet Exchange/Sequenced Packet Exchange (IPX/SPX).
intranet
A network within an organization that uses Internet technologies and protocols, but is available only to certain people, such as employees of a company. An intranet is also called a private network.
inventory
Information that Systems Management Server inventory client agents collect for each client in a site. The inventory can include hardware and software information and collected files, depending on the administrator-defined configuration.
IP address
A 32-bit address used to identify a node on a an IP internetwork. Each node on the IP internetwork must be assigned a unique IP address, which is made up of the network ID, plus a unique host ID. This address is typically represented with the decimal value of each octet separated by a period (for example, 192.168.7.27). In Windows 2000, the IP address can be configured manually or dynamically through DHCP. See also Dynamic Host Configuration Protocol (DHCP); node.
IPSec
See Internet Protocol security.
IPSec driver
An Internet Protocol security mechanism, activated when Internet Protocol security is configured for a computer, that watches packets for a match with an IP filter in the computer's active Internet Protocol security policy. The IPSec driver also performs the actual encryption and decryption of the data. See also Internet Protocol Security.
IPSec driver
A driver that uses the IP Filter List from the active IPSec policy to watch for outbound IP packets that must be secured and inbound IP packets that need to be verified and decrypted.

K

Kerberos authentication protocol
An authentication mechanism used to verify user or host identity. The Kerberos v5 protocol is the default authentication service for Windows 2000. Internet Protocol security and the QoS admission control service use the Kerberos protocol for authentication. See also QoS admission control service; Internet Protocol security (IPSec).
key
A secret code or number required to read, modify, or verify secured data. Keys are used in conjunction with algorithms to secure data. Windows 2000 automatically handles key generation. For the registry, a key is an entry in the registry that can contain both subkeys and entries. In the registry structure, keys are analogous to folders, and entries are analogous to files. In the Registry Editor window, a key appears as a file folder in the left pane. In an answer file, keys are character strings that specify parameters from which Setup obtains the needed data for unattended installation of the operating system.
key distribution center (KDC)
A network service that supplies session tickets and temporary session keys used in the Kerberos authentication protocol. In Windows 2000, the KDC runs as a privileged process on all domain controllers. The KDC uses Active Directory to manage sensitive account information such as passwords for user accounts. See also Kerberos authentication protocol; session ticket.
key exchange
Confidential exchange of secret keys online, which is commonly done with public key cryptography. See also public key cryptography.
key management
Secure management of private keys for public key cryptography. Windows 2000 manages private keys and keeps them confidential with CryptoAPI and CSPs. See also private key; CryptoAPI; cryptographic service providers.
key pair
A private key and its related public key. See also public/private key pair.
keyboard filters
Special timing and other devices that compensate for erratic motion tremors, slow response time, and other dexterity impairments.

L

L2TP
See Layer Two Tunneling Protocol.
label
See domain name label.
LAN
See local area network.
LAN emulation (LANE)
A set of protocols that allow existing Ethernet and Token Ring LAN services to overlay an ATM network. LANE allows connectivity among LAN- and ATM-attached stations. See also Asynchronous Transfer Mode (ATM).
LAN emulation client (LEC)
The client on an emulated local area network (ELAN) that performs data forwarding, address resolution, and other control functions. The LEC resides on end stations in an emulated local area network (ELAN). See also asynchronous transfer mode; emulated local area network (ELAN); LAN emulation.
LAN emulation server (LES)
The central control point for an emulated local area network (ELAN). Enables LANE clients to join the emulated local area network (ELAN) and resolves LAN addresses to ATM addresses. See also ATM; emulated local area network (ELAN); LAN emulation (LANE).
LAN manager replication
The file replication service used under Windows NT. See File Replication service.
large window support
In TCP communications, the largest amount of data that can be transferred without acknowledgment. The window has a fixed size. Large window support dynamically recalculates the window size and allows larger amounts of data to be transferred at one time causing greater throughput.
latency
See replication latency.
layer 2 tunneling protocol (L2TP)
A tunneling protocol that encapsulates PPP frames to be sent over IP, X.25, Frame Relay, or ATM networks. L2TP is a combination of the Point-to-Point Tunneling Protocol (PPTP) and Layer 2 Forwarding (L2F), a technology proposed by Cisco Systems, Inc.
LDAP API
See Lightweight Directory Access Protocol Access Programming Interface
license service
A server in Terminal Services that stores all client licenses that have been downloaded for a Terminal server and tracks the licenses that have been issued to client computers or terminals.
Lightweight Directory Access Protocol (LDAP)
A directory service protocol that runs directly over TCP/IP and the primary access protocol for Active Directory. LDAP version 3 is defined by a set of Proposed Standard documents in Internet Engineering Task Force (IETF) RFC 2251. See also Lightweight Directory Access Protocol Access Programming Interface (LDAP API).
Lightweight Directory Access Protocol Access Programming Interface (LDAP API)
A set of low-level C-language APIs to the LDAP protocol.
Line Printer Daemon (LPD)
A service on the print server that receives documents (print jobs) from line printer remote (LPR) tools running on client systems. See also Line Printer Remote (LPR).
Line Printer Remote (LPR)
A connectivity utility that runs on client systems and is used to print files to a computer running an LPD server. See also Line Printer Daemon (LPD).
link state database (LSDB)
A map of an area maintained by OSPF routers. It is updated after any change in the network topology. The link state database is used to compute IP routes, which must be computed again after any change in the topology. See also open shortest path first (OSPF).
linked object
An object that is inserted into a document but still exists in the source file. When information is linked, the new document is updated automatically if the information in the original document changes. See also embedded object.
load-balancing
Scaling the performance of a server-based program (such as a Web server) by distributing its client requests across multiple servers within the cluster by Windows Clustering. Each host can specify the load percentage that it will handle, or the load can be equally distributed across all the hosts. If a host fails, Windows Clustering dynamically redistributes the load among the remaining hosts. See also client request; cluster; host; scalability; server.
local area network (LAN)
A communications network connecting a group of computers, printers, and other devices located within a relatively limited area (for example, a building). A LAN allows any connected device to interact with any other on the network.. See also wide area network (WAN).
local computer
The computer that a user is currently logged on to. More specifically, a local computer is a computer that can be accessed directly without using a communications line or a communications device, such as a network adapter or a modem. Similarly, running a local program means running the program on your computer, as opposed to running it from a server.
local group
For computers running Windows 2000 Professional and member servers, a group that is granted permissions and rights from its own computer to only those resources on its own computer on which the group resides. See also global group.
local printer
A printer that is directly connected to one of the ports on your computer.
local storage
For Windows 2000 Server, NTFS disk volumes used as primary data storage. Such disk volumes can be managed by Remote Storage by copying infrequently accessed files to remote, or secondary, storage. See also remote storage.
LocalTalk
The Apple networking hardware built into every Macintosh computer. LocalTalk includes the cables and connector boxes to connect components and network devices that are part of the AppleTalk network system. LocalTalk was formerly known as the AppleTalk Personal Network.
lock
To make a file inaccessible. When more than one user can manipulate a file, that file is locked when a user accesses it in order to prevent more than one user from modifying the file simultaneously.
log file
A file that stores messages generated by an application, service, or operating system. These messages are used to track the operations performed. For example, Web servers maintain log files listing every request made to the server. Log files are usually ASCII files and often have a .log extension. In Backup, a file that contains a record of the date the tapes were created and the names of files and directories successfully backed up and restored. The Performance Logs and Alerts service also creates log files.
log off
To stop using a network, which removes the user name from active use until the user logs on again.
log on
To begin using a network by providing a user name and password that identifies a user to the network.
logical drive
A volume created within an extended partition on a basic disk. You can format and assign a drive letter to a logical drive. Only basic disks can contain logical drives. A logical drive cannot span multiple disks. See also basic disk; basic volume; extended partition.
logical IP subnet (LIS)
A group of IP hosts/members belonging to the same IP subnet and whose host ATMARP server ATM address is the same.
logical printer
The software interface between the operating system and the printer in Windows 2000. While a printer is the device that does the actual printing, a logical printer is its software interface on the print server. This software interface determines how a print job is processed and how it is routed to its destination (to a local or network port, to a file, or to a remote print share). When a document is printed, it is spooled (or stored) on the logical printer before it is sent to the printer itself. See also spooling.
loopback option
An option that allows an administrator to apply Group Policy settings based on the computer that the user logs on to, even after the user settings have been processed.

M

master domain
A Windows NT domain that holds user account data. Also known as an account domain.
master server
In a DNS zone transfer, the computer that is the source of the zone. Master servers can vary and are one of two types (either primary or secondary masters), depending on how the server obtains its zone data. See also primary server; secondary server; zone; zone transfer.
maximum password age
The period of time a password can be used before the system requires the user to change it.
media access control
A layer in the network architecture of Windows NT and Windows 2000 that deals with network access and collision detection.
media access control address
The address used for communication between network adapters on the same subnet. Each network adapter has an associated media access control address.
member server
A computer that runs Windows 2000 Server but is not a domain controller of a Windows 2000 domain. Member servers participate in a domain, but do not store a copy of the directory database. Permissions can be set on a member server's resources that allow users to connect to the server and use its resources. Resource permissions can be granted for domain global groups and users as well as for local groups and users. See also domain controller; global group; local group.
metric
A number used to indicate the cost of a route in the IP routing table so that one can select the best route among possible multiple routes to the same destination.
Microsoft Component Services
A program that runs on an Internet or other server and manages the application and database transaction requests for a client's user. Component Services screens the user and client computer from having to formulate requests for unfamiliar databases and forwards the requests to database servers. It also manages security, connection to other servers, and transaction integrity.
Microsoft Management Console (MMC)
A framework for hosting administrative consoles. A console is defined by the items on its console tree, which might include folders or other containers, World Wide Web pages, and other administrative items. A console has one or more windows that can provide views of the console tree and the administrative properties, services, and events that are acted on by the items in the console tree. The main MMC window provides commands and tools for authoring consoles. The authoring features of MMC and the console tree might be hidden when a console is in User Mode. See also console tree.
migrate
The process of moving files or programs from an older file format or protocol to a more current format or protocol. For example, WINS database entries can be migrated from static WINS database entries to dynamically-registered DHCP entries.
migration
The process of copying an object from local storage to remote storage.
Mini-Setup wizard
A wizard that starts the first time a computer boots from a hard disk that has been duplicated. The wizard gathers any information that is needed for the newly duplicated hard disk.
minimum password length
The fewest characters a password can contain.
minimum TTL
A default Time-To-Live (TTL) value set in seconds for use with all resource records in a zone. This value is set in the start-of-authority (SOA) resource record for each zone. By default, the DNS server includes this value in query answers to inform recipients how long it can store and use resource records provided in the query answer before they must expire the stored records data. When TTL values are set for individual resource records, those values will override the minimum TTL. See also Time To Live (TTL).
miniport drivers
A driver that is connected to an intermediate driver and a hardware device.
mirror set
A fully redundant or shadow copy of data. Mirror sets provide an identical twin for a selected disk; all data written to the primary disk is also written to the shadow or mirror disk. This gives you instant access to another disk with a copy of the information. Mirror sets provide fault tolerance. See also stripe set with parity; volume set.
mirrored volume
A fault-tolerant volume that duplicates data on two physical disks. The mirror is always located on a different disk. If one of the physical disks fails, the data on the failed disk becomes unavailable, but the system continues to operate by using the unaffected disk. A mirrored volume is slower than a RAID-5 volume in read operations but faster in write operations. Mirrored volumes can only be created on dynamic disks. In Windows NT 4.0, a mirrored volume was known as a mirror set. See also dynamic disk; dynamic volume; fault tolerance; redundant array of independent disks (RAID); volume.
mixed mode
The default mode setting for domains on Windows 2000 domain controllers. Mixed mode allows Windows 2000 domain controllers and Windows NT backup domain controllers to co-exist in a domain. Mixed mode does not support the universal and nested group enhancements of Windows 2000. You can change the domain mode setting to Windows 2000 native mode after all Windows NT domain controllers are either removed from the domain or upgraded to Windows 2000. See also native mode.
mixed mode domains
A networked set of computers running more than one operating system, for example, both Windows NT and Windows 2000.
MMC
See Microsoft Management Console.
MMC snap-in
A type of management tool that you can add to the console tree of a console supported by Microsoft Management Console (MMC), for example, Device Manager. A snap-in can be either a stand-alone or an extension snap-in. A stand-alone snap-in can be added by itself; an extension snap-in can only be added to extend another snap-in. See also Microsoft Management Console (MMC).
mobile user
A user who travels away from a corporate campus such as a salesperson or field technician.
mobility impairments
The diminished ability to perform certain manual tasks, such as using a mouse or typing two keys at the same time; having a tendency to hit multiple keys, or bounce fingers off keys; or inability to hold a printed book.
module
A component of the Windows 2000 operating system that has sole responsibility for its functions. An application runs in a separate module in user mode, from which it requests system services. Application processes are transferred to one or more modules in kernel mode (protected), where the actual service is provided.
MouseKeys
A feature in Microsoft Windows that allows use of the numeric keyboard to move the mouse pointer.
mouthstick
An alternative assistive input device for users with physical impairments.
MS-DOS-based application
An application that is designed to run with MS-DOS and therefore might not be able to take full advantage of all Windows 2000 features.
multicast
Network traffic destined for a set of hosts that belong to a multicast group. See also multicast group.
multicast backbone
The IP-multicast network portion of the Internet.
multicast DHCP (MDHCP)
An extension to the DHCP protocol standard that supports dynamic assignment and configuration of IP multicast addresses on TCP/IP-based networks.
multicast forwarding table
The table used by IP to forward IP multicast traffic. An entry in the IP multicast forwarding table consists of the multicast group address, the source IP address, a list of interfaces to which the traffic is forwarded (next hop interfaces), and the single interface on which the traffic must be received in order to be forwarded (the previous hop interface).
multicast group
A group of member TCP/IP hosts configured to listen and receive datagrams sent to a specified destination IP address. The destination address for the group is a shared IP address in the Class D address range (224.0.0.0 to 2239.255.255.255). See also datagram.
multicast scope
A range of IP multicast addresses in the range of 239.0.0.0 to 239.254.255.255. Multicast addresses in this range can be prevented from propagating in either direction (send or receive) through the use of scope-based multicast boundaries.
multihomed
A computer that has multiple network adapters installed.
multilingual APIs
Application Programming Interfaces used to support multiple languages in Windows 2000.
multimaster replication
A replication model in which any domain controller accepts and replicates directory changes to any other domain controller. This differs from other replication models in which one computer stores the single modifiable copy of the directory and other computers store backup copies. See also domain controller; replication.
multiple-master replication
The process by which Windows 2000 domain controllers replicate domain data. The primary domain controller emulator replicates the domain data to the other domain controllers. See primary domain controller emulator.
Multipurpose Internet Mail Extensions (MIME)
A common method for transmitting non-text data through Internet e-mail. MIME encodes non-text data as ASCII text and then decodes it back to its original format at the receiving end. A MIME header is added to the file which includes the type of data contained and the encoding method used. See also Secure/Multipurpose Internet Mail Extensions (S/MIME).
mutual authentication
The process when the calling router authenticates itself to the answering router and the answering router authenticates itself to the calling router. Both ends of the connection verify the identity of the other end of the connection. MS-CHAP v2 and EAP-TLS authentication methods provide mutual authentication.

N

name resolution
The process of having software translate between names that are easy for users to work with, and numerical IP addresses, which are difficult for users but necessary for TCP/IP communications. Name resolution can be provided by software components such as the Domain Name System (DNS) or the Windows Internet Name Service (WINS). In directory service, the phase of LDAP directory operation processing that involves finding a domain controller that holds the target entry for the operation. See also Domain Name System (DNS); Transmission Control Protocol/Internet Protocol (TCP/IP); Windows Internet Name Service (WINS).
name resolution service
A service required by TCP/IP internetworks to convert computer names to IP addresses and IP addresses to computer names. (People use "friendly" names to connect to computers; programs use IP addresses.) See also internetwork; IP address; Transmission Control Protocol/Internet Protocol (TCP/IP).
name server
In the DNS client/server model, a server authoritative for a portion of the DNS database. The server makes computer names and other information available to client resolvers querying for name resolution across the Internet or an intranet. See also Domain Name System (DNS).
named pipe
A portion of memory that can be used by one process to pass information to another process, so that the output of one process is the input of the other process. The second process can be local (on the same computer as the first) or remote (on a networked computer).
namespace
A set of unique names for resources or items used in a shared computing environment. The names in a namespace can be resolved to the objects they represent. For Microsoft Management Console (MMC), the namespace is represented by the console tree, which displays all of the snap-ins and resources that are accessible to a console. For Domain Name System (DNS), namespace is the vertical or hierarchical structure of the domain name tree. For example, each domain label, such as "host1" or "example," used in a fully qualified domain name, such as "host1.example.microsoft.com," indicates a branch in the domain namespace tree. For Active Directory, namespace corresponds to the DNS namespace in structure, but resolves Active Directory object names.
naming service
A service, such as that provided by WINS or DNS, that allows friendly names to be resolved to an address or other specially defined resource data that is used to locate network resources of various types and purposes.
native mode
The condition in which all domain controllers within a domain are Windows 2000 domain controllers and an administrator has enabled native mode operation (through Active Directory Users and Computers). See also mixed mode.
nested groups
A Windows 2000 capability available only in native mode that allows the creation of groups within groups. See universal group, global group, domain local group, forest, trusted forest.
NetBIOS Enhanced User Interface (NetBEUI)
A network protocol native to Microsoft Networking, that is usually used in local area networks of 1 to 200 clients. NetBEUI uses Token Ring source routing as its only method of routing. It is the Microsoft implementation of the NetBIOS standard.
NetBIOS name
A name recognized by WINS, which maps the name to an IP address.
NetBIOS name resolution
The process of resolving a NetBIOS name to its IP address.
NetBIOS over TCP/IP (NetBT)
A feature that provides the NetBIOS programming interface over the TCP/IP protocol. It is used for monitoring routed servers that use NetBIOS name resolution.
Netdom
A tool that allows management of Windows 2000 domains and trust relationships from the command line.
NetWare
Novell's network operating system.
NetWare Core Protocol (NCP)
The file-sharing protocol that governs communications about resource (such as disk and printer), bindery, and NDS operations between server and client computers on a Novell NetWare network. Requests from client computers are transmitted by the IPX protocol. Servers respond according to NCP guidelines. See also bindery; Internetwork Packet Exchange (IPX); Novell Directory Services (NDS).
network adapter
A software or hardware plug-in board that connects a node or host to a local area network. If the node is a member of a server cluster, the network adapter is a server cluster object (the network interface object).
network address
See network ID.
Network Address Translation (NAT)
A protocol that allows a network with private addresses to access information on the Internet through an IP translation process.
network address translator
An IP router defined in RFC 1631 that can translate IP addresses and TCP/UDP port numbers of packets as they are being forwarded.
network administrator
A person responsible for setting up and managing domain controllers or local computers and their user and group accounts; assigning passwords and permissions; and helping users with networking issues. Administrators are members of the Administrators group and have full control over the domain or computer.
network basic input/output system (NetBIOS)
An application programming interface (API) that can be used by applications on a local area network or computers running MS-DOS, OS/2, or some version of UNIX. NetBIOS provides a uniform set of commands for requesting lower level network services.
network gateway
A device that connects networks using different communications protocols so that information can be passed from one to the other. A gateway both transfers information and converts it to a form compatible with the protocols being used by the receiving network.
network ID
A number used to identify the systems that are located on the same physical network bounded by routers. The network ID should be unique to the internetwork.
network layer
A layer that addresses messages and translates logical addresses and names into physical addresses. It also determines the route from the source to the destination computer and manages traffic problems, such as switching, routing, and controlling the congestion of data packets.
network load balancing
The Windows Clustering component that distributes incoming Web requests among its cluster of IIS servers.
network load balancing cluster
Between 2 and 32 IIS servers from which Network Load Balancing presents a single IP address to Web clients and among which Network Load Balancing distributes incoming Web requests.
network media
The type of physical wiring and lower-layer protocols used for transmitting and receiving frames. For example, Ethernet, FDDI, and Token Ring.
Network Monitor
A packet capture and analysis tool used to view network traffic. This feature is included with Windows 2000 Server; however, Systems Management Server has a more complete version.
network name
In server clusters, the name through which clients access server cluster resources. A network name is similar to a computer name, and when combined in a resource group with an IP address and the applications clients access, presents a virtual server to clients.
Network News Transfer Protocol (NNTP)
A member of the TCP/IP suite of protocols, used to distribute network news messages to NNTP servers and clients, or news readers, on the Internet. NNTP is designed so that news articles are stored on a server in a central database, thus enabling a user to select specific items to read. See also Transmission Control Protocol/Internet Protocol (TCP/IP).
network prefix
The number of bits in the IP network ID starting from the high order bit. The network prefix is another way of expressing a subnet mask.
network prefix notation
The practice of expressing a subnet mask as a network prefix rather than a dotted decimal notation.
NNTP
See Network News Transfer Protocol
node
In tree structures, a location on the tree that can have links to one or more items below it. In local area networks (LANs), a device that is connected to the network and is capable of communicating with other network devices. In a server cluster, a server that has Cluster service software installed and is a member of a cluster. See also LAN.
nonauthoritative restore
A restore of a backup copy of a Windows 2000 domain controller in which the objects in the restored directory are not treated as authoritative. The restored objects are updated with changes held in other replicas of the restored domain. See also authoritative restore.
noncontainer object
An object that cannot logically contain other objects. A file is a noncontainer object. See also container object; object.
nonrepudiation
A basic security function of cryptography. Nonrepudiation provides assurance that a party in a communication cannot falsely deny that a part of the communication occurred. Without nonrepudiation, someone can communicate and then later deny the communication or claim that the communication occurred at a different time. See also cryptography; authentication; confidentiality; integrity.
Novell Directory Services (NDS)
On networks running Novell NetWare 4.x and NetWare 5.x, a distributed database that maintains information about every resource on the network and provides access to these resources.
NTFS file system
A recoverable file system designed for use specifically with Windows NT and Windows 2000. NTFS uses database, transaction-processing, and object paradigms to provide data security, file system reliability, and other advanced features. It supports file system recovery, large storage media, and various features for the POSIX subsystem. It also supports object-oriented application by treating all files as objects with user-defined and system-defined attributes.
NWLink
An implementation of the Internetwork Packet Exchange (IPX), sequenced packet exchange (SPX), and NetBIOS protocols used in Novell networks. NWLink is a standard network protocol that supports routing and can support NetWare client/server applications, where NetWare-aware Sockets-based applications communicate with IPX/SPX Sockets-based applications. See also Internetwork Packet Exchange (IPX); network basic input/output system (NetBIOS).

O

object
An entity, such as a file, folder, shared folder, printer, or Active Directory object, described by a distinct, named set of attributes. For example, the attributes of a File object include its name, location, and size; the attributes of an Active Directory User object might include the user's first name, last name, and e-mail address. For OLE and ActiveX objects, an object can also be any piece of information that can be linked to, or embedded into, another object. See also attribute; container object; noncontainer object; parent object; child object.
object class
The object class is the formal definition of a specific kind of object that can be stored in the directory. An object class is a distinct, named set of attributes that represents something concrete, such as a user, a printer, or an application. The attributes hold data describing the thing that is identified by the directory object. Attributes of a user might include the user's given name, surname, and e-mail address. The terms object class and class are used interchangeably. The attributes that can be used to describe an object are determined by the content rules.
object linking and embedding (OLE)
A method for sharing information among applications. Linking an object, such as a graphic, from one document to another inserts a reference to the object into the second document. Any changes you make in the object in the first document will also be made in the second document. Embedding an object inserts a copy of an object from one document into another document. Changes you make in the object in the first document will not be updated in the second unless the embedded object is explicitly updated. See also ActiveX.
offline
In a server cluster, the state of a resource, group, or node when it is unavailable to the cluster. Resources and groups also have an offline state. See also group; node; online, paused; resource.
OLE
See object linking and embedding.
on-demand installation
An installation option that gives Windows 2000-compatible software the ability to install new features on first use rather than when the application is first installed.
on-demand router-to-router VPN connection
A router-to-router VPN connection that is made by a calling router who has a dial-up connection to the Internet.
online
In a server cluster, the state of a resource, group, or node when it is available to the cluster. See also heartbeat; node; offline; paused; resource.
open database connectivity (ODBC)
An application programming interface (API) that enables database applications to access data from a variety of existing data sources.
open shortest path first (OSPF)
A routing protocol used in medium-sized and large-sized networks. This protocol is more complex than RIP, but allows better control and is more efficient in propagating routing information.
organizational units
An Active Directory container object used within domains. Organizational units are logical containers into which users, groups, computers, and other organizational units are placed. It can contain objects only from its parent domain. An organizational unit is the smallest scope to which a Group Policy or delegate authority can be applied.
original equipment manufacturer (OEM)
The maker of a piece of equipment. In making computers and computer related equipment, manufacturers of original equipment typically purchase components from other manufacturers of original equipment and then integrate them into their own products.

P

package
An icon that represents embedded or linked information. That information can consist of a complete file, such as a Paint bitmap, or part of a file, such as a spreadsheet cell. When a package is chosen, the application used to create the object either plays the object (if it is a sound file, for example) or opens and displays the object. If the original information is changed, linked information is then updated. However, embedded information needs to be manually updated. In Systems Management Server, an object that contains the files and instructions for distributing software to a distribution point. See also embedded object; linked object; object linking and embedding (OLE).
package distribution
In Systems Management Server, the process of placing a decompressed package image on distribution points, sharing that image, and making it accessible to clients. This process occurs when you specify distribution points for a package.
packet
A transmission unit of fixed maximum size that consists of binary information. This information represents both data and a header containing an ID number, source and destination addresses, and error-control data.
packet filtering
Prevents certain types of network packets from either being sent or received. This can be employed for security reasons (to prevent access from unauthorized users) or to improve performance by disallowing unnecessary packets from going over a slow connection. See also packet.
page fault
An error that occurs when the requested code or data cannot be located in the physical memory that is available to the requesting process.
page-description language (PDL)
A computer language that describes the arrangement of text and graphics on a printed page. See also printer control language (PCL); PostScript.
paging
The process of moving virtual memory back and forth between physical memory and the disk. Paging occurs when physical memory limitations are reached and only occurs for data that is not already "backed" by disk space. For example, file data is not paged out because it already has allocated disk space within a file system. See also virtual memory.
paging file
A hidden file on the hard disk that Windows 2000 uses to hold parts of programs and data files that do not fit in memory. The paging file and physical memory, or RAM, comprise virtual memory. Windows 2000 moves data from the paging file to memory as needed and moves data from memory to the paging file to make room for new data. Also called a swap file. See also RAM; virtual memory.
parent domain
For DNS and Active Directory, domains that are located in the namespace tree directly above other derivative domain names (child domains). For example, "reskit.com" would be the parent domain for "eu.reskit.com", a child domain. See also child domain; domain; directory partition.
parent object
The object in which another object resides. A parent object implies relation. For example, a folder is a parent object in which a file, or child object, resides. An object can also be both a parent and a child object. See also child object; object.
parenting
The concept of managing the growth and delegation of a parent domain into further child domains, which are derived and delegated from the parent name. See also child domain; parent domain.
partial replica
A read-only replica of a directory partition that contains a subset of the attributes of all objects in the partition. The sum of partial replicas in a forest is called the global catalog. The attributes contained in a partial replica are defined in the schema as the attributes whose attributeSchema objects have the isMemberOfPartialAttributeSet attribute set to TRUE. See also full replica; Global Catalog.
partition
A logical division of a hard disk. Partitions make it easier to organize information. Each partition can be formatted for a different file system. A partition must be completely contained on one physical disk, and the partition table in the master boot record for a physical disk can contain up to four entries for partitions.
partition table
An area of the master boot record that the computer uses to determine how to access the disk. The partition table can contain up to four partitions for each physical disk.
password authentication protocol (PAP)
A simple, plaintext authentication scheme for authenticating PPP connections. The user name and password are requested by the remote access server and returned by the remote access client in plaintext.
path
A sequence of directory (or folder) names that specifies the location of a directory, file, or folder within the Windows directory tree. Each directory name and file name within the path must be preceded by a backslash (\). For example, to specify the path of a file named Readme.doc located in the Windows directory on drive C, you type C:\Windows\Readme.doc.
paused
The state of a node that is a fully active member in the server cluster but cannot host groups. The paused state is provided for an administrator to perform maintenance. See also cluster member; failback; failover; node; offline.
PC Card
A removable device, approximately the size of a credit card, that can be plugged into a PCMCIA (Personal Computer Memory Card International Association) slot in a portable computer. PCMCIA devices can include modems, network adapters, and hard disk drives.
performance counter
In System Monitor, a data item associated with a performance object. For each counter selected, System Monitor presents a value corresponding to a particular aspect of the performance that is defined for the performance object. See also performance object.
performance object
In System Monitor, a logical collection of counters that is associated with a resource or service that can be monitored. See also performance counter.
peripheral component interconnect (PCI)
A specification introduced by Intel Corporation that defines a local bus system that allows up to 10 PCI-compliant expansion cards to be installed in the computer.
permanent virtual circuit (PVC)
A virtual circuit assigned to a preconfigured static route.
permission
A rule associated with an object to regulate which users can gain access to the object and in what manner. In Windows 2000, objects include files, folders, shares, printers, and Active Directory objects. Services for Macintosh translates between permissions and Macintosh access privileges so that permissions set on a folder (volume) are enforced for Macintosh users and access privileges set by Macintosh users are enforced for personal computer users connected to the computer running Windows 2000 Server. See also object.
personal identification number (PIN)
A secret identification code that is used to protect smart cards from misuse. The PIN is similar to a password and is known only to the owner of the card. The smart card can be used only by someone who possesses the smart card and knows the PIN. See also smart card.
ping
A tool that verifies connections to one or more remote hosts. The ping command uses the ICMP echo request and echo reply packets to determine whether a particular IP system on a network is functional. Ping is useful for diagnosing IP network or router failures. See also Internet Control Message Protocol (ICMP).
plaintext
Data that is not encrypted. Sometimes also called clear text. See also ciphertext; encryption; decryption.
Plug and Play
A set of specifications developed by Intel that allows a computer to automatically detect and configure a device and install the appropriate device drivers.
Point-to-Point Protocol (PPP)
An industry standard suite of protocols for the use of point-to-point links to transport multiprotocol datagrams. PPP is documented in RFC 1661.
Point-to-Point Tunneling Protocol (PPTP)
A tunneling protocol that encapsulates Point-to-Point Protocol (PPP) frames into IP datagrams for transmission over an IP-based internetwork, such as the Internet or a private intranet.
port
A mechanism that allows multiple sessions. A refinement to an IP address. In Device manager, a connection point on a computer where devices that pass data in and out of a computer can be connected. For example, a printer is typically connected to a parallel port (also known as an LPT port), and a modem is typically connected to a serial port (also known as a COM port).
port rule
For Network Load Balancing, a set of configuration parameters that determine the filtering mode to be applied to a range of ports. See also filtering mode.
PostScript
A page-description language (PDL) developed by Adobe Systems for printing with laser printers. PostScript offers flexible font capability and high-quality graphics. It is the standard for desktop publishing because it is supported by imagesetters, the high-resolution printers used by printing services for commercial typesetting. See also printer control language (PCL); page-description language (PDL).
primary domain controller
A Windows NT 4.0 and 3.51domain controller that is the first one created in the domain and contains the primary storehouse for domain data. Within the domain, the primary domain controller periodically replicates its data to the other domain controllers, known as backup domain controllers. See also backup domain controller.
primary domain controller emulator
The first Windows 2000 domain controller created in a domain. In addition to replicating domain data to the other Windows 2000 domain controllers, the primary domain controller emulator acts like a Windows NT primary domain controller in that it performs primary domain controller duties, including replication of domain data to any backup domain controllers within the domain. If the primary domain controller emulator goes offline, another Windows 2000 domain controller in the domain can assume the primary domain controller emulator role. See also primary domain controller; backup domain controller.
primary partition
A volume created using unallocated space on a basic disk. Windows 2000 and other operating systems can start from a primary partition. As many as four primary partitions can be created on a basic disk, or three primary partitions and an extended partition. Primary partitions can be created only on basic disks and cannot be subpartitioned. See also basic disk; dynamic volume; extended partition; partition.
primary server
An authoritative DNS server for a zone that can be used as a point of update for the zone. Only primary masters have the ability to be updated directly to process zone updates, which include adding, removing, or modifying resource records that are stored as zone data. Primary masters are also used as the first sources for replicating the zone to other DNS servers.
primary token
The access token assigned to a process to represent the default security information for that process. It is used in security operations by a thread working on behalf of the process itself rather than on behalf of a client. See also access token; impersonation token; process.
print device
A hardware device used for printing that is commonly called a printer. See also logical printer.
print server
A computer that is dedicated to managing the printers on a network. The print server can be any computer on the network.
print sharing
The ability for a computer running Windows NT Workstation or Windows NT Server to share a printer on the network. This is accomplished by double-clicking Printers in Control Panel or entering the net share command at the command prompt.
print spooler
Software that accepts a document sent to a printer by the user and then stores it on disk or in memory, holding it until the printer is ready for it. This collection of dynamic-link libraries (DLLs) receives, processes, schedules, and distributes documents for printing. The term spooler is an acronym created from "simultaneous print operations on line." See also spooling.
printer control language (PCL)
The page-description language (PDL) developed by Hewlett Packard for their laser and inkjet printers. Because of the widespread use of laser printers, this command language has become a standard in many printers. See also page-description language (PDL); PostScript.
printer driver
A program designed to allow other programs to work with a particular printer without concerning themselves with the specifics of the printer's hardware and internal language. By using printer drivers that handle the subtleties of each printer, programs can communicate properly with a variety of printers. See also printer control language (PCL); PostScript.
printer permissions
Permissions that specify the type of access that a user or group has to a printer. The printer permissions are Print, Manage Printers, and Manage Documents.
printers folder
The folder in Control Panel that contains the Add Printer wizard and icons for all the printers installed on your computer.
priority
A precedence ranking that determines the order in which the threads of a process are scheduled for the processor.
private addresses
IP addresses within the private address space that are designed to be used by organizations for private intranet addressing. A private IP address is within one of the following blocks of addresses: 10.0.0.0/8, 172.16.0.0/12, 192.168.0.0/16.
private key
The secret half of a cryptographic key pair that is used with a public key algorithm. Private keys are typically used to digitally sign data and to decrypt data that has been encrypted with the corresponding public key. See also public key.
privilege
A user's right to perform a specific task, usually one that affects an entire computer system rather than a particular object. Privileges are assigned by administrators to individual users or groups of users as part of the security settings for the computer. See also access token; permission; user rights.
process
An operating system object that consists of an executable program, a set of virtual memory addresses, and one or more threads. When a program runs, a Windows 2000 process is created. See also thread.
protocol
A set of rules and conventions by which two computers pass messages across a network. Networking software usually implements multiple levels of protocols layered one on top of another. Windows NT and Windows 2000 include NetBEUI, TCP/IP, and IPX/SPX-compatible protocols.
public addresses
IP addresses assigned by the Internet Network Information Center (InterNIC) that are guaranteed to be globally unique and reachable on the Internet.
public key
The non secret half of a cryptographic key pair that is used with a public key algorithm. Public keys are typically used to verify digital signatures or decrypt data that has been encrypted with the corresponding private key. See also private key.
public key certificate
A digital passport that serves as proof of identity. Public key certificates are issued by a certification authority (CA). See also certification authority (CA); Kerberos protocol.
public key cryptography
A method of cryptography in which two different keys are used: a public key for encrypting data and a private key for decrypting data. Public key cryptography is also called asymmetric cryptography.
public key infrastructure
The laws, policies, standards, and software that regulate or manipulate certificates and public and private keys. In practice, it is a system of digital certificates, certification authorities, and other registration authorities that verify and authenticate the validity of each party involved in an electronic transaction. Standards for PKI are still evolving, even though they are being widely implemented as a necessary element of electronic commerce.
public/private key pair
A set of cryptographic keys used for public key cryptography. One key is used to encrypt, the other to decrypt. See also public key; private key.
published applications
Applications that are available to users managed by a Group Policy object. Each user decides whether or not to install the published application by using Add/Remove Programs in Control Panel.
pull partner
A Windows Internet Name Service (WINS) service that pulls in replicas from its push partner by requesting them and then accepting the pushed replicas. See also push partner.
push partner
A Windows Internet Name Service (WINS) service that sends replicas to its pull partner upon receiving a request from it. See also pull partner.

Q

QoS Admission Control Service
A software service that controls bandwidth and network resources on the subnet to which it is assigned. Important applications can be given more bandwidth, less important applications less bandwidth. The QoS Admission Control Service can be installed on any network-enabled computer running Windows 2000.
Quality of Service (QoS)
A set of quality assurance standards and mechanisms for data transmission, implemented in Windows 2000.
queue
A list of programs or tasks waiting for execution. In Windows 2000 printing terminology, a queue refers to a group of documents waiting to be printed. In NetWare and OS/2 environments, queues are the primary software interface between the application and print device; users submit documents to a queue. With Windows 2000, however, the printer is that interface; the document is sent to a printer, not a queue.
quorum log
The record, stored on the quorum disk, of changes that have been made to the cluster hive of the registry since the last hive checkpoint was taken. Also known as the recovery log or change log.

R

RAID
See redundant array of independent disks.
RAID-5 volume
A fault-tolerant volume with data and parity striped intermittently across three or more physical disks. Parity is a calculated value that is used to reconstruct data after a failure. If a portion of a physical disk fails, you can recreate the data that was on the failed portion from the remaining data and parity.
RAM
See random access memory
raster fonts
Fonts that are stored as bitmaps; also called bit-mapped fonts. Raster fonts are designed with a specific size and resolution for a specific printer and cannot be scaled or rotated. If a printer does not support raster fonts, it will not print them.
read-only memory (ROM)
A semiconductor circuit that contains information that cannot be modified.
recovery
The process of using a log file to restore a database to a consistent state after a system crash and to restore a database from a backup to the most recent state that is recorded in the log file after a media failure. See also authoritative restore.
redirection
In UNIX, to send the standard output to a file instead of to the terminal or to take the standard input from a file instead of from the terminal.
redirector
See Windows 2000 redirector.
redundant array of independent disks (RAID)
A method used to standardize and categorize fault-tolerant disk systems. Six levels gauge various mixes of performance, reliability, and cost. Windows 2000 provides three of the RAID levels: Level 0 (striping), Level 1 (mirroring), and Level 5 (stripe sets with parity). See also fault tolerance; mirrored volume; RAID-5 volume; striped volume.
referral
In Dfs, information that maps a DNS name in the logical namespace to the UNC equivalent name of a physical share. When a Dfs client gains access to a shared folder in the Dfs namespace, the Dfs root server returns a referral for the client to use in locating the shared folder. In DNS, a pointer to an authoritative DNS server that is authoritative for a lower level of the domain namespace.
refresh
To update displayed information with current data.
refresh interval
In DNS, a 32-bit time interval that needs to elapse before the zone data is refreshed. When the refresh interval expires, the secondary server checks with a master server for the zone to see if its zone data is still current or if it needs to be updated by using a zone transfer. This interval is set in the start of authority (SOA) resource record for each zone. See also resource record; secondary server; start of authority (SOA) resource record; zone; zone transfer.
refresh rate
The frequency with which the video screen is retraced in order to prevent the image from flickering. The entire image area of most monitors is refreshed approximately 60 times per second.
registry
In Windows 2000, Windows NT, and Windows 98, a database for information about a computer's configuration. The registry is organized in a hierarchical structure and consists of subtrees and their keys, hives, and entries.
registry key
An identifier for a record or group of records in the registry.
relative identifier (RID)
The part of a security identifier (SID) that identifies an account or group. RIDs are unique relative to the domain in which an account or group is created. See also security identifier.
remote access policy
A set of conditions and connection parameters that define the characteristics of the incoming connection and the set of constraints imposed on it. Remote access polices determine whether a specific connection attempt is authorized to be accepted.
remote access server
A Windows 2000 Server-based computer running the Routing and Remote Access service and configured to provide remote access.
Remote Access Service (RAS)
A Window NT 4.0 service that provides remote networking for telecommuters, mobile workers, and system administrators who monitor and manage servers at multiple offices.
remote computer
A computer that is accessible only by using a communications line or a communications device, such as a network adapter or a modem.
remote installation boot floppy (RBFG.exe)
A component in the Remote Installation Service that is used to create a boot floppy, which is needed to install RIS-based operating systems on certain client computers.
Remote Installation Preparation wizard (RIPrep.exe)
A component in Remote Installation Services that is used to create operating system images and to install them on the RIS server.
Remote Installation Services (RIS)
An optional component of Windows 2000 that remotely installs Windows 2000 Professional. It installs operating systems on remote boot-enabled client computers by connecting the computer to the network, starting the client computer, and logging on with a valid user account.
Remote Installation Services setup (RISetup.exe)
A component in Remote Installation Services that is used to set up the RIS server
remote procedure call (RPC)
A message-passing facility that allows a distributed application to call services that are available on various machines in a network. Used during remote administration of computers.
remote storage
For Windows 2000 Server, removable tapes in a library used for secondary data storage. Specified tapes used for secondary data storage are managed by Remote Storage and contain data that is either stored on, or has been removed from, local storage to free up disk space. See also local storage.
repackaging
The process of converting an older application to take advantage of many Windows Installer features, including the ability to advertise the application to users, the ability of the software to repair itself if essential files are deleted or corrupted, and the ability of users to install the application with elevated privileges.
RepeatKeys
A feature that allows users with dexterity impairments to adjust the repeat rate or to disable the key-repeat function on the keyboard.
replica
In Active Directory replication, a copy of a logical Active Directory partition that is synchronized through replication between domain controllers that hold copies of the same directory partition. Replica can also refer to the composite set of directory partitions held by any one domain controller.
replication
The process of copying data from a data store or file system to multiple computers that store the same data for the purpose of synchronizing the data. In Windows 2000, replication of Active Directory occurs through the Directory Replicator Service and replication of the file system occurs through Dfs replication.
replication latency
In Active Directory replication, the delay between the time an update is applied to a given replica of a directory partition and the time it is applied to some other replica of the same directory partition. Latency is sometimes referred to as propagation delay. See also multimaster replication.
replication topology
In Active Directory replication, the set of connections that domain controllers use to replicate information among themselves, both within sites and between sites. See also domain controller; Active Directory replication.
Request for Comments (RFC)
A document that defines a TCP/IP standard. RFCs are published by the Internet Engineering Task Force (IETF) and other working groups.
resolver
DNS client programs used to look up DNS name information. Resolvers can be either a small "stub" (a limited set of programming routines that provide basic query functionality) or larger programs that provide additional lookup DNS client functions, such as caching. See also caching, caching resolver.
resource
Any part of a computer system or network, such as a disk drive, printer, or memory, that can be allotted to a program or a process while it is running. For Device Manager, any of four system components that control how the devices on a computer work. These four system resources are: interrupt request (IRQ) lines, direct memory access (DMA) channels, input/output (I/O) ports, and memory addresses. See also direct memory access (DMA); input/output port; interrupt request (IRQ) lines; memory address. In a server cluster, an instance of a resource type; the Cluster service manages various physical or logical items as resources.
Resource DLL
A dynamic-link library that defines default properties and behavior for a specific type of resource. The Resource DLL contains an implementation of the Resource API for a specific type of resource and is loaded into the address space of its Resource Monitor. See also dynamic-link library; Resource Monitor.
resource domain
A Windows NT domain that holds account data for workstations and resource computers (for example, file and print servers) associated with an account or master domain. See account domain; master domain.
Resource Monitor
The server cluster component that manages communication between a node's Cluster service and one or more of its resources. See also node; resource.
resource record (RR)
Information in the DNS database that can be used to process client queries. Each DNS server contains the resource records it needs to answer queries for the portion of the DNS namespace for which it is authoritative.
response time
The amount of time required to do work from start to finish. In a client/server environment, this is typically measured on the client side.
reverse lookup
A query in which the IP address is used to determine the DNS name for the computer.
reverse lookup zone
A zone that contains information needed to perform reverse lookups. See also reverse lookup.
roaming profile
A set of user-specific settings in a single location on a server so that users can move from computer to computer while retaining the same profile.
roaming user profile
A server-based user profile that is downloaded to the local computer when a user logs on and is updated both locally and on the server when the user logs off. A roaming user profile is available from the server when logging on to any computer that is running Windows 2000 Professional or Windows 2000 Server. When logging on, the user can use the local user profile if it is more current than the copy on the server.
root
The highest or uppermost level in a hierarchically organized set of information. The root is the point from which further subsets are branched in a logical sequence that moves from a broad or general focus to narrower perspectives.
root certificate
A self-signed certification authority certificate. It is called a root certificate because it is the certificate for the root authority. The root authority must sign its own certificate because there is no higher certifying authority in the certification hierarchy. See also certificate; certification authority; root authority.
root certification authority
The most trusted certification authority (CA), which is at the top of a certification hierarchy. The root CA has a self-signed certificate. Also called the root authority. See also certification authority; certification path; root certificate.
root domain
The beginning of the Domain Name System (DNS) namespace. In Active Directory, the initial domain in an Active Directory tree. Also the initial domain of a forest.
round robin
A simple mechanism used by DNS servers to share and distribute loads for network resources. Round robin is used to rotate the order of resource record (RR) data returned in a query answer when multiple RRs exist of the same RR type for a queried DNS domain name.
route summarization
The practice of combining multiple network IDs into a single route in the routing table. With proper planning, hierarchical routing infrastructures can use route summarization.
router
A network server that helps LANs and WANs achieve interoperability and connectivity and that can link LANs that have different network topologies, such as Ethernet and Token Ring.
routing
The process of forwarding a packet based on the destination IP address.
routing infrastructure
The structure and topology of the internetwork.
routing protocol
A series of periodic or on-demand messages containing routing information that is exchanged between routers to exchange routing information and provide fault tolerance. Except for their initial configuration, dynamic routers require little ongoing maintenance, and therefore can scale to larger internetworks.
routing table
A database of routes containing information on network IDs, forwarding addresses, and metrics for reachable network segments on an internetwork.
rules
An IPSec policy mechanism that governs how and when an IPSec policy protects communication. A rule provides the ability to trigger and control secure communication based on the source, destination, and type of IP traffic. Each rule contains a list of IP filters and a collection of security actions that take place upon a match with that filter list.

S

scalability
A measure of how well a computer, service, or application can expand to meet increasing performance demands. For server clusters, the ability to incrementally add one or more systems to an existing cluster when the overall load of the cluster exceeds its capabilities.
scaling
The process of adding processors to a system to achieve higher throughput.
schema
A description of the object classes and attributes stored in Active Directory. For each object class, the schema defines what attributes an object class must have, what additional attributes it may have, and what object class can be its parent. Active Directory schema can be updated dynamically. For example, an application can extend the schema with new attributes and classes and use the extensions immediately. Schema updates are accomplished by creating or modifying the schema objects stored in Active Directory. Like every object in Active Directory, schema objects have an access control list so that only authorized users can alter the schema.
script
A type of program consisting of a set of instructions to an application or utility program. A script usually expresses instructions by using the application's or utility's rules and syntax, combined with simple control structures such as loops and if/then expressions. "Batch program" is often used interchangeably with "script" in the Windows environment.
secondary server
An authoritative DNS server for a zone that is used as a source for replication of the zone to other servers. Secondary masters only update their zone data by transferring zone data from other DNS servers and do not have the ability to perform zone updates. See also master server; zone transfer.
secondary storage
A storage device used to store data that has been migrated from managed volumes. Secondary storage includes the part of the hard disk that is used for a migration staging area.
secret key
An encryption key that two parties share with each other and with no one else. See also symmetric key encryption.
secure dynamic update
The process by which a secure dynamic update client submits a dynamic update request to a DNS server, and the server attempts the update only if the client can prove its identity and has the proper credentials to make the update. See also dynamic update.
Secure Sockets Layer (SSL)
A proposed open standard developed by Netscape Communications for establishing a secure communications channel to prevent the interception of critical information, such as credit card numbers. Primarily, it enables secure electronic financial transactions on the World Wide Web, although it is designed to work on other Internet services as well.
Secure/Multipurpose Internet Mail Extensions (S/MIME)
An extension of MIME to support secure mail. It enables message originators to digitally sign e-mail messages to provide proof of message origin and data integrity. It also enables messages to be transmitted in encrypted format to provide confidential communications. See also Multipurpose Internet Mail Extensions (MIME).
security administrator
A user who has been assigned the right to manage auditing and the security log. By default, this user right is granted to the Administrators group. See also auditing; system access control list (SACL); user rights.
security association (SA)
A set of parameters that defines the services and mechanisms necessary to protect Internet Protocol security communications. See also Internet Protocol security (IPSec).
security context
The security attributes or rules that are currently in effect. For example, the rules that govern what a user can do to a protected object are determined by security information in the user's access token and in the object's security descriptor. Together, the access token and the security descriptor form a security context for the user's actions on the object. See also access token; security descriptor.
security descriptor
A set of information attached to an object that specifies the permissions granted to users and groups, as well as the security events to be audited. See also discretionary access control list (DACL); object; system access control list (SACL).
security groups
Groups that can be used to administer permissions for users and other domain objects
security identifier (SID)
A unique name that identifies a user who is logged on to a Windows NT or Windows 2000 security system. A security identifier can represent an individual user, a group of users, or a computer.
security method
A process that determines the Internet Protocol security services, key settings, and algorithms that will be used to protect the data during the communication.
security principal
A Windows 2000 entity that is automatically assigned a security identifier for access to resources. A security principal can be a user, group, or computer. Windows 2000 uses Active Directory for account management of user and security principals. See also security principal name.
security principal name
A name that uniquely identifies a user, group, or computer within a single domain. This name is not guaranteed to be unique across domains. See also security principal.
seek time
The amount of time required for a disk head to position itself at the right disk cylinder to access requested data.
sender
A Systems Management Server thread component that uses an existing connectivity system to communicate among sites. A sender manages the connection, ensures the integrity of transferred data, recovers from errors, and closes connections when they are no longer needed.
SerialKeys
A Windows feature that uses a communications aid interface device to allow keystrokes and mouse controls to be accepted through a computer's serial port.
server
A computer that provides shared resources to network users.
server cluster
A cluster created and administered by Cluster service and associated software (.exe and .dll files), between whose nodes Cluster service provides failover support for applications running on the servers. The server cluster includes the hardware and the cluster configuration as well as the Cluster service. See also cluster; node.
server message block (SMB)
A file-sharing protocol designed to allow networked computers to transparently access files that reside on remote systems over a variety of networks. The SMB protocol, jointly developed by Microsoft, Intel, and IBM, defines a series of commands that pass information between computers. SMB uses four message types: session control, file, printer, and message.
service level agreement (SLA)
A contract between your IT group and users that specifies what performance levels are acceptable for services, such as equipment replacement and network downtime.
service name
The name by which a port is known.
service ticket
See session ticket.
session key
A key used primarily for encryption and decryption. Session keys are typically used with symmetric encryption algorithms where the same key is used for both encryption and decryption. For this reason, session and symmetric keys usually refer to the same type of key. See also symmetric key encryption.
session ticket
A credential presented by a client to a service in the Kerberos authentication protocol. Because session tickets are used to obtain authenticated connections to services, they are sometimes called service tickets. See also Kerberos authentication protocol; Key Distribution Center (KDC).
sessions
Multiple packets sent with acknowledgments between two endpoints.
shared printer
A printer that receives input from more than one computer. For example, a printer attached to another computer on the network can be shared so that it is available for many users. Also called a network printer.
shell
The command interpreter that is used to pass commands to the operating system.
shortcut trust
A two-way trust relationship that is explicitly created between two Windows 2000 domains in different domain trees within a forest. The purpose of a shortcut trust is to optimize the inter-domain authentication process. A shortcut trust can be created only between Windows 2000 domains in the same forest. All shortcut trusts are transitive. See also domain tree; forest; transitive trust.
ShowSounds
A global flag that instructs programs to display captions for speech and system sounds to alert users with hearing impairments or people who work in a noisy location such as a factory floor.
Simple Mail Transport Protocol (SMTP)
A protocol used on the Internet to transfer mail reliably and efficiently. SMTP is independent of the particular transmission subsystem and requires only a reliable, ordered, data stream channel.
Simple Network Management Protocol (SNMP)
A network management protocol installed with TCP/IP and widely used on TCP/IP and Internet Package Exchange (IPX) networks. SNMP transports management information and commands between a management program run by an administrator and the network management agent running on a host. The SNMP agent sends status information to one or more hosts when the host requests it or when a significant event occurs.
single point of failure
Any component in your environment that would block data or applications if it failed.
site
A location in a network that holds Active Directory servers. A site is defined as one or more well-connected TCP/IP subnets. ("Well-connected" means that network connectivity is highly reliable and fast.) Because computers in the same site are close to each other in network terms, communication among them is reliable, fast, and efficient. Defining a site as a set of subnets allows administrators to configure Active Directory access and replication topology to take advantage of the physical network. When users log on to the network, Active Directory clients find Active Directory servers in the same site as the client. In Systems Management Server, site servers and client computers bounded by a group of subnets, such as an IP subnet or an IPX network number. See also domain controller locator; subnet; replication topology.
site server
A computer running Windows NT Server on which Systems Management Server (SMS) site setup has been run. When SMS is installed on a computer, that computer is assigned the site server role. The site server, which hosts SMS components needed to monitor and manage an SMS site, typically performs several additional SMS roles, including component server, client access point, and distribution point.
slow link processing
A configurable Group Policy processing mode that allows administrators to define which Group Policy settings will not be processed over slow network links.
SlowKeys
A Windows feature that instructs the computer to disregard keystrokes that are not held down for a minimum period of time, which allows the user to brush against keys without any effect. See also FilterKeys.
Small Computer System Interface (SCSI)
A standard high-speed parallel interface defined by the X3T9.2 committee of the American National Standards Institute (ANSI). A SCSI interface is used for connecting microcomputers to peripheral devices, such as hard disks and printers, and to other computers and local area networks.
Small Office/Home Office (SOHO)
An office with a few computers that can be considered a small business or part of a larger network.
smart card
A credit card-sized device that is used with a PIN number to enable certificate-based authentication and single sign-on to the enterprise. Smart cards securely store certificates, public and private keys, passwords, and other types of personal information. A smart card reader attached to the computer reads the smart card. See also authentication.
smart-card reader
A device that is installed in computers to enable the use of smart cards for enhanced security features. See also smart card.
SMTP
See Simple Mail Transfer Protocol.
sniffer
An application or device that can read, monitor, and capture network data exchanges and read network packets. If the packets are not encrypted, a sniffer provides a full view of the data inside the packet.
SOA (start of authority) resource record
See start of authority (SOA) resource record.
software inventory
In Systems Management Server, the automated process that SMS uses to gather information about software on client computers.
software metering
In Systems Management Server, the process by which SMS monitors and manages the use of software applications to ensure compliance with software licensing agreements or to understand software usage.
SoundSentry
A Windows feature that produces a visual cue, such as a screen flash or a blinking title bar instead of system sounds.
speech synthesizer
An assistive device that produces spoken words, either by splicing together prerecorded words or by programming the computer to produce the sounds that make up spoken words.
spooling
A process on a server in which print documents are stored on a disk until a printer is ready to process them. A spooler accepts each document from each client, stores it, and sends it to a printer when the printer is ready.
stand-alone certification authority
A Windows 2000 certification authority that is not integrated with Active Directory. See also certification authority; enterprise certification authority.
start of authority (SOA) resource record
A record that indicates the starting point or original point of authority for information stored in a zone. The SOA resource record (RR) is the first RR created when adding a new zone. It also contains several parameters used by others to determine how long other DNS servers will use information for the zone and how often updates are required. See also authoritative; secondary master; zone.
stateless
As related to servers, not involving the update of a server-side database based on a client request. As related to handling of files, the content of the file is not modified or noticed. For Web servers, a stateless client request, which members of a Network Load Balancing cluster can process, is one that returns a static Web page to the client.
static routing
Routing limited to fixed routing tables, as opposed to dynamically updated routing tables. See also dynamic routing; routing; routing table.
status area
The area on the taskbar to the right of the taskbar buttons. The status area displays the time and can also contain icons that provide quick access to programs, such as Volume Control and Power Options. Other icons can appear temporarily, providing information about the status of activities. For example, the printer icon appears after a document has been sent to the printer and disappears when printing is complete.
StickyKeys
An accessibility feature built into Windows that causes modifier keys such as SHIFT, CTRL, or ALT to stay on after they are pressed, eliminating the need to press multiple keys simultaneously. This feature facilitates the use of modifier keys for users who are unable to hold down one key while pressing another.
streaming media servers
Software (such as Microsoft Media Technologies) that provides multimedia support, allowing you to deliver content by using Advanced Streaming Format over an intranet or the Internet.
stripe set
The saving of data across identical partitions on different drives. A stripe set does not provide fault tolerance; however, stripe sets with parity do provide fault tolerance. See also fault tolerance; partition; stripe set with parity; volume set.
stripe set with parity
A method of data protection in which data is striped in large blocks across all the disks in an array. Data redundancy is provided by the parity information. This method provides fault tolerance. See also stripe set, fault tolerance.
striped volume
A volume that stores data in stripes on two or more physical disks. Consecutive logical blocks of data are distributed among the participating disks in round-robin fashion, much like interleaving in a multibank memory system. Each "stripe" of data consists of one block of data per disk (including any redundant data).
Structured Query Language (SQL)
A widely accepted standard database sublanguage used in querying, updating, and managing relational databases.
stub area
An OSPF area that does not advertise individual external networks. Routing to all external networks in a stub area is done through a default route (destination 0.0.0.0 with the network mask of 0.0.0.0).
subdomain
A DNS domain located directly beneath another domain name (the parent domain) in the namespace tree. For example, "eu.reskit.com" is a subdomain of the domain "reskit.com."
subject
An entity acting on an object. For example, when a thread of execution opens a file, the thread is a subject and the file is the object of its action. See also object; thread.
subnet
A subdivision of an IP network. Each subnet has its own unique subnetted network ID.
subnet mask
A 32-bit value expressed as four decimal numbers from 0 to 255, separated by periods (for example, 255.255.0.0.). This number allows TCP/IP to distinguish the network ID portion of the IP address from the host ID portion. The host ID identifies individual computers on the network. TCP/IP hosts use the subnet mask to determine whether a destination host is located on a local or a remote network.
subnetting
The act of subdividing the address space of a TCP/IP network ID into smaller network segments, each with its own subnetted network ID.
switch
A computer or other network-enabled device that controls routing and operation of a signal path. In clustering, a switch is used to connect the cluster hosts to a router or other source of incoming network connections. See also routing.
switched virtual circuit (SVC)
A connection established dynamically between devices on an ATM network through the use of signaling.
symmetric key
A single key that is used with symmetric encryption algorithms for both encryption and decryption. See also bulk encryption; encryption; decryption; session key.
symmetric key encryption
An encryption algorithm that requires the same secret key to be used for both encryption and decryption. This is often called secret key encryption. Because of its speed, symmetric encryption is typically used rather than public key encryption when a message sender needs to encrypt large amounts of data. See also public key encryption.
Symmetric Multiprocessing (SMP)
A computer architecture in which multiple processors share the same memory, which contains one copy of the operating system, one copy of any applications that are in use, and one copy of the data. Because the operating system divides the workload into tasks and assigns those tasks to whatever processors are available, SMP reduces transaction time.
Synchronization Manager
In Windows 2000, the tool used to ensure that a file or directory on a client computer contains the same data as a matching file or directory on a server.
Synchronized Accessible Media Interchange (SAMI)
A format optimized for creating captions and audio descriptions in a single document.
synchronous processing
The default Group Policy processing mode in Windows 2000. In this default mode users cannot log on until all computer Group Policy objects have been processed and cannot begin working on their computers until all user Group Policy objects have been processed.
Syspart
A process that executes through an optional parameter of Winnt32.exe. Used for clean installations to computers that have dissimilar hardware. This automated installation method reduces deployment time by eliminating the file-copy phase of Setup. See automated installation.
Sysprep
A tool that prepares the hard disk on a source computer for duplication to target computers and then runs a third-party disk-imaging process. This automated installation method is used when the hard disk on the master computer is identical to those of the target computers. See automated installation.
system access control list (SACL)
Represents part of an object's security descriptor that specifies which events are to be audited per user or group. Examples of auditing events are file access, logon attempts, and system shutdowns. See also access control entry (ACE); discretionary access control list (DACL); object; security descriptor.
system files
Files that are used by Windows to load, configure, and run the operating system. Generally, system files must never be deleted or moved.
system policy
In network administration, the part of Group Policy that is concerned with the current user and local computer settings in the registry. In Windows 2000, system policy is sometimes called software policy and is one of several services provided by Group Policy, a Microsoft Management Console (MMC) snap-in. The Windows NT 4.0 System Policy Editor, Poledit.exe, is included with Windows 2000 for backward compatibility. That is, administrators need it to set system policy on Windows NT 4.0 and Windows 95 computers. See also Microsoft Management Console (MMC); registry.
system state
In Backup, a collection of system-specific data that can be backed up and restored. For all Windows 2000 operating systems, the System State data includes the registry, the class registration database, and the system boot files. For Windows 2000 server operating systems, the System State data also includes the Certificate Services database (if the server is operating as a certificate server). If the server is a domain controller, the System State data also includes Active Directory and the Sysvol directory. See also Active Directory; domain controller; Sysvol.
systemroot
The path and folder name where the Windows 2000 system files are located. Typically, this is C:\Winnt, although a different drive or folder can be designated when Windows 2000 is installed. The value %Systemroot% can be used to replace the actual location of the folder that contains the Window 2000 system files. To identify your systemroot folder, click Start, click Run, and then type %Systemroot%.
Systems Management Server
A part of the Windows BackOffice suite of products. Systems Management Server (SMS) includes inventory collection, deployment and diagnostic tools. SMS can significantly automate the task of upgrading software, allow remote problem solving, provide asset management information, manage software licenses, and monitor computers and networks.
Sysvol
A shared directory that stores the server's copy of the domain's public files, which are replicated among all domain controllers in the domain. See also domain; domain controller.

T

T1
A wide-area carrier that transmits data at 1.544 Mbps.
T3
A wide-area carrier that transmits data at 44.736 Mbps and in the same format as DS3.
taskbar
The bar that contains the Start button and appears by default at the bottom of the desktop. You can use the taskbar buttons to switch between the programs you are running. The taskbar can be hidden, moved to the sides or top of the desktop, or customized in other ways. See also desktop; taskbar button; status area.
taskbar button
A button that appears on the taskbar when an application is running. See also taskbar.
TCP connection
The logical connection that exists between two processes that are using TCP to exchange data.
TCP/IP
See Transmission Control Protocol/Internet Protocol.
Telnet
A terminal-emulation protocol that is widely used on the Internet to log on to network computers. Telnet also refers to the application that uses the Telnet protocol for users who log on from remote locations.
terminal
A device consisting of a display screen and a keyboard that is used to communicate with a computer.
text mode
The portion of Setup that uses a text-based interface.
thin client
A network computer that does not have a hard disk.
thread
A type of object within a process that runs program instructions. Using multiple threads allows concurrent operations within a process and enables one process to run different parts of its program on different processors simultaneously. A thread has its own set of registers, its own kernel stack, a thread environment block, and a user stack in the address space of its process.
throughput
For disks, the transfer capacity of the disk system.
Time Service
A server cluster resource that maintains consistent time across all nodes.
Time To Live (TTL)
A timer value included in packets sent over TCP/IP-based networks that tells the recipients how long to hold or use the packet or any of its included data before expiring and discarding the packet or data. For DNS, TTL values are used in resource records within a zone to determine how long requesting clients should cache and use this information when it appears in a query response answered by a DNS server for the zone.
ToggleKeys
A Windows feature that beeps when one of the toggle keys (CAPS LOCK, NUM LOCK, or SCROLL LOCK) is turned on or off.
Token Ring
A type of network media that connects clients in a closed ring and uses token passing to allow clients to use the network. See also Fiber Distributed Data Interface (FDDI); LocalTalk.
topology
In Windows operating systems, the relationships among a set of network components. In the context of Active Directory replication, topology refers to the set of connections that domain controllers use to replicate information among themselves. See also domain controller; replication.
transform
A custom script created to customize the behavior of an installation by directly modifying the setup script and without repacking the application.
transitive trust relationship
The trust relationship that inherently exists between Windows 2000 domains in a domain tree or forest, or between trees in a forest, or between forests. When a domain joins an existing forest or domain tree, a transitive trust is automatically established. Transitive trusts are always two-way relationships. See also domain tree; forest.
Transmission Control Protocol/Internet Protocol (TCP/IP)
A set of software networking protocols widely used on the Internet that provide communications across interconnected networks of computers with diverse hardware architectures and operating systems. TCP/IP includes standards for how computers communicate and conventions for connecting networks and routing traffic.
Transport Layer Security (TLS)
A standard protocol that is used to provide secure Web communications on the Internet or intranets. It enables clients to authenticate servers or, optionally, servers to authenticate clients. It also provides a secure channel by encrypting communications for confidentiality.
transport protocol
A protocol that defines how data should be presented to the next receiving layer in the Windows NT and Windows 2000 networking model and packages the data accordingly. The transport protocol passes data to the network adapter driver through the Network Device Interface Specification (NDIS) interface and to the redirector through the Transport Driver Interface (TDI).
Trivial File Transfer Protocol (TFTP)
A protocol that is used by the IntelliMirror server to download the initial files needed to begin the boot or installation process.
trust relationship
A logical relationship established between domains that allows pass-through authentication in which a trusting domain honors the logon authentications of a trusted domain. User accounts and global groups defined in a trusted domain can be given rights and permissions in a trusting domain, even though the user accounts or groups do not exist in the trusting domain's directory. See also authentication; domain; two-way trust relationship.
trusted forest
A forest that is connected to another forest by explicit or transitive trust. See explicit trust relationship, forest, transitive trust.
TTL
See Time To Live.
tunnel
The logical path by which the encapsulated packets travel through the transit internetwork.
tunneling
A method of using an internetwork infrastructure of one protocol to transfer a payload (the frames or packets) of another protocol.
tunneling protocol
A communication standard used to manage tunnels and encapsulate private data. Data that is tunneled must also be encrypted to be a VPN connection. Windows 2000 includes the Point-to-Point Tunneling Protocol (PPTP) and Layer Two Tunneling Protocol (L2TP).
two-way trust relationship
A link between domains in which each domain trusts user accounts in the other domain to use its resources. Users can log on from computers in either domain to the domain that contains their account. See also trust relationship.

U

UDP
See User Datagram Protocol.
unallocated space
Available disk space that is not allocated to any partition, logical drive, or volume. The type of object created on unallocated space depends on the disk type (basic or dynamic). For basic disks, unallocated space outside partitions can be used to create primary or extended partitions. Free space inside an extended partition can be used to create a logical drive. For dynamic disks, unallocated space can be used to create dynamic volumes. Unlike basic disks, the exact disk region used is not selected to create the volume. See also basic disk; dynamic disk; extended partition; logical drive; partition; primary partition; volume.
Unattended Setup
An automated, hands-free method of installing Windows 2000. During installation, Unattended Setup uses an answer file to supply data to Setup instead of requiring that an administrator interactively provide the answers.
UNC name
A full Windows 2000 name of a resource on a network. It conforms to the \\servername\sharename syntax, where servername is the server's name and sharename is the name of the shared resource. UNC names of directories or files can also include the directory path under the share name, with the following syntax: \\servername\sharename\directory\filename. UNC is also called Universal Naming Convention.
unicast
An address that identifies a specific, globally unique host.
Unicode
A fixed-width, 16-bit character-encoding standard capable of representing the letters and characters of the majority of the world's languages. Unicode was developed by a consortium of U.S. computer companies.
uninterruptible power supply (UPS)
A device connected between a computer and a power source to ensure that electrical flow is not interrupted. UPS devices use batteries to keep the computer running for a period of time after a power failure. UPS devices usually provide protection against power surges and brownouts as well.
universal group
A Windows 2000 group only available in native mode that is valid anywhere in the forest. A universal group appears in the global catalog but contains primarily global groups from domains in the forest. This is the simplest form of group and can contain other universal groups, global groups, and users from anywhere in the forest. See also domain local group; forest; global catalog.
Universal Serial Bus (USB)
A bidirectional, isochronous, dynamically attachable serial interface for adding peripheral devices, such as game controllers, serial and parallel ports, and input devices on a single bus.
UNIX
A powerful, multiuser, multitasking operating system initially developed at AT&T Bell Laboratories in 1969 for use on minicomputers. UNIX is considered more portable-that is, less computer-specific-than other operating systems because it is written in C language. Newer versions of UNIX have been developed at the University of California at Berkeley and by AT&T.
user account objects
Objects used to identify a specific user account in Windows NT Server 4.0 or Windows 2000 Server.
User Datagram Protocol (UDP)
A TCP component that offers a connectionless datagram service that guarantees neither delivery nor correct sequencing of delivered packets.
user name
A unique name identifying a user account to Windows 2000. An account's user name must be unique among the other group names and user names within its own domain or workgroup.
user password
The password stored in each user's account. Each user generally has a unique user password and must type that password when logging on or accessing a server.
user profile
A file which contains configuration information for a specific user, such as desktop settings, persistent network connections, and application settings. Each user's preferences are saved to a user profile that Windows NT and Windows 2000 use to configure the desktop each time a user logs on.
user rights
A credential issued to a user by the Key Distribution Center (KDC) when the user logs on. The user must present the TGT to the KDC when requesting session tickets for services. Because a TGT is normally valid for the life of the user's logon session, it is sometimes called a user ticket. See also Kerberos authentication protocol; Key Distribution Center; session ticket.
user ticket
See ticket-granting ticket.
users
A special group that contains all users who have user permissions on the server. When a Macintosh user assigns permissions to everyone, those permissions are given to the groups' users and guests. See also everyone category; guest.
Utility Manager
A function of Windows 2000 that allows administrators to review the status of applications and tools and to customize features more easily.

V

Virtual Circuit (VC)
A point-to-point connection for the transmission of data. This allows greater control of call attributes, such as bandwidth, latency, delay variation, and sequencing.
virtual link
A logical link between a backbone area border router and an area border router that is not connected to the backbone.
virtual memory
The space on the hard disk that Windows 2000 uses as memory. Because of virtual memory, the amount of memory taken from the perspective of a process can be much greater than the actual physical memory in the computer. The operating system does this in a way that is transparent to the application, by paging data that does not fit in physical memory to and from the disk at any given instant.
virtual network
A logical network that exists inside Novell NetWare and NetWare-compatible servers and routers but is not associated with a physical adapter. The virtual network appears to a user as a separate network. On a computer running Windows 2000 Server, programs advertise their location on a virtual network, not a physical network. The internal network number identifies a virtual network inside a computer. See also internal network number; external network number.
virtual private network (VPN)
The extension of a private network that encompasses links across shared or public networks, such as the Internet.
virtual private network connection
A link in which private data is encapsulated and encrypted.
virtual private networking
The act of configuring and creating a virtual private network.
virtual server
In a server cluster, a set of resources, including a Network Name resource and an IP Address resource, that is contained by a resource group. To clients, a virtual server presents the appearance of a system that is running Windows NT Server or Windows 2000 Server.
voice input utilities
A type of speech recognition program that allows users with disabilities to control the computer with their voice instead of a mouse or keyboard.
volume
A portion of a physical disk that functions as though it were a physically separate disk. In My Computer and Windows Explorer, volumes appear as local disks, such as C or D.
volume mount points
New system objects in the internal namespace of Windows 2000 that represent storage volumes in a persistent, robust manner.
volume set
A combination of partitions on a physical disk that appears as one logical drive. See also; fault tolerance; stripe set.
VPN client
A computer that initiates a VPN connection to a VPN server. A VPN client can be an individual computer that obtains a remote access VPN connection or a router that obtains a router-to-router VPN connection.
VPN connection
The portion of the connection in which your data is encrypted.
VPN server
A computer that accepts VPN connections from VPN clients. A VPN server can provide a remote access VPN connection or a router-to-router VPN connection.

W

Web server
A server that provides the ability to develop COM-based applications and to create large sites for the Internet and corporate intranets.
wide area network (WAN)
A communications network connecting geographically separated computers, printers, and other devices. A WAN allows any connected device to interact with any other on the network. See also LAN.
Windows 2000 MultiLanguage Version
A version of Windows 2000 that extends the native language support in Windows 2000 by allowing user interface languages to be changed on a per user basis. This version also minimizes the number of language versions you need to deploy across the network.
Windows 2000 Setup
The program that installs Windows 2000. Also known as Setup, Winnt32.exe, and Winnt.exe.
Windows Installer
A Windows 2000 component that standardizes the way applications are installed on multiple computers by requiring that every application have its own setup file or script.
Windows Internet Name Service (WINS)
A software service that dynamically maps IP addresses to computer names (NetBIOS names). This allows users to access resources by name instead of requiring them to use IP addresses that are difficult to recognize and remember. WINS servers support clients running Windows NT 4.0 and earlier versions of Windows operating systems. See also Domain Name System (DNS).
Windows Management Instrumentation
Microsoft technology used to extend the Desktop Management Task Force (DMTF) Web-based Enterprise Management (WBEM) initiative by representing physical and logical objects that exist in Windows management environments in a consistent and unified manner. WMI is designed to simplify the development of well-integrated management applications, allowing vendors to provide highly efficient, scalable management solutions for enterprise environments.
Windows Sockets (Winsock)
An industry-standard application programming interface (API) used on the Microsoft Windows operating system that provides a two-way, reliable, sequenced, and unduplicated flow of data.
Windows-based terminal
A terminal that uses a Windows operating system.
WinInstall LE
A repackaging tool that comes with Windows 2000 Server.
WINS
See Windows Internet Name Service.
WINS database
The database used to register and resolve computer names to IP addresses on Windows-based networks. The contents of this database are replicated at regular intervals throughout the network. See also push partner, pull partner, replication.
WINS proxy
A computer that listens to name query broadcasts and responds for those names not on the local subnet. The proxy communicates with the name server to resolve names and then caches them for a specific time period. See also Windows Internet Name Service (WINS).

X

X.509 version 3 certificate
Version 3 of the ITU-T recommendation X.509 for syntax and format. This is the standard certificate format used by Windows 2000 certificate-based processes. An X.509 certificate includes the public key and information about the person or entity to whom the certificate is issued, information about the certificate, plus optional information about the certification authority (CA) issuing the certificate. See also certificate; public key.

Z

ZAP (.zap) file
Zero Administration Windows application package file. A text file (similar to an .ini file) that describes how to install an application (which command line to use); the properties of the application (name, version, and language); and what entry points the application should automatically install (for file name extension, CLSID, and ProgID). A .zap file is generally stored in the same location on the network as the setup program it references.
zone
In a DNS database, a zone is a contiguous portion of the DNS tree that is administered as a single separate entity by a DNS server. The zone contains resource records for all the names within the zone. In the Macintosh environment, a logical grouping that simplifies browsing the network for resources, such as servers and printers. It is similar to a domain in Windows 2000 Server networking. See also domain; Domain Name System (DNS); DNS server.
zone transfer
The process by which DNS servers interact to maintain and synchronize authoritative name data. When a DNS server is configured as a secondary server for a zone, it periodically queries the master DNS server configured as its source for the zone. If the version of the zone kept by the master is different than the version on the secondary server, the secondary server will pull zone data from its master DNS server to update zone data. See also full zone transfer (AXFR); incremental zone transfer (IXFR); secondary server; zone.

© 1985-1999 Microsoft Corporation. All rights reserved.


Copywright

Copyright

Information in this document, including URL and other Internet web site references, is subject to change without notice. The example companies, organizations, products, people and events depicted herein are fictitious. No association with any real company, organization, product, person or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 1999 Microsoft Corporation. All rights reserved.

Microsoft, MS-DOS, Windows, Windows NT, and other names of Microsoft products and/or services referenced herein are either registered trademarks or trademarks of Microsoft Corporation in the U.S.A. and/or other countries.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.

Any RFC excerpts are subject to the following statement:

Copyright © The Internet Society (1999). All Rights Reserved. This document and translations of it may be copied and furnished to others, and derivative works that comment on or otherwise explain it or assist in its implementation may be prepared, copied, published and distributed, in whole or in part, without restriction of any kind, provided that the above copyright notice and this paragraph are included on all such copies and derivative works. However, this document itself may not be modified in any way, such as by removing the copyright notice or references to the Internet Society or other Internet organizations, except as needed for the purpose of developing Internet standards in which case the procedures for copyrights defined in the Internet Standards process must be followed, or as required to translate it into languages other than English. The limited permissions granted above are perpetual and will not be revoked by the Internet Society or its successors or assigns. This document and the information contained herein is provided on an "AS IS" basis and THE INTERNET SOCIETY AND THE INTERNET ENGINEERING TASK FORCE DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY WARRANTY THAT THE USE OF THE INFORMATION HEREIN WILL NOT INFRINGE ANY RIGHTS OR ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.